My favorites | Sign in
v8
Project Home Downloads Wiki Issues Source Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 631: Build failure on Mac OS X 10.6.2
6 people starred this issue and may be notified of changes. Back to list
Status:  Invalid
Owner:  ----
Closed:  Apr 2013


Sign in to add a comment
 
Reported by Myles.By...@gmail.com, Mar 3, 2010
$ scons --version
SCons by Steven Knight et al.:
	script: v1.2.0.d20090919.r4369[MODIFIED], 2009/09/19 16:58:54, by scons on scons-dev

$gcc --version
i686-apple-darwin10-gcc-4.2.1 (GCC) 4.2.1 (Apple Inc. build 5646) (dot 1)

$ scons
scons: Reading SConscript files ...
scons: done reading SConscript files.
scons: Building targets ...
gcc -o obj/release/dtoa-config.o -c -Werror -Wno-uninitialized -m32 -O3 -fomit-frame-
pointer -fdata-sections -ffunction-sections -ansi -mmacosx-version-min=10.4 -
DV8_TARGET_ARCH_IA32 -DENABLE_DEBUGGER_SUPPORT -DV8_NATIVE_REGEXP -
DENABLE_LOGGING_AND_PROFILING -Isrc src/dtoa-config.c
i686-apple-darwin10-gcc-4.2.1: src/dtoa-config.c: No such file or directory
i686-apple-darwin10-gcc-4.2.1: no input files
scons: *** [obj/release/dtoa-config.o] Error 1
scons: building terminated because of errors.

Looks like scons is somehow in the wrong working directory, because if I run:

gcc -o obj/release/dtoa-config.o -c -Werror -Wno-uninitialized -m32 -O3 -fomit-frame-
pointer -fdata-sections -ffunction-sections -ansi -mmacosx-version-min=10.4 -
DV8_TARGET_ARCH_IA32 -DENABLE_DEBUGGER_SUPPORT -DV8_NATIVE_REGEXP -
DENABLE_LOGGING_AND_PROFILING -Isrc src/dtoa-config.c

It compiles obj/release/dtoa-config.o just fine
Mar 7, 2010
#1 ben%hosk...@gtempaccount.com
I'm having the same issue. Like Myles, I can build dtoa-config.c manually. Running OS X 10.6.2.
Mar 8, 2010
#2 iandenni...@gmail.com
I am also having the same issue.  I can confirm that this fails to build with the current trunk, 
revision 4055.

$ svn info
Path: .
URL: http://v8.googlecode.com/svn/trunk
Repository Root: http://v8.googlecode.com/svn
Repository UUID: ce2b1a6d-e550-0410-aec6-3dcde31c8c00
Revision: 4055
Node Kind: directory
Schedule: normal
Last Changed Author: ager@chromium.org
Last Changed Rev: 4030
Last Changed Date: 2010-03-05 03:56:14 -0500 (Fri, 05 Mar 2010)

Like Ben, I am using OS X 10.6.2 on a 1st gen MBP, 32-bit.  Just like the others, I can build dtoa-
config.c manually.  I am using case-sensitive HFS+.  

I'd like to put forth the following assertions, each of which is unverified:

1. people using case insensitive HFS+ do not see this error (can someone verify this?)
2. dtoa-config.c fails to build because its CWD or parent dir has been blown away
3. scons moves or removes a path that differs from another path only in terms of which letters 
are capitalized (a theory - can someone verify this?)

If someone knows scons well enough to test these assertions, I think it will shed light on the 
source of this scons build error.
Mar 8, 2010
#3 ben%hosk...@gtempaccount.com
> I'd like to put forth the following assertions, each of which is unverified:
> 1. people using case insensitive HFS+ do not see this error (can someone verify this?)

I'm using case-insensitive HFS+ (the default), so it's not a case-related issue.
Mar 8, 2010
#4 Myles.By...@gmail.com
case-insensitive here too
Mar 8, 2010
#5 iandenni...@gmail.com
Thanks - sounds like case sensitivity has nothing to do with it.
Mar 15, 2010
#6 ben%hosk...@gtempaccount.com
It's a permissions issue. Running `sudo make` works.

Reference: http://twitter.com/geoffreyd/status/10555199014
Mar 16, 2010
#7 iandenni...@gmail.com
Yep - I can confirm that it builds beyond the dtoa-config.c error, with 'sudo scons'  
Good find!
Apr 9, 2010
#8 Myles.By...@gmail.com
thanks!
Aug 16, 2010
#9 simon.st...@gmail.com
Is there a workaround to build without superuser privs?
Apr 2, 2013
Project Member #10 yangguo@chromium.org
doesn't seem to be relevant anymore.
Status: Invalid
Sign in to add a comment

Powered by Google Project Hosting