My favorites | Sign in
Project Home Downloads Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 46: Number of Comments includes Number of Trackbacks
6 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 40
Owner:  chris.gossmann@googlemail.com
Closed:  Jan 2012


Sign in to add a comment
 
Project Member Reported by chris.gossmann@googlemail.com, Jun 19, 2009
http://themeshaper.com/forums/topic/separating-trackbacks-and-comments

"Another related issue is that my home page lists x comments, where x is
the number of trackbacks + the number of comments. When there is 1
trackback and zero comments, it is confusing as it will say 1 comment, the
user clicks on comments, and then sees no comments. Someone reported it to
me as a bug last night.

Desired behavior: Number of comments should list number of comments alone
(don't include trackbacks in the total)"


Jul 3, 2009
#1 justinta...@gmail.com
Maybe instead of "1 Comment," "2 Comments," and so on, it should read "1 Response" or
"2 Responses," which would be true because "responses" can be both pings and comments.
Apr 20, 2010
#2 arne.fra...@gmail.com
since WordPress counts Trackbacks and Pingbacks as types of comments, there does not
seem to be a way to get the number of comments alone from the WordPress core.
This would probably be worth a feature request for the WordPress core.

Best regards, Arne
Jan 22, 2012
Project Member #5 eugene.m...@gmail.com
(No comment was entered for this change.)
Labels: -WP-Comments Comments
Jan 26, 2012
Project Member #6 eugene.m...@gmail.com
This does bug does not paper to exist any more.

Testing  issue 40  against WP 3.x cannot reproduce the behavior stated in this ticket. Possibly was dealt with in WP over time? 

This appear not to need fixing so wontfix 
Status: WontFix
Jan 26, 2012
Project Member #7 eugene.m...@gmail.com
Oops too fast... This does exist in pagination of comments / trackbacks.

Gonna merge into 40. There's a better chance to address it all there. 
Status: Duplicate
Mergedinto: 40
Sign in to add a comment

Powered by Google Project Hosting