My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 419: Major regression: /trunk/include missing
1 person starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 416
Owner:  ----
Closed:  Jan 2011


Sign in to add a comment
 
Reported by arvi...@gmail.com, Dec 29, 2010
When building Tesseract on most recent revision (r549) the following error occurs:

coutln.cpp:26:24: error: allheaders.h: No such file or directory
coutln.cpp: In member function ‘void C_OUTLINE::render(int, int, Pix*)’:
coutln.cpp:632: error: ‘PIX_DST’ was not declared in this scope
coutln.cpp:632: error: ‘PIX_NOT’ was not declared in this scope
coutln.cpp:632: error: ‘pixRasterop’ was not declared in this scope
coutln.cpp:635: error: ‘PIX_DST’ was not declared in this scope
coutln.cpp:635: error: ‘PIX_NOT’ was not declared in this scope
coutln.cpp:635: error: ‘pixRasterop’ was not declared in this scope

Turns out that the whole /trunk/include dir was deleted in r474 which
https://code.google.com/p/tesseract-ocr/source/detail?r=474
and indeed, Tess builds successfully on r473

From the comments it appears that the developer deleting /include was doing adaptations for Windows and may have these dirs stored somewhere else, which explains how this wasn't detected earlier?

So, it appears that the solution is to simply reinsert /include. If I knew anything at all about Tesseract's source, I might have done it myself ;-)

OSX 10.6.4 on 13" MBP 2010, gcc version 4.2.1 (Apple Inc. build 5664)
Jan 2, 2011
Project Member #2 zde...@gmail.com
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 416
Sign in to add a comment

Powered by Google Project Hosting