My favorites | Sign in
Project Home Downloads Wiki Issues Source
Search
for
SpockVersionsAndDependencies  
Spock versions and their compatible Groovy/JUnit/Grails/etc. versions.
Updated Oct 4, 2012 by pnied...@gmail.com

Spock requires Java SE 5.0 or higher. Make sure to pick a Spock version that matches the Groovy version you would like to use.

Release Versions

Releases are available from http://repo1.maven.org/maven2/ (group ID: org.spockframework).

Spock version Groovy version JUnit version Grails version Spring version
0.5-groovy-1.6 1.6.1-1.6.x 4.7-4.x 1.2.0-1.2.x 2.5.0-3.x
0.5-groovy-1.7 1.7.0-1.7.x 4.7-4.x 1.3.0-1.3.x 2.5.0-3.x
0.6-groovy-1.7 1.7.0-1.7.x 4.7-4.x 1.3.0-1.3.x 2.5.0-3.x
0.6-groovy-1.8 1.8.1-1.8.x 4.7-4.x 2.0-2.x 2.5.0-3.x
0.7-groovy-1.8 1.8.1-1.8.x 4.7-4.x 2.0-2.x 2.5.0-3.x
0.7-groovy-2.0 2.0.0 -2.x.x 4.7-4.x 2.2-2.x 2.5.0-3.x

Note: Grails version applies to Grails plugin. Spring version applies to SpringExtension.

Snapshot Versions

Snapshots are available from http://oss.sonatype.org/content/repositories/snapshots/ (group ID: org.spockframework).

Spock version Groovy version JUnit version Grails version Spring version
1.0-groovy-1.8-SNAPSHOT 1.8.1 - 1.8.x 4.7-4.x 2.0-2.x 2.5.0-3.x
1.0-groovy-2.0-SNAPSHOT 2.0.0 - 2.x.x 4.7-4.x 2.2-2.x 2.5.0-3.x

Note: Grails version applies to Grails plugin. Spring version applies to SpringExtension.

Comment by tim....@gmail.com, Feb 29, 2012

I looked at the provided release repos and could only find versions 0.4-groovy-1.6/, 0.4-groovy-1.7/, 0.5-groovy-1.7/, and 0.5-groovy-1.8/. Is there a typo here?

Comment by project member pnied...@gmail.com, Feb 29, 2012

The information has already been updated for the 0.6 release (which is imminent).

Comment by ambarsek...@gmail.com, Jul 26, 2012

Which Spock release (not snapshot) will support Groovy 2.0.x, and when will it be released?

Comment by project member pnied...@gmail.com, Jul 26, 2012

0.7, and when I get to it. 0.7 is largely done, but finalizing a release takes time, and I have a demanding day job. You can actively help by trying the latest 0.7 snapshot and reporting back how it works for you.

Comment by ganesh.gowtham, Jul 11, 2013

Hi,

I followed steps from https://github.com/breskeby/GradleSite/blob/master/README.markdown

fail to get it run. ( i generated the local jar and referred in another project in another project like )

buildscript {

repositories {
mavenCentral() mavenLocal()
} dependencies {
// classpath 'com.breskeby:GradleSite?:0.1-SNAPSHOT'
compile files('C:/Users/gowtham/Downloads/GradleSite?-master/GradleSite?-master/build/libs/GradleSite?-master-0.1-SNAPSHOT.jar')
}
}

i am getting following exception while i was generating "gradle site"

Where: Build file 'C:\Users\gowtham\workspace\Groovy\build.gradle' line: 8

What went wrong: A problem occurred evaluating root project 'Groovy'. > No signature of method: org.gradle.api.internal.artifacts.dsl.dependencies.Def aultDependencyHandler.compile() is applicable for argument types: (org.gradle.ap i.internal.file.collections.DefaultConfigurableFileCollection?) values: [file col lection] Possible solutions: module(java.lang.Object)

Please help me where i am going wrong

Thanks Ganesh gowtham http://ganesh.gowtham.googlepages.com

Comment by rupendra...@optimusinfo.com, Aug 29, 2013

I am getting this issue while running: Grails version 2.1.1

Groovy:Unexpected problem with AST transform: The Spock compiler plugin cannot execute because Spock 0.7.0-groovy-1.8 is not compatible with Groovy 2.0.7. For more information, see http://versioninfo.spockframework.org

Comment by malcolm....@googlemail.com, Jul 31, 2014

I'm just getting started with gradle, and I've tried to build several open source projects like the gradle cargo plugin from source.

I kept getting :

groovy.lang.GroovyRuntimeException?: Conflicting module versions. Module [groovy-all is loaded in version 2.3.3 and you are trying to load version 2.0.5

during testing. The work-arround seems to be to explictly exclude groovy from the spock dependancy like:

testCompile ('org.spockframework:spock-core:0.7-groovy-2.0') {
exclude group: 'org.codehaus.groovy'
}

It seems bizarre to me that a framework like this specifies a maximum version of a compiler. My gradle installation comes with 2.3.3 (which still matches 2.x.x). Doesn't groovy observe backward compatibility?

Comment by project member pnied...@gmail.com, Jul 31, 2014

Please direct all questions to http://forum.spockframework.org.


Sign in to add a comment
Powered by Google Project Hosting