My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 142: Tests failing on non-US system
1 person starred this issue and may be notified of changes. Back to list
Status:  Verified
Owner:  ----
Closed:  May 2010


Sign in to add a comment
 
Reported by moritz.u...@haw-hamburg.de, May 10, 2010
What steps will reproduce the problem?
1. run "mvn test"

What is the expected output? What do you see instead?

org.specs.form.fieldSpec fails because of different decimal format symbols ("," vs ".")

What version of the product are you using? On what operating system?

Scala version 2.8.0.RC2 (Java HotSpot(TM) 64-Bit Server VM, Java 1.6.0_20), Mac OS X 10.6.3 de_DE


Please provide any additional information below.

Either the spec has to be adjusted to take care of localized decimal formatting symbols or the default 
formatting has to be done in US locale. As you normally specify your specs in english I would suggest the latter 
alternative. A patch fixing this issue is attached.

format-fix.diff
871 bytes   View   Download
May 10, 2010
Project Member #1 etorrebo...@gmail.com
Thanks for creating an issue and sending a patch. I've known about that for a while and 
it's been on my to do list. Now I have no excuse not to fix it, so that's done.
Status: Fixed
May 26, 2010
Project Member #2 etorrebo...@gmail.com
(No comment was entered for this change.)
Labels: Milestone-1.6.5
Aug 1, 2010
Project Member #3 etorrebo...@gmail.com
(No comment was entered for this change.)
Status: Verified
Sign in to add a comment

Powered by Google Project Hosting