My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 520: Using a timeouted keyword with wrong number of arguments causes `FrameworkError`
  Back to list
Status:  Done
Owner:  jpran...@gmail.com
Closed:  Apr 2010


Sign in to add a comment
 
Project Member Reported by jpran...@gmail.com, Mar 31, 2010
The executed keyword will fail normally, but the possible keywords
afterwards will fail with FrameworkError. The simplest example
demonstrating this is below.

*** Test Cases ***
Test
    KW  wrong args
    [Teardown]  No Operation

*** Keywords ***
KW  [Timeout]  1 seconds
    No Operation

It's possible to get the test fail outside teardown using `Run Keyword And
Ignore/Expect Error`. In these cases the original syntax error is also
hidden which makes debugging the problem harder. This kind of errors
shouldn't actually be hidden, but that's another issue.


Mar 31, 2010
Project Member #1 jpran...@gmail.com
(No comment was entered for this change.)
Status: Started
Owner: jprantan
Apr 13, 2010
Project Member #2 jpran...@gmail.com
Fixed in r2951 and added tests in r2952.
Status: Done
May 6, 2010
Project Member #3 jussi.ao...@gmail.com
This issue is included in RF 2.5 alpha 1.
Labels: alpha1
May 6, 2010
Project Member #4 pekka.klarck
(No comment was entered for this change.)
Summary: Using a timeouted keyword with wrong number of arguments causes `FrameworkError`
Sign in to add a comment

Powered by Google Project Hosting