My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 217: wash command wont work .
15 people starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by lunglung...@gmail.com, Feb 4, 2012
A few things to consider before submitting an issue:

0. We write documentation for a reason, if you have not read it and are
having problems with Reaver these pages are required reading before
submitting an issue:
https://code.google.com/p/reaver-wps/wiki/HintsAndTips
https://code.google.com/p/reaver-wps/wiki/README
https://code.google.com/p/reaver-wps/wiki/FAQ
https://code.google.com/p/reaver-wps/wiki/SupportedWirelessDrivers
1. Reaver will only work if your card is in monitor mode.  If you do not
know what monitor mode is then you should learn more about 802.11 hacking
in linux before using Reaver.
2. Using Reaver against access points you do not own or have permission to
attack is illegal.  If you cannot answer basic questions (i.e. model
number, distance away, etc) about the device you are attacking then do not
post your issue here.  We will not help you break the law.
3. Please look through issues that have already been posted and make sure
your question has not already been asked here: https://code.google.com/p
/reaver-wps/issues/list
4. Often times we need packet captures of mon0 while Reaver is running to
troubleshoot the issue (tcpdump -i mon0 -s0 -w broken_reaver.pcap).  Issue
reports with pcap files attached will receive more serious consideration.

Answer the following questions for every issue submitted:

0. What version of Reaver are you using?  (Only defects against the latest
version will be considered.)
reaver 1.4
1. What operating system are you using (Linux is the only supported OS)?
back track 5
2. Is your wireless card in monitor mode (yes/no)?
yes
3. What is the signal strength of the Access Point you are trying to crack?
yes
4. What is the manufacturer and model # of the device you are trying to
crack?
dlink
5. What is the entire command line string you are supplying to reaver?

svn checkout http://reaver-wps.googlecode.com/svn/trunk/

ls

cd trunk/

ls

cd src/

ls

./configure

make install

ls

./wash
airmon-ng start wlan0
airodump-ng mon0
reaver-i mon0 -b (BSSID)

6. Please describe what you think the issue is.
./wash command wont work, and a message display 

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

when i type command '' airmon-ng start wlan0 

how to solve those problem ?

7. Paste the output from Reaver below.

root@root:~/trunk/src# make install
rm -f /usr/local/bin/reaver /usr/local/bin/wash /usr/local/bin/walsh
if [ ! -d /usr/local/etc/reaver ]; then mkdir -p /usr/local/etc/reaver; fi
if [ ! -e /usr/local/etc/reaver/reaver.db ]; then cp reaver.db /usr/local/etc/reaver/reaver.db && chmod -R a+rw /usr/local/etc/reaver; fi
if [ -e wash ]; then cp wash /usr/local/bin/wash; fi
if [ -e reaver ]; then cp reaver /usr/local/bin/reaver; fi
root@root:~/trunk/src# ./wash
bash: ./wash: No such file or directory
root@root:~/trunk/src# .wash
.wash: command not found
root@root:~/trunk/src#  ./wash
bash: ./wash: No such file or directory
root@root:~/trunk/src# airmon-ng start wlan0


Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID	Name
2710	dhclient3
2711	dhclient3
2799	dhclient
Process with PID 2711 (dhclient3) is running on interface wlan0


Interface	Chipset		Driver

wlan0		Atheros AR9280	ath9k - [phy0]
				(monitor mode enabled on mon0)

Feb 4, 2012
#1 AdiR...@gmail.com
simply type wash without dot or something else...
Feb 4, 2012
#2 lunglung...@gmail.com
but after i type wash command , it will display command at below .

root@root:~/trunk/src# wash
No command 'wash' found, did you mean:
 Command 'ash' from package 'ash' (universe)
 Command 'bash' from package 'bash' (main)
 Command 'dash' from package 'dash' (main)
 Command 'kash' from package 'kanif' (universe)
 Command 'wish' from package 'tk8.3' (universe)
 Command 'wish' from package 'tk8.4' (main)
 Command 'wish' from package 'tk8.5' (main)
 Command 'wish' from package 'tk' (main)
 Command 'nash' from package 'lrslib' (universe)
 Command 'sash' from package 'sash' (universe)
wash: command not found
root@root:~/trunk/src# 

what mean ? then what next ? 

Feb 4, 2012
#3 lulzse...@gmail.com
mb you forgot about 'make' command before 'make install'
Feb 4, 2012
#4 lunglung...@gmail.com
oic... can u let me know the completely command from install the reaver process until the end . thx =0

btw what about this msg meaning ?

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!


Feb 4, 2012
#5 hurenhan...@googlemail.com
https://code.google.com/p/reaver-wps/wiki/README

INSTALLATION

    Reaver is only supported on the Linux platform, requires the libpcap and libsqlite3 libraries, and can be built and installed by running: 

                $ ./configure
                $ make
                # make install
Feb 4, 2012
#6 lunglung...@gmail.com
i using live boot usb pendrive , so i need download reaver everytime when i needed.
so everytime i type all those command shown as below :


svn checkout http://reaver-wps.googlecode.com/svn/trunk/
ls
cd trunk/
ls
cd src/
ls
./configure
make 
make install
ls
wash <--------- ( but everytime the process until here cant continue , the error msg just what i posted just now)

airmon-ng 
airmon-ng start wlan0
reaver -i mon0 -b (BSSID)

IS THAT ALL CORRECT ?

Feb 4, 2012
#7 lulzse...@gmail.com
run 'wash' on time, just for choose BSSID, then kill it proc and run 'reaver'.
and before run 'wash' exec 'airmon-ng srart wlan0' (one time for all your session with LiveCD)

...
...
make install
airmon-ng start wlan0
wash -i mon0 (here we take BSSID with max level pwr priority)
reaver -i mon0 -b BSSID -vv
Feb 5, 2012
#8 lunglung...@gmail.com
woo... thx dude.... it's work =D
Feb 13, 2012
#9 joshuavi...@gmail.com
It doesn't work with installing via apt-get in Backtrack 5.
Feb 17, 2012
#10 leacocks...@gmail.com
Hello there, im trying to make a script, that make it easy to crack wps, could you please save me the time and create one, it would be like this, the code will ask various questions such as if the wifi card plugged in and it will scan the wireless network and show the vulnerable clients, then it would create an array, the output in the terminal window will ask you which network would you obtain, you will type in 0 1 2 3 etc depends on the array after, it will start cracking it for you, when it has been completed it will save the keys information into a folder or database, if you can use this into metasploit framework or create the code into python that would be fucking asum, as well if you can generate this code into a linksys router that would be sick! what about an AIROS the are unlimited possibilities 
Apr 17, 2012
#11 MrCra...@gmail.com
Hi to all, I have Back Track 5 R2, it has reaver in it already, no installing needed! i to get the

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

message, i just type: airmon-ng check kill

this solves that problem, Now my problem.

wash -i mon0/wlan0(either) doesn't work, all i get is an error scrolling sayin

found bad FCS packet, skipping,
found bad FCS packet, skipping,
found bad FCS packet, skipping, and so-on

then when i use reaver i can authenticate and try pin 12345670 but then it keeps repeating that same pin, eventually starts to say period timed out or something similar, ideas anyone??
May 7, 2012
#12 tawfikch...@yahoo.com
error: pcap library not found!
this problem 
 pleas tell me the soulition :)
when ./configure  ????






May 7, 2012
#13 lulzse...@gmail.com
try install libsqlite3-dev
Jul 25, 2012
#14 attil...@gmail.com
root@bt:~# wash -i mon0

Wash v1.4 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

BSSID                  Channel       RSSI       WPS Version       WPS Locked        ESSID
---------------------------------------------------------------------------------------------------------------
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
[!] Found packet with bad FCS, skipping...
^C
root@bt:~# 


Anybody any idea what might be wrong?


Jul 25, 2012
#15 lulzse...@gmail.com
just run wash with -C arg.
wash -i mon0 -C
Aug 5, 2012
#16 harikar...@gmail.com
is any reaver command i can run if i already have wps pin and want to convert it to WPA PSK???
Dec 30, 2012
#17 johny...@gmail.com
Hi to all, I have Back Track 5 R2, it has reaver in it already, no installing needed! i to get the

Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

message, i just type: airmon-ng check kill

this solves that problem, Now my problem.

wash -i mon0/wlan0(either) doesn't work, all i get is an error scrolling sayin

found bad FCS packet, skipping,
found bad FCS packet, skipping,
found bad FCS packet, skipping, and so-on

then when i use reaver i can authenticate and try pin 12345670 but then it keeps repeating that same pin, eventually starts to say period timed out or something similar, ideas anyone??
-------------------------------------------------------------
I know I had this same problem but I found out why.

You are probably trying to run the command with you built-in wireless adapter which was what I did and if you type in airmon-ng as root you will see your chipset model and mine is a Intel.
Intel chipsets for some reason times out and keeps of repeating the same PIN while using reaver. What I did was. I bought an external antena from ALPHA that had a realtek chipset. Once I plugged it in and ran the reaver command once again. It worked like a charm!!


Apr 20, 2013
#18 dahraiak...@gmail.com
root@bt:~/trunk/src# ./wash
bash: ./wash: No such file or directory
root@bt:~/trunk/src# airmon-ng start wlan0


Found 3 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID	Name
2130	dhclient3
2224	dhclient
2246	dhclient


Interface	Chipset		Driver


root@bt:~/trunk/src# airodump-ng mon0
Interface mon0: 
ioctl(SIOCGIFINDEX) failed: No such device
root@bt:~/trunk/src# reaver-i mon0 -b (BSSID)
bash: syntax error near unexpected token `('
root@bt:~/trunk/src# ./wash command wont work, and a message display
bash: ./wash: No such file or directory
root@bt:~/trunk/src# airmon-ng start wlan0 


please help
May 5, 2014
#19 olegfila...@gmail.com
wash not scanning at all in ubuntu 14.04. immediately stop after starting. wifi drivers patched, working properly with wepcrackGUI.


root@ua:/home/ua# ^C
root@ua:/home/ua# sudo wash -i mon0 -C

Wash v1.4 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

BSSID                  Channel       RSSI       WPS Version       WPS Locked        ESSID
---------------------------------------------------------------------------------------------------------------



root@ua:/home/ua# 
May 11, 2014
#20 kib0rg1...@gmail.com
The reason why reaver & wash not work in Ubuntu 14.04 is the new version of libpcap & libpcap-dev, which is probably have some bug or incompatibility.

You can downgrade to version from Ubuntu 13.10:

wget http://mirrors.kernel.org/ubuntu/pool/main/libp/libpcap/libpcap0.8_1.4.0-2_amd64.deb http://mirrors.kernel.org/ubuntu/pool/main/libp/libpcap/libpcap0.8-dev_1.4.0-2_amd64.deb
sudo dpkg -i libpcap0.8_1.4.0-2_amd64.deb libpcap0.8-dev_1.4.0-2_amd64.deb
Jun 11, 2014
#21 shakeyma...@gmail.com
On arch linux this was what worked for me...
1) Use 'pacman -Rdd libpcap' if you already have it installed this will remove it.
2) Then get the 1.3.0 libpcap from http://www.tcpdump.org/release/libpcap-1.3.0.tar.gz.
3) Unpack it and cd into it and run './configure --prefix=/usr'.
4) 'make'
5) 'make install'

After that rebuild reaver and wash.
Not sure the effect this will have on programs which may rely on newest version like say tcpdump and wireshark but I'm sure I'll find out soon enough. Good luck.
Sign in to add a comment

Powered by Google Project Hosting