My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 210: Pyicq-t after portupgrade -aRr
1 person starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by deathsta...@gmail.com, Feb 28, 2011


After updating the software on a FreeBSD server operations ceased to be visible in the services of my Jabber server, I tried to install on svezheustannovlennoy system - the same thing starts, but the network does not come out, and in the services it net.V What is it? Version of a package dependency is attached. 
deathstar# /usr/local/etc/rc.d/jabber-pyicq-transport status
jabber_pyicq is running as pid 5691.

deathstar # pkg_info-r jabber-pyicq-transport-0.8.1.5, 1 
Information for jabber-pyicq-transport-0.8.1.5, 1: 

Depends on: 
Dependency: renderproto-0.11 
Dependency: kbproto-1.0.5 
Dependency: expat-2.0.1_1 
Dependency: tcl-modules-8.5.9 
Dependency: tcl-8.5.9 
Dependency: python26-2.6.6 
Dependency: py26-openssl-0.11 
Dependency: jpeg-8_3 
Dependency: py26-setuptools-0.6c11_1 
Dependency: py26-zopeInterface-3.6.1 
Dependency: py26-twistedCore-10.1.0 
Dependency: py26-twistedWords-10.1.0 
Dependency: py26-twistedWeb-10.1.0 
Dependency: pkg-config-0.25_1 
Dependency: xproto-7.0.16 
Dependency: libXdmcp-1.0.3 
Dependency: libXau-1.0.6 
Dependency: freetype2-2.4.4 
Dependency: fontconfig-2.8.0, 1 
Dependency: libpthread-stubs-0.3_3 
Dependency: libxcb-1.7 
Dependency: libX11-1.3.6, 1 
Dependency: libXrender-0.9.5 
Dependency: libXft-2.1.14 
Dependency: tk-8.5.9 
Dependency: py26-tkinter-2.6.6_3 
Dependency: py26-imaging-1.1.7 
Dependency: libiconv-1.13.1_1 
Dependency: ejabberd-2.1.5


Oct 12, 2011
#1 petr999@gmail.com
Same happens here for me.
The last seen from 'ejabberdctl live' is:

    I(<0.513.0>:ejabberd_service:124) : ({socket_state,gen_tcp,#Port<0.4367>,<0.512.0>}) External service connected

And no any messages about 'Route registered'.
The last seen from 'pyicqt -D' is:

    Starting factory <twisted.words.protocols.jabber.xmlstream.XmlStreamFactory object at 0x2841d9cc>

After stopping pyicqt ejabberd treats this as:

    I(<0.513.0>:ejabberd_service:368) : terminated: normal

It doesn't seem enough to me to know if that was the reason. The client sees that as '503 service unavailable' and no service to be seen in Discovery.

Shall we downgrade pyicqt? Which version is known as the earliest and without security issues?

Thank you.
Sign in to add a comment

Powered by Google Project Hosting