My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 7: Selecting MUT preference in Pmount cripples Pmount function
1 person starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by otrop...@gmail.com, Nov 1, 2009
What steps will reproduce the problem?
1. choose Pmount/preferences/MUT
2. close Pmount menu
3. click on Pmount desktop icon or select Pmount from Start menu


What is the expected output? 

Pmount menu should open on desktop, showing types of storage devices
available, and allowing them to be mounted, unmounted, and their capacity
and unused space to be checked

What do you see instead?

The yellow "wait" popup flashes on the desktop briefly, but the Pmount menu
doesn't open. Hard drives can still be accessed by clicking on their
desktop icons, but not USB storage devices, even if they already have an
icon on the desktop.

It's impossible to read or write to a Flash Card in a USB reader, even if
it's inserted at boot-up. If booting from a USB flash card, it's possible
to view the host partition, as it's mounted automatically. Have not tried
writing to it.

To eliminate the possibility of corruption of the 2fs file being the cause,
have reproduced this with a clean boot from Live-CD without loading any 2fs
file. 


What version of the product are you using? On what operating system?

Puppy Linux 4.2.1 

Please provide any additional information below.

Puppy Forum member MinHundHettePerro suggested a means of recovery:

deleting the file /root/.pmountengine

and it works. However, the MUT preference option definitely does not...


Nov 8, 2009
Project Member #1 brad.ope...@gmail.com
it appears to be looking for mut2 - I don't have an external device handy to test it
but perhaps making a symlink for /usr/sbin/mut2 to /usr/sbin/mut will fix it.
Nov 8, 2009
#2 otrop...@gmail.com
Final-Recipient: RFC822; puppy-development@googlecode.com
Action: failed
Status: 5.4.6
Diagnostic-Code: SMTP; 554 5.4.6 Too many hops
Last-Attempt-Date: Sun, 8 Nov 2009 23:11:23 GMT


---------- Forwarded message ----------
From: otro pogo <otropogo@gmail.com>
To: puppy-development@googlecode.com
Date: Sun, 8 Nov 2009 16:09:58 -0700
Subject: Re: Issue 7 in puppy-development: Selecting MUT preference in Pmount
cripples Pmount function
Since posting the bug here I've discussed the issue in murga-linux with Jesse, the
author of MUT. He suggested a test the results of which I posted there:

http://www.murga-linux.com/puppy/viewtopic.php?t=48452&start=15

(second page)

Perhaps a look at it might help.

The behaviour of Pmount when the MUT box is ticked has now changed. Outwardly,
nothing happens. That is, Pmount still functions normally, and the Pmount window is
unchanged after the MUT option is elected.

BUT, on my system, when MUT is selected, it takes Pmount 30 seconds from the moment
its icon is clicked to open it's window on the desktop and become operational. When
the MUT box is unchecked, this process completes in only 3 seconds.

NB: I tried to reply via gmail, and my message bounced as indicated above
Nov 13, 2009
#3 otrop...@gmail.com
Have learned that somehow in upgrading from Puppy 4.2.1 to 4.3.1, the desktop menus
got corrupted, with tabs from the earlier version not included in the later one
remaining on the 4.3.1 desktop, but not functional, and items from the stock 4.3.1
missing from the menu.

So possibly Pmount/MUT was also corrupted in this upgrade?
Sign in to add a comment

Powered by Google Project Hosting