My favorites | Sign in
Project Home Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 77: java.lang.OutOfMemoryError "Force close" error in applications - N12 UMay (2.3.4)
2 people starred this issue and may be notified of changes. Back to list
Status:  New
Owner:  ----


Sign in to add a comment
 
Reported by chris%al...@gtempaccount.com, May 9, 2011
What steps will reproduce the problem?
1. Download "Words with Friends Free" from Market
2. Play a move in a game and submit, skip advertisement
3. Go "back" to game list and enter another game.  Force Close message will appear and OOME will show in logcat

OR

1. Download "Words with Friends Free" from Market
2. Open Words with Friends and open a game where you have a wildcard tile
3. Place wildcard tile onto board in game.  Force Close message will appear and OOME will show in logcat

OR

Other applications will also fail at different points, also showing OOME in logs.

What is the expected output? What do you see instead?
Expect application to perform requested action.  Applications consistently crashing.  Example application (Words with Friends Free) was working on older (06) kernel and N11 combo.

What is your device, RootFS, Multiboot and kernel versions?
Nokia N900, Multiboot, power46-wl1 kernel + 2.6.28.NIT.07_rc3 kernel, N12 UMay (2.3.4)

What was installation method?
Fresh install, power kernel + nitdroid-installer + N12 untar to eMMC + dpkg NITDroid kernel.

Please provide any additional information below.
Logcat log provided from "Words with Friends Free" crash.

logcat2.txt
61.3 KB   View   Download
May 9, 2011
#1 chris%al...@gtempaccount.com
Have tried enabling swap also with no luck, in default.prop:
persist.swap.swappiness=1
May 9, 2011
Project Member #2 alexey.r...@gmail.com
Work for me. Ob both devices - N12/N900 and CM6/G1.
Labels: -Priority-Medium Priority-Low
May 9, 2011
#3 chris%al...@gtempaccount.com
This has now been reproduced on two devices, both N12/07rc3/N900.  Memory usage is full each time, also tried setting persist.swap.swappiness=60, however executing 'free' shows the swap size at 0.  Memory shows as close to full (~4000 free).
May 14, 2011
#4 ThugThra...@gmail.com
I have basically identical issue on a Droid X, kernel 2.6.32.9-g55626e1, Apex 1.4.1
Nov 26, 2011
#5 ch...@alphastara.com.au
Fixed:

1. Boot into Maemo
2. Open X-Term (Ctrl+X)
3. Run 'vi /home/system/build.prop'
4. Press i to change to edit/insert mode
5. At the end of the file, add the following line:
dalvik.vm.heapsize=32m
6. Press 'esc', write ':wq'
7. Boot back into Nitdroid and you should be sweet
Sign in to add a comment

Powered by Google Project Hosting