My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 2277: Offline Khan Academy r953 does not run under Windows 7
3 people starred this issue and may be notified of changes. Back to list
Status:  Accepted
Owner:  ----


Sign in to add a comment
 
Reported by Mike...@gmail.com, Jan 24, 2011
What were you trying to do when the problem occurred?
-- Per instructions, I downloaded r953, unzipped it and run
the run.bat on an XP machine. It runs well. Doing the same
for Windows 7 the "Khan Academy" home page is displayed on 
Firefox browser. Selecting any lesson will not display
video lesson contents.

What happened that you didn't expect?
-- Offline version of "Khan Academy" videos version r953
does not work with Windows 7.

Please provide any additional information below.
-- I have piped the 'run.bat' and 'download_scripts' error
messages to the 2 attached text file.

BTW: Really impressed with the quality of the instructions!!
download-scripts-output.log
6.2 KB   View   Download
download-scripts-error.log
91.7 KB   View   Download
Mar 2, 2011
#1 jmich...@gmail.com
From the errors on the second attached file, it looks like there were problems downloading the videos.  Maybe you weren't connected to the internet?  Can you verify that you can reach youtube and archive.org from your Windows 7 machine?  Here is the link for the first Algebra video on archive.org:
http://www.archive.org/download/KhanAcademy_Algebra/simple-equations.flv
Status: Accepted
Mar 2, 2011
#2 Mike...@gmail.com
I have verified that I was connecting fine to the Internet. I will try to re-download r953 again to a Windows 7 and a different Windows XP machine soon and will report result.

Sincerely,
Michael Wyn
Mar 2, 2011
#3 jmich...@gmail.com
I'm trying it from Windows 7 now, and it works for me, though it's getting the files from archive.org instead of locally for some reason.  

I noticed above that you said you attached the output of both run.bat and the download_script, but the two attachments are both from the download_script.  The run.bat output might be helpful in tracking this down.

Also, what exactly do you mean by "will not display video lesson contents"?  Does the green bordered box show up, but just doesn't play?
Mar 2, 2011
#4 jmich...@gmail.com
I take it back, everything is working fine on Windows 7 for me.
Sign in to add a comment

Powered by Google Project Hosting