My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 302: The parameter --dryRunFor TestCase name does not work properly
2 people starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  corbinrs...@gmail.com
Closed:  Dec 2011


Sign in to add a comment
 
Reported by m.jurcov...@gmail.com, Dec 2, 2011
What steps will reproduce the problem?
1. Go to sample 'Hello World' project.
2. java -jar JsTestdriver.jar --port 42442 --browser <path to browser>
3.java -jar JsTestdriver.jar --dryRunFor GreeterTest --server http://127.0.0.1:42442

What is the expected output? What do you see instead?
Expected: Firefox 8.0.1: 1 tests [GreeterTest.testGreet]
Instead see: java.lang.NullPointerException
        at com.google.jstestdriver.DryRunAction$DryRunActionResponseStream.stream(DryRunAction.java:64)
        at com.google.jstestdriver.AggregatingResponseStreamFactory$AggregatingResponseStream.stream(AggregatingResponseStreamFactory.java:98)
        at com.google.jstestdriver.CommandTask.run(CommandTask.java:138)
        at com.google.jstestdriver.JsTestDriverClientImpl.sendCommand(JsTestDriverClientImpl.java:103)
        at com.google.jstestdriver.JsTestDriverClientImpl.dryRunFor(JsTestDriverClientImpl.java:159)


What version of the product are you using? On what operating system?
trunk

Please provide any additional information below.
The server sends following json: {"numTests":1,"testNames":["GreeterTest.testGreet"]}

Classes DryRunAction and DryRunInfo expect following JSON: {"numTests":1,"testNames":[JSON for TestCase]}



Dec 2, 2011
#1 m.jurcov...@gmail.com
Attached patch changes the class DryRunInfo to match with incoming JSON. 
patch04-dryRunForConcreteTestCases.patch
3.0 KB   View   Download
Dec 2, 2011
#2 m.jurcov...@gmail.com
1.) Ignore previous comment please, I just found out that it will be better to change CommandExecutor.js to send list of test cases instead of test names. 

2.) --dryRunFor all does not work either, I will try to fix them both at the same time.


Dec 2, 2011
Project Member #3 corbinrs...@gmail.com
This issue was closed by revision r1095.
Status: Fixed
Dec 2, 2011
Project Member #4 corbinrs...@gmail.com
Did the clean up and cleaned out the bitrot.
Sign in to add a comment

Powered by Google Project Hosting