My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 79: Install fails if MySQL root password is wrong
1 person starred this issue and may be notified of changes. Back to list
Status:  Invalid
Owner:  michaelb...@gmail.com
Closed:  Jul 17


Sign in to add a comment
 
Reported by maik.kulbe, Dec 1, 2011
What steps will reproduce the problem?
1. Start installation of iRedMail on clean system
2. Choose the MySQL backend
3. Give the installation routine a wrong MySQL root password

What is the expected output? What do you see instead?
The installation routine should check the password first, then continue - instead it just continues with the (maybe) wrong password wich will result in an iRedMail system completely not working. 
Also running the installation routine a second time wont fix it as it just skips all functions.

What version of the product are you using? On what operating system?
iRedMail 0.7.3 on Debian 6

Please provide any additional information below.

Jul 17, 2014
Project Member #1 michaelb...@gmail.com
iRedMail requires a new/fresh server OS.
Status: Invalid
Jul 17, 2014
#2 maik.kulbe
Have you even read that issue? Sorry, but I clearly stated:

1. Start installation of iRedMail on clean system

Also, "requires a fresh server OS" is probably one of the worst IT excuses. If you don't want to work on a project, release it to the community so it gets a new project lead who really wants to improve the software.. 
Jul 17, 2014
Project Member #3 michaelb...@gmail.com
Maybe my comment is not clear, but I don't like to read a comment full filled with angry. Relax please.

1) Your issue was submitted in 2011, and it's now 2014, i just want to clean up old issues since we moved to https://bitbucket.org/zhb/iredmail/issues

2) According to iRedMail installation guide, section "System Requirements":

"WARNING: iRedMail is designed to be deployed on a FRESH server system, which means your server does NOT have mail related components installed, e.g. MySQL, OpenLDAP, Postfix, Dovecot, Amavisd, etc (iRedMail will install and configure them for you automatically). Otherwise it may override your existing files/configurations althought it will backup files before modifing, and it may be not working as expected."

It's clearly mentioned that it cannot have MySQL installed. iRedMail will install MySQL packages and set the initial password with the password you typed during iRedMail installation.

So, If we don't have MySQL installed before installing iRedMail, or we have MySQL packages installed without root password, the issue you reported won't happen at all.

That's why i closed this issue, hope it helps.
Sign in to add a comment

Powered by Google Project Hosting