My favorites | Sign in
Project Home Downloads Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 114: PNG Background Image on div container disable links in IE6
5 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Owner:  dean.edw...@gmail.com
Closed:  Feb 2010


Sign in to add a comment
 
Reported by Acid.Mo...@gmail.com, Sep 30, 2008
What steps will reproduce the problem?
1. Make a div with a png transparent in BG
2. Put some links inside the div
3. test in ie6

What is the expected output? What do you see instead?
Working links, but appeared disabled.

What version of the product are you using? On what operating system?
ie7(2.0) IE6 - mac Parrallels software

Please provide any additional information below.



Oct 24, 2008
#1 pdxweb...@gmail.com
Workaround: specify a position parameter of relative or absolute seems to do the trick.
Oct 24, 2008
#2 Acid.Mo...@gmail.com
Nop, the position parameter doesn't work in this particular case. 
Nov 11, 2008
#3 sprilla...@gmail.com
I am experiencing the same problem.  The whole page has a transparent png behind it
in a div, and as such the entire page is not clickable.  Took me awhile to figure it out.
Jan 8, 2009
#4 officialstupid
use that link   -  position:relative  
Jan 30, 2009
#5 spreaf...@gmail.com
No, "position:relative" does *not* work in this case. This seems to be an issue with
all the scripts that fix IE6, unfortunately.
Feb 19, 2009
#6 tyler.du...@gmail.com
Try setting the links to position:relative. This places them on a higher level, above
the DirectX filter. Use this:

#png_background {
	filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='images/back.png',
sizingMethod='scale');
	background-image:none;
}

#png_background a:link,
#png_background a:visited {
	position:relative;
}
Mar 23, 2009
#7 dewant...@gmail.com
position:relative on link work for me.. thank you..
Mar 23, 2009
#8 Acid.Mo...@gmail.com
No, "position:relative" does *not* work in this particular case. Please read previous
msgs before post the same "position:relative is the solution".

Apr 13, 2009
#9 sism...@gmail.com
I'm having this same problem. Links are completely disabled in IE6 and I can't select
the HTML text using the cursor. Has anyone found a REAL solution?

Thanks
May 5, 2009
#10 synapsis...@gmail.com
I think someone should found a solution! The position relative doesnt fix it... come
on guys stop lying
May 14, 2009
#11 chris.mo...@gmail.com
I just tried the position:relative suggestion and it worked for me. Maybe you need to
flush your history for that change to take effect???
May 14, 2009
#12 chris.mo...@gmail.com
I just tried the position:relative suggestion and it worked for me. Maybe you need to
flush your history for that change to take effect???

May 15, 2009
#13 Acid.Mo...@gmail.com
Please!!! READ and reproduce the problem. The Solution NOT is position:relative.
Aug 19, 2009
#14 michaelc...@gmail.com
position:relative does NOT work for me either, I have a div with a transparent
background and a link; it's not clickable
Sep 2, 2009
#15 xavi...@optonline.net
This is not a bug with the script. It is a side effect of Microsoft's Alpha Image
Loader, which is the key component used to make IE6 render transparent PNG files. No
links in or under the div can be interacted with in any form. The div's onClick
property can still be utilized, but only non-transparent areas inside the div will
trigger it. It may be possible to use this as a sort of convoluted work around. You
will not get a true "fix" for this, though, as it is a flaw inherent to the base
technology.
Oct 5, 2009
#16 ulf.seek...@gmail.com
Not sure if it is of any use for you guys but I just placed a div with a higher z-
index and the onclick tags over the div including the background image.
At least that sorted me out.
Oct 5, 2009
Project Member #17 dean.edw...@gmail.com
I've never found a satisfactory solution to this problem. Sometime setting 
position:relative fixes the problem but not always.

As xavierq says in comment #15, this is a problem with the Alpha Image Loader.
Status: Accepted
Owner: dean.edwards
Oct 6, 2009
#18 weblator...@googlemail.com
Hi guys
I have had a few similar problems and found that most of the time setting:

position:relative;
z-index:1000; (probably any z-index greater than 1 will work)

fixes the problem in most cases.

The issue seems to be that IE6 renders the z-indexes correctly visually but gets it
wrong in selection/clickability order.

The only situation I have had where the above didn't fix the problem is where i used
mootools swiff to embed an SWF inside a child of the png-fixed div.

Thanks
Neil
Oct 31, 2009
#19 oliver...@gmail.com
I have the same problem. Nothing of this works :-(
Feb 10, 2010
Project Member #20 dean.edw...@gmail.com
This is a duplicate of Issue #76.

It should be fixed in the next release.
Status: Duplicate
Sign in to add a comment

Powered by Google Project Hosting