My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 1365: Table engine does not offer all possibilities
1 person starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 1164
Owner:  damage3...@gmail.com
Closed:  Aug 2012
Cc:  Caius.Chance


Sign in to add a comment
 
Reported by jeng...@inai.de, Dec 3, 2011
What version of the product are you using? On what operating system?
OS (Linux distributions, UNIX or ...): openSUSE 12.1
Architecture (i386, x86_64): x86_64
IBus version: 1.4.0
Input method name and version: custom
Python version: 2.7/3.0
dbus version: 1.5.8
dbus-python version: 0.83.2
gtk version (if bug is about gtk applications): gtk 2.24.7/3.2.1
qt version (if bug is about qt applications): qt 4.7.4

What steps will reproduce the problem?
1. load up the attached file into ibus-table
2. type an 's' letter
3.

What is the expected output?
To see the lookup window with four proposals: for з, ш, щ and ж.

What do you see instead?
Two possibilities are offered only: 1. з, 2. ж


Please provide any additional information below.
IIRC, all four possibilites were offered earlier in ibus 1.3.8/ibus-table 1.2.0 and the older scim-1.4.7/scim-tables-0.5.8.
ru-translit-de.txt
3.8 KB   View   Download
Dec 3, 2011
#1 jeng...@inai.de
Input method name and version: openSUSE 12.1 ships ibus-table 1.3.0.20100621
Jun 30, 2012
Project Member #3 damage3...@gmail.com
Hi,

I cannot reproduce your problem.

I'd point out that non-Chinese language is not ibus-table's focus.
ibus-m17n should be the engine to handle Russian.

Anyway, I still like to know why such regression happen.
So I'd look into it later.
Status: Accepted
Owner: damage3...@gmail.com
Jun 30, 2012
Project Member #4 damage3...@gmail.com
I'm sorry for a serious typo.

I CAN reproduce your problem.
Jul 1, 2012
#5 jeng...@inai.de
Yes, my ru-translit-de is fully convertible to a m17n MIM file.

Now I just need to figure out how to make m17n show the lookup window, since it does not do that *at all* right now. :)
ru-phonde.mim
2.2 KB   View   Download
Aug 10, 2012
Project Member #6 damage3...@gmail.com
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 1164
Sign in to add a comment

Powered by Google Project Hosting