My favorites | Sign in
Project Home Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 2990: Add CSS fallback font to HTML export
1 person starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  ----
Closed:  Oct 2012


Sign in to add a comment
 
Reported by woutervannifterick, Oct 11, 2012
What exact steps will reproduce the problem?
1. Select some data in a table or query result
2. Export grid rows as HTML table

What was the expected output?
HTML on the clipboard that can be distributed.

What happened instead?
I use the "Dina" font to display data, which is a programmers font that makes a clear distinction between iIL1| and 8B3 etc.

Therefore, I always have to manually edit the HTML before I can send it around, because most likely the receivers don't have this font installed. Instead they get some crappy alternative, which sometimes even messes up any intended layout.

Suggested fix (optional)?
Default to a "web-safe" font.

Something like: font-family:arial,sans-serif
Oct 12, 2012
Project Member #1 a...@anse.de
Select another fontname/size in Tools > Preferences > Data?
Status: Invalid
Oct 16, 2012
#2 woutervannifterick
I have a very handy font to view data, which is not standard in Windows or any other OS.

That font is perfect for using HeidiSQL, but chances are 99.9% that that the receiver of my HTML output does not have that font. Specifying such a font only is just bad practice for CSS/HTML.

I hope you were joking when you suggested to changes preferences every time I want to export to HTML :)

Why not make use of the handy font-stack that CSS gives us?
Add the fancy font name that the user uses, but have a second or third font in case the user doesn't have it installed.

So, something like this perhaps?

font-family: "Fancy But Non-Standard Font", "Default HeidiSQL font?", Arial, Helvetica, sans-serif

Then on my PC i'll get my fancy font, and others will still get something reasonable.
Oct 16, 2012
Project Member #3 a...@anse.de
Ah, ok sure, very reasonable. Will do that.
Summary: Add CSS fallback font to HTML export
Status: Accepted
Labels: -Type-Defect Type-Enhancement Severity-Cosmetic
Oct 19, 2012
Project Member #4 a...@anse.de
This issue was closed by revision r4211.
Status: Fixed
Sign in to add a comment

Powered by Google Project Hosting