My favorites | Sign in
Project Home Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 29: Adding a new AppEngine SDK didn't copy jars in to WEB-INF/lib
1 person starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  chintanr...@google.com
Closed:  Dec 2011


Sign in to add a comment
 
Project Member Reported by sar...@google.com, Nov 21, 2011
smithd:

Eclipse 3.6, GPE 2.4.0r36v201108301710

Under Project > Properties > Google > AppEngine, clicked Configure SDKs... and added 1.5.5, which I'd unzipped into a new directory. Made 1.5.5 the default. The AppEngine page in Properties reflected that 1.5.5 was the default SDK. However, 1.5.5 jars were not copied in to the project's WEB-INF/lib directory (i.e., they still retained 1.5.4 jars), resulting in an unlaunchable project.

Using the dialog to switch to a specific (older) SDK, then back to using the default SDK caused the jars to be copied.

I'm fairly certain that the jars used to be automatically copied, since I install new SDK versions frequently.

If you want to duplicate using 1.5.5, grab it from /google/data/rw/projects/apphosting/java/appengine-java-sdk-1.5.5rc0-orm-samples.zip

Eclipse 3.6, GPE 2.4.0r36v201108301710

Under Project > Properties > Google > AppEngine, clicked Configure SDKs... and added 1.5.5, which I'd unzipped into a new directory. Made 1.5.5 the default. The AppEngine page in Properties reflected that 1.5.5 was the default SDK. However, 1.5.5 jars were not copied in to the project's WEB-INF/lib directory (i.e., they still retained 1.5.4 jars), resulting in an unlaunchable project.

Using the dialog to switch to a specific (older) SDK, then back to using the default SDK caused the jars to be copied.

I'm fairly certain that the jars used to be automatically copied, since I install new SDK versions frequently.

If you want to duplicate using 1.5.5, grab it from /google/data/rw/projects/apphosting/java/appengine-java-sdk-1.5.5rc0-orm-samples.zip


Dec 16, 2011
#1 ridhi...@google.com
Fixed in GPE 2.5
Status: Fixed
Sign in to add a comment

Powered by Google Project Hosting