My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 667: Not compatible with gnome-shell 3.1.90
1 person starred this issue and may be notified of changes. Back to list
Status:  Assigned
Owner:  rainwood...@gmail.com


Sign in to add a comment
 
Reported by mikkilin...@gmail.com, Sep 3, 2011
What steps will reproduce the problem?
1.Install latest gnome-shell-3.1.90 in Ubuntu or Fedora
2.Try to enable extension


What is the expected output?
Global Menu should work as expected 

What do you see instead?
missing init and enable functions 

What version of the Global Menu are you using? On what operating system?

Latest git

What version of Vala are you using? (if your Global Menu is built from git)
0.13.3

Please provide any additional information below.

Sep 3, 2011
Project Member #1 rainwood...@gmail.com
interesting. Do you know of any changes of the extension system in 3.1.90 from 3.0?



Sep 3, 2011
#2 mikkilin...@gmail.com
Not exactly. But I have downloaded latest extensions provided by gnome from  git http://git.gnome.org/browse/gnome-shell-extensions and they are working fine. Looked in to extension.js file from working extensions. There are some new functions like init, enable and disable functions added into latest extensions.

When I tried to enable GlobalMenu extension it was trowing an error that init functions is missing. I have added a dummy init function in to code and tried to enable again. This time I hove got an error that enable function missing. Since I am not coder I don't have any idea what I need to write in these functions :(

   
Sep 4, 2011
Project Member #3 rainwood...@gmail.com
Thanks a lot. This information shall directly lead to a fix. I'll just have to find the time to work on it. 
Status: Assigned
Owner: rainwood...@gmail.com
Sep 21, 2011
#4 lorenx...@gmail.com
I've subitted the pull request on github to fix this issue.
Anyway, I attached the patch here, too.
gnome-global-menu-gnome-3.2.patch
3.1 KB   View   Download
Oct 2, 2011
#5 flx.b...@gmail.com
Has the complete patch set been merged in the git tree? 

Gnome 3.2 has landed in Archlinux, and the applied patches didn't make the global menu work here. 
Oct 2, 2011
#6 flx.b...@gmail.com
Oh well, the extension has been deactivated during the update transition. I manually reactivated it via gnome-tweak-tool and everything is working again :)
Sign in to add a comment

Powered by Google Project Hosting