My favorites | Sign in
Project Home Downloads Wiki Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 2: FFmbc v0.2 Make Fails - x264 (r1318) error
1 person starred this issue and may be notified of changes. Back to list
Status:  WontFix
Owner:  ----
Closed:  Nov 2009


Sign in to add a comment
 
Project Member Reported by phillclarke@gmail.com, Nov 6, 2009
What steps will reproduce the problem?

1. Download x264 from Git. Problem occurs with r1318

2. Configure FFmbc:

aptitude install build-essential subversion git-core yasm libgpac-dev
libdirac-dev libgsm1-dev libschroedinger-dev libspeex-dev libvorbis-dev
libopenjpeg-dev libdc1394-dev libsdl1.2-dev zlib1g-dev texi2html
libfaac-dev libfaad-dev libmp3lame-dev libtheora-dev libxvidcore4-dev
libopencore-amrnb-dev libopencore-amrwb-dev

3. make install

4. Make then fails with the following error:

libavcodec/libx264.c: In function ‘encode_nals’:
libavcodec/libx264.c:75: warning: implicit declaration of function
‘x264_nal_encode’
libavcodec/libx264.c: In function ‘X264_init’:
libavcodec/libx264.c:190: error: ‘x264_param_t’ has no member named
‘b_bframe_pyramid’
make: *** [libavcodec/libx264.o] Error 1


What is the expected output? What do you see instead?

Expected FFmbc to build without errors.


What version of the product are you using? On what operating system?


Running Ubuntu Karmic Koala Netbook Remix on a Asus EeePC 1005HA




Nov 6, 2009
Project Member #1 phillclarke@gmail.com
Stupid me copied and pasted the incorrect thing. I was configuring FFmbc with the
following:

/configure --enable-gpl --enable-postproc --enable-pthreads --enable-libfaac
--enable-libfaad --enable-libmp3lame --enable-libtheora --enable-libx264
--enable-shared --enable-nonfree --enable-libvorbis --enable-libgsm --enable-libspeex
--enable-libschroedinger --enable-libdirac --enable-avfilter --enable-avfilter-lavf
--enable-libdc1394 --enable-libopenjpeg --enable-libopencore-amrnb
--enable-libopencore-amrwb --enable-version3 
Nov 9, 2009
Project Member #2 baptiste...@gmail.com
You have to use an older x264 version. This won't be fixed until next release (0.3)
Status: WontFix
Nov 30, 2009
#3 kishore....@gmail.com
Yes you are absolutely right .. even i did face this Issue.. 

turned out it worked fine with the older version of x264 source.. 
Sign in to add a comment

Powered by Google Project Hosting