My favorites | Sign in
Project Home Wiki Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 5766: Breakpoint editor text is invisible!
3 people starred this issue and may be notified of changes. Back to list
 
Reported by Jedipetey@gmail.com, Jul 31, 2012
Please read http://getfirebug.com/wiki/index.php/I_found_a_Firebug_Bug!
first.

To fix a bug we need

* a TEST CASE (no matter how trivial)
* detailed STEPS TO REPRODUCE the issue

Attempt to create a breakpoint condition in the editor. The code completion text may display, but the actual code does not. 

What is the expected result? What do you see instead?
I expect to be able to read the breakpoint condition in the editor, and not have to wait to see if the value in the watch list is what I actually wanted. I don't actually see anything in the breakpoint editor (aside from code suggestions).

Also, clicking on the breakpoint editor (e.g. to edit the breakpoint condition) causes the editor to close.


Firebug version (number): 1.10
(Note: Bugs in earlier versions than the latest are unlikely to be fixed.)
Browser version: Firefox 15
Operating system: OSX Lion 10.7.4

Jul 31, 2012
Project Member #1 sebastia...@gmail.com
For me editing breakpoint conditions is working. Tested with FF 15.0 (beta) + FB 1.10 on Win7.

My steps:
1. Opened Firebug on https://getfirebug.com/tests/manual/console/joes-original/test.html
2. Enabled and switched to the Script panel
3. Reloaded the page
4. Right-clicked at the breakpoint column at line 23 (" console.log("This is a call to log with multiple arguments.", document.body, 42);")
   => A breakpoint was set and condition editor opened.
6. Typed "d<Tab>.b<Tab>==d<Tab>.fi<Tab"
   => The condition editor showed "document.body==document.firstChild"
7. Hit Enter
   => The Watch side panel showed "document.body==document.firstChild false".
8. Switched to the Breakpoints side panel
   => The panel showed one breakpoint:
"logit    test.html (line 23)
console.log("This is a call to log with multiple arguments.", document.body, 42);"

So everything seems to be working correctly for me.
So please create a new Firefox profile, just install Firebug, repeat your steps and let us know if the problem is gone.

Sebastian
Status: NeedInfo
Cc: sebastia...@gmail.com
Labels: script
Aug 1, 2012
#2 Jedipetey@gmail.com
Tested with FF 15.0 (beta) + FB 1.10 on OSX Lion 10.7.4.
In a fresh profile with only Firebug installed. Followed the your exact steps above:

At step 6 (there is no 5): The text I typed is not displayed.

Additional: As mentioned before, clicking on the breakpoint condition editor causes it to close so I couldn't even edit the breakpoint condition there if I could see what I was doing.
Aug 2, 2012
#3 ZacharyJ...@gmail.com
I have the same issue, although if you type without clicking in the box it will let you set the breakpoint condition, you just cannot see it until you are finished typing and press enter.

If I use the code completion like you said you are using it will continue to show up as it suggests code but once I hit tab it goes invisible again until it suggests something else.

FF - 14.0.1
FB - 1.10 and still happens today after update to 1.10.1
on OS X 10.7
Aug 2, 2012
#4 ZacharyJ...@gmail.com
Seems like it is only on OS X, I just tested this on Windows 7 using FF 14.0.1 and FB 1.10.1 and it worked fine.
Aug 3, 2012
Project Member #5 sebastia...@gmail.com
Thanks for the hint. I think I fixed it in the attached build, though I can't reproduce it because I'm using Windows.
So could somebody please verify that it's working with the attached version?

Sebastian
firebug-1.11.0a0.5766.xpi
1.5 MB   Download
Status: Started
Owner: sebastia...@gmail.com
Cc: -sebastia...@gmail.com odva...@gmail.com simon.lindholm10
Labels: Type-Defect 1.10.1 Test-case-available blocks-1.10.2
Aug 3, 2012
Project Member #7 sebastia...@gmail.com
(No comment was entered for this change.)
Labels: port-1.10
Aug 3, 2012
Project Member #8 odva...@gmail.com
(No comment was entered for this change.)
Status: Commit
Aug 3, 2012
Project Member #9 odva...@gmail.com
Tested and works for me (using VMware Player).
Honza


Labels: -port-1.10 ported-1.10
Aug 3, 2012
#10 ZacharyJ...@gmail.com
The change works for me. Thank you.
Aug 3, 2012
Project Member #11 odva...@gmail.com
This issue has been fixed in Firebug 1.10.2
https://getfirebug.com/releases/firebug/1.10/firebug-1.10.2.xpi

Thanks for the report and help!
Honza


Status: Fixed
Labels: fixed-1.10.2
Aug 5, 2012
Project Member #12 sebastia...@gmail.com
Thanks for the verification Zachary and Honza!

Sebastian
Status: Verified
Sign in to add a comment

Powered by Google Project Hosting