My favorites | Sign in
Project Home Wiki Issues
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 1341: Firefox uses all memory when Firebug installed.
2 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 1030
Owner:  sebastia...@gmx.de
Closed:  Mar 2012
Cc:  johnjbar...@johnjbarton.com, odva...@gmail.com
1.2

Blocking:
issue 2601


Sign in to add a comment
 
Reported by tammiehe...@gmail.com, Jan 2, 2009
What steps will reproduce the problem?
1. Open Firefox with Firebug install and leave it open for an hour
2. Watch the memory usage steadily increase until the system comes to a crawl
3. Disable firebug, restart firefox problem goes away

What is the expected output? What do you see instead?
Reduced memory usage 

What version of the product are you using? On what operating system?
OS X 10.5.6, Firefox 3.0.5, Firebug 

Please provide any additional information below.
This issue has been discussed before, Issue # 127
https://code.google.com/p/fbug/issues/detail?id=127&can=4&q=
It is clear from the old thread that others are still having the problem,
however the issue was closed as fixed, but it is far from fixed.

Screen shot of memory usage from another user with this problem:
http://img74.imageshack.us/img74/3330/firebugisnutsyp1.jpg

Jan 2, 2009
#1 tammiehe...@gmail.com
Forgot to add the version of firebug 1.2.1
Jan 3, 2009
Project Member #2 johnjbar...@johnjbarton.com
I have Firefox with Firebug open for many hours and I have never seen this problem.
Many thousands of other people also have it open and don't have a problem. So there
is something different in your environment that we need to discover.

Two likely differences are 
  1) Other extensions: to test this create a new Firefox profile and install Firebug
only, then repeat your test. If you don't see a problem, add your extensions one at a
time repeating the test.  
  2) URLs: to test this, open Firefox with only one tab "about:blank".  Repeat your
test. If you don't see the problem, look to the URLs you usually have open and
isolate the one which causes memory to fill.

Summary: Firefox uses all memory when Firebug installed.
Cc: johnjbar...@johnjbarton.com
Labels: Type-Defect performance 1.2
Jul 28, 2009
#3 mark.and...@gmail.com
I'm seeing something similar with firebug 1.4.0 and 1.4.1 on firefox 3.5.1, with no
other add-ons installed, on Leopard (10.5.7).

After loading a page with firebug disabled, I can reload that page at will, and the
memory usage stays near constant (the page I've been working with sticks at about
113MB physical ram).  After enabling firebug, every successive reload causes the
memory usage to climb.  After some time (an hour or two of work), this winds up with
all the physical ram being used, and my disk thrashing.  I've seen it get up over 1.4
GB of physical ram in use.

This may not be a bug in firebug per se, but may be a bug in the mac version of
firefox that is revealed by firebug.
Jul 28, 2009
Project Member #4 johnjbar...@johnjbarton.com
With out a test case there is nothing to do here.
Labels: Test-case-needed
Aug 28, 2009
Project Member #5 johnjbar...@johnjbarton.com
Please try firebug 1.5a22, http://getfirebug.com/releases/firebug/1.5X and let us
know if it makes any improvement.
Mar 29, 2011
Project Member #6 johnjbar...@johnjbarton.com
Marking some of the issues reported about memory use
Labels: memory
Apr 19, 2011
Project Member #7 odva...@gmail.com
(No comment was entered for this change.)
Cc: odva...@gmail.com
Aug 1, 2011
#8 sebastia...@gmx.de
Note, there are several issues describing the same (https://code.google.com/p/fbug/issues/list?can=2&q=label%3Dmemory), so they should be merged.
Status: Triaged
Cc: sebastia...@gmx.de
Mar 21, 2012
#9 sebastia...@gmx.de
Because we still don't have a clear test case, I merge this now with issue 1030.

Sebastian
Status: Duplicate
Owner: sebastia...@gmx.de
Cc: -sebastia...@gmx.de
Mergedinto: 1030
Sign in to add a comment

Powered by Google Project Hosting