My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 162: Add EP to system.. removes Liines in code in officer notes.. then does not show up in epgp
1 person starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Owner:  evlogimenos
Closed:  May 2008


Sign in to add a comment
 
Reported by hbarton0...@gmail.com, May 13, 2008
What steps will reproduce the problem?
1. Enter EP for the Raid group
2.
3.

What is the expected output? What do you see instead?

When we entered the points threw the EP slot at the bottom it changed there
points but removed the lines from 0|10189|0|5001 to 01018905001. now they
dont show up in the epgp mod.


What version of the product are you using? What other addons do you have
installed and what versions?

3.3.5 and we tried in the 4.0.1 beta.. 2nd
Paste the text surrounded by -EPGP- in Guild Information here:
-EPGP-
@FC
@DECAY_P:10
@MIN_EP:10000
-EPGP-
[GC3/C:GUILD,2/H:14]


Please provide any additional information below.
 
May 13, 2008
#1 hbarton0...@gmail.com
happen at 2.4.2 patch
May 13, 2008
#2 liam.rei...@gmail.com
Hi,

I isolated the problem. There is an undocumented API change with
GuildRosterSetOfficerNote - escape characters are now strictly
evaluated and require escaping.

In other words, instead of this (Cache.lua line 164 in 3.3.2):

  return string.format("%d|%d|%d|%d", 0, ep, 0, gp)

do this:

  return string.format("%d||%d||%d||%d", 0, ep, 0, gp)

I have not tested this thoroughly, and I am not familiar enough with
the code to know if there are other places where the | must be
escaped.

Good luck, thanks for an excellent mod. 
May 13, 2008
#3 liam.rei...@gmail.com
162 is the same as 160.
May 13, 2008
#4 pentscha...@gmail.com
I'm having the same issue, after making the change above if I add to or subtract 
someone's EPGP they are left with only that EPGP which I just manipulated.

Something like this:
0103050 becomes after adding 505 EP
0|505|0|0
May 15, 2008
Project Member #5 evlogimenos
This is a duplicate of 160.
Status: Duplicate
Owner: evlogimenos
Sign in to add a comment

Powered by Google Project Hosting