My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 2015: 2nd wiimote disconnects upon game launch
4 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 3195
Owner:  ----
Closed:  Sep 2010


Sign in to add a comment
 
Reported by Jazzkin...@gmail.com, Jan 13, 2010
What steps will reproduce the problem?
1.Connect both Wiimotes with normal microsoft drivers.
2.Open Dolphin.
3.In wiimote settings, set wiimote 1 and 2 as "real wiimote".
4.Launch New Super Mario Bros

What is the expected output? What do you see instead?
I would expect the normal game to open up, and the ability to start up a
game with two players. Instead, the 2nd wiimote disconnects (a window
announces this and offers to recconect it immediately, but fails.) , and it
is not possible to recconect without quitting out of dolphin and
reconnecting the wiimote to the pc with the microsoft bluetooth driver.
Selecting tools->connect wiimote 2 doesn't help. Trying to connect the 2nd
wiimote only once the "add new players" screen in nsmb also doesn't work,
because standard bluetooth driver won't reconnect to the wiimote while
dolphin is running.

What version of the product are you using? On what operating system?
4828, windows xp, nsbm europe version.

Please provide any additional information below.
I love dolphin Emu, keep up the good work! Thanks for the advice/fixes.

Jan 20, 2010
#1 emar...@gmail.com
Same problem here. 
My steps:
1. start dolphin
2. go to wiimote dialog (already set to use real wiimotes for both 1 and 2).
   It shows 2 wiimotes are connected without needing to sync (All four lights
   are lit on each of the wiimotes)
4. Press OK (One wiimote shows light #1 and the other shows light #2)
5. Start mario kart wii
6. wait for the wiimote screen to show
7. The lights on the #2 wiimote go black (pressing A does nothing - no flashing)
8. Press Alt-F5 and F6
9. The wiimote reconnect dialog box comes up and I press ok

I can use only the 1st wiimote. The other one will not respond. I can resync it if I
pause the game but it goes black once I enter the game again.

This same behavior happens in all of my games except Animal Crossing where no real
wiimotes work at all. 

Also, if I try to connect my balance board it becomes #1 wiimote and I can't do
anything. (Yes, one thing at a time but maybe that's helpful)

Release:         r4910
OS:              WinXP
Bluetooth stack: MS

Question: Is it possible to specify the wiimote mac address for a particular wiimote
slot? I know it's not optimal for the user but it might help debug the problem.

And I aggree, thanks devs for your effort! You guys are working miracles!
Sep 14, 2010
Project Member #2 godisgovernment
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 3195
Sign in to add a comment

Powered by Google Project Hosting