My favorites | Sign in
Project Home Downloads Wiki Issues Source
Search
for
Compatibility  
Tracks compatibility of the DataNucleus App Engine plugin
Updated Jan 24, 2014 by googleco...@yahoo.co.uk

DataNucleus App Engine Plugin Compatibility

1.0.0:
Requires DataNucleus 1.1.0 (core, jpa, enhancer).
Requires SDK 1.2.0
Note that this release of Datanucleus is no longer supported by the DataNucleus project

1.0.1:
Requires DataNucleus 1.1.0 (core, jpa, enhancer).
Requires SDK 1.2.1
Note that this release of Datanucleus is no longer supported by the DataNucleus project

2.0:
Requires DataNucleus 3.0+ (core, api-jdo, api-jpa, enhancer).
Requires SDK 1.5.4+
Note that this release of Datanucleus is no longer supported by the DataNucleus project

2.1:
Requires DataNucleus 3.1.x (core, api-jdo, api-jpa, enhancer).
Requires SDK 1.6.4+
Note that this release of Datanucleus is no longer supported by the DataNucleus project

3.0: (unreleased, only in SVN)
Requires DataNucleus 3.2.x/3.3.x (core, api-jdo, api-jpa).
Requires SDK 1.7.0+

The next version of DataNucleus (4.0) is now starting, and there are no plans to update this plugin to work with v4.0 of DataNucleus. If you require that, you need to request that upgrade from Google (and maybe at the same time ask why 3.0 of this plugin is still unreleased a year after being written, and why v1.x of this plugin is still seemingly the default provided by GAE SDK).

Comment by hathanht...@gmail.com, Apr 21, 2009

It should be DataNucleus 1.1.0

Comment by geoffc, Apr 24, 2009

could someone paste the exact dependencies that should go in the pom? also would doing an <exclude> on one of them fix the problem too?

Comment by ydw.w...@gmail.com, May 10, 2009

Where can I get SDK 1.2.1 (I assume it is the GAE Java 1.2.1 )? I can not find it at http://code.google.com/p/googleappengine/downloads/list . As for unzipping 1.0.1 and remove the old datanucleus-appengine-1.0.0.final.jar: the java projects won't compile since the "App Engine SDK" classpath entry in Eclipse becomes invalid.

Comment by a.revolu...@gmail.com, Jun 24, 2009

Get the 1.2.1 using eclipse plugin, or try that link again, and look for "appengine-java-1.2.1". It's there.

The google plugin is sneaky... You can remove all the old version data-nucleus stuff, drop in the new files {in /user/tools and /user/lib/orm}, and the plugin should recognize that you want to use an updated version {don't change anything in eclipse, just close it, drop in the new files and move / delete the old ones.}

BACKUP BEFORE YOU DO THIS. I don't have to remind you of that, but I did.

PS - I'm still getting appengine+gwt error: "does not support org.datanucleus.sco.backed.ArrayList?" with 1.1.4. Not really a global compatibility issue, as gwt IS a corner case, but it still sucks!

Comment by yasou...@gmail.com, Jul 3, 2013

When will the new version (3.0.0) of datanucleus-appengine be released?

Especially if the current version only works with unsupported versions of DataNucleus.

thanks

Comment by ch...@c4-soft.com, Sep 11, 2013

I am looking forward to see 3.0 in maven repos. Is there a release plan ?

Comment by nsoeff...@gmail.com, Nov 20, 2013

Since the last commit is from juli, is it reasonable to conclude that this project is abandoned? If not, are there any future plans for supporting datanucleus v3.3 en thus JPA 2.1?


Sign in to add a comment
Powered by Google Project Hosting