My favorites | Sign in
Project Home Wiki Issues Source Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 7402: Feature Request: Easily access the operating system's current default browser
1 person starred this issue and may be notified of changes. Back to list
Status:  NotPlanned
Owner:  ----
Closed:  Dec 2012


Sign in to add a comment
 
Reported by Blurr...@gmail.com, Dec 13, 2012
With a local client side application, with

import 'dart:io';
I think there should be a simple way to find the users current default browser and then load a web page. (Locally stored HTML or a url)

I've searched the API documentation at http://api.dartlang.org, yet have found no easy way, without messing with Processes and having to take care of multiple operating systems.

Are there are plans to simplify this? Preferably similar to the Desktop class in java?(http://docs.oracle.com/javase/6/docs/api/java/awt/Desktop.html)

Originally discussed here: http://stackoverflow.com/questions/13845498/get-the-current-operating-systems-default-browser-open-a-web-page-with-it

Thanks~
Dec 14, 2012
Project Member #1 iposva@google.com
(No comment was entered for this change.)
Status: Triaged
Labels: Area-IO
Dec 17, 2012
Project Member #2 ager@google.com
Thanks for the feature request. We do not have current plans for adding high-level APIs like this to dart:io. We are focused on lower-level APIs.

As the comments on stackoverflow mention, this should be easy to built as a package on top of Platform and Process classes in dart:io. It would be a great addition to the community Pub packages.
Status: NotPlanned
Labels: -Type-Defect Type-Enhancement
May 14, 2014
Project Member #3 kevmoo@google.com
(No comment was entered for this change.)
Labels: -Area-IO Area-Library Library-IO
Sign in to add a comment

Powered by Google Project Hosting