My favorites | Sign in
Project Home Downloads Wiki Issues Source
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 21: can't open multiple .gcda or .gcdo files in one CoverStory window
12 people starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  ----
Closed:  Jul 2013


Sign in to add a comment
 
Reported by dan.jar...@gmail.com, Jul 1, 2009
What steps will reproduce the problem?
1. Try to open multiple .gcda files
2. I can't find any way to get all the files open in one CoverStory window,
which is really annoying.  I want to be able to browse the code coverage
figures for my whole project.

What is the expected output? What do you see instead?
I expect all the files in one window, like that shown on the screenshot
showing how to use CoverStory!

What version of the product are you using? On what operating system?
v4.0.1 on Mac OS X

Please provide any additional information below.


Jul 2, 2009
Project Member #1 thoma...@gmail.com
If you open the folder containing the coverage files, it will list them all in the list on the left of the window.
Jul 6, 2009
#2 dan.jar...@gmail.com
Thank you, that works nicely.  I didn't think it was a very obvious way of doing it
though!  

May I suggest a enhancement to add help text (currently all empty), or a new menu
option ("open folder of coverage files") that only shows directories/folders?

Jul 6, 2009
#3 dan.jar...@gmail.com
Feel free to close this issue if you want to (I didn't seem to be able to update its
status or priority, which should now be "low").
Oct 19, 2009
#4 eric.tre...@gmail.com
This does not work for me.

When I try to open any of the build output folders, I invariably get an error dialog that says: The document "xxx" 
could not be opened. CoverStory cannot open files of this type.

This happens even when attempting to open an "i386" folder full of gcda / gcno files (not sure which of the two 
types is the relevant one).
Nov 3, 2009
#5 toad...@gmail.com
I've noticed that 10.5 and 10.6 handle this differently. On 10.5, Cover Story seems to be able to open a folder 
full of these, and on 10.6 it doesn't.
Nov 12, 2009
#7 iamr...@gmail.com
Confirming toadgee's report:
Can't open a folder of *.gc* files in 10.6.
Dec 13, 2009
#9 dan.cong...@gmail.com
Endless loading (spinner animation) when opening a folder in one CoverStory window.
It seems that it's loading all the time, but the files are not shown as your screenshot.
although the message tells me : Found 76 gcda files to process.

I am using Mac OS X 10.5.8, CoverStory 4.0.1 


Picture 2.png
58.6 KB   View   Download
Jan 5, 2010
#10 vegang...@gmail.com
This is due to the Info.plist settings for document types. Coverstory uses all the inbuilt document opening stuff 
from NSDocument.
I edited the Info.plist to change the folder entry in DocumentTypes to remove the child element with the key 
"CFBundleTypeOSTypes" which has a value of 'fold' and replace it with a Document Content Type UTIs element 
(shows up in popup) with a value of public.item.
I've done this and the open dialogue will now accept folders. Now I'm trying to figure out if it's hanging after that 
or just taking a reeeeaaallllyyyy long time to process my 637 gcda files
Jan 5, 2010
#11 vegang...@gmail.com
note: after the change mentioned above, the log window does show the following:

Scanning for coverage data in '/Users/[redacted ...]/Source/Mac/build/Logger.build'
Found 637 gcda files to process.

And I've attached the plist in case my comment wasn't clear
Info.plist
2.8 KB   View   Download
Apr 18, 2010
#12 Natha...@gmail.com
Hey Vegangeek....did you ever figure this out?  Which Info.plist file did you change?  
Jun 2, 2010
Project Member #13 dmaclach
 Issue 27  has been merged into this issue.
Jun 2, 2010
#14 vegang...@gmail.com
NathanIV:
I changed the Info.plist inside the coverstory application bundle as noted in comment 10 and attached to 
comment 11.

Last time I tried, I was able to open a smaller sized group of files with my changed plist.
Jun 2, 2010
#15 jgedit...@gmail.com
I too have had problems with this. 

I've changed the Info.plist inside the CoverStory app as recommended but CoverStory still freezes with the 
spinner active. The message box as previously says "Found 114 GCDA files to process." I've left it going for a 
good 20 minutes and still nothing. 

I've tried lots and lots of different things - cleaning and rebuilding etc. I've opened the coverage files using 
the command line gcov and I can open individual files in CoverStory fine, but when it comes to a whole folder 
it still fails loading.

I'm on Snow Leopard 10.6.3.
Oct 11, 2010
#16 rdl...@gmail.com
Had the same problem with an iOS4 project. Dug into the code. In my case the problem was as follows:

The method processCoverageForFiles:inFolder: in CoverStoryDocument.m constructs a shell script and executes it via a GTMScriptRunner. The script runner invokes the script attaching pipes to stdout and stderr. Then it reads the data from stdout followed by the data from stderr. The problem is that stderr fills up with data and blocks the script from continuing.

I tried to modify the script runner to fix this but am not familiar enough with this area. In the end I hacked the shell script so that it just sent stderr to stdout:

      NSString *script
        = [NSString stringWithFormat:@"cd \"%@\" && /usr/bin/xargs -0 \"%@\" -l -o \"%@\" < \"%@\" 2>&1",
           tempDir, gcovPath, folderPath, fileListPath];

This is good enough for me as a workaround for now. But I'd love to see a real fix.
Aug 9, 2011
#17 jojo.rudolph@googlemail.com
I'm experiencing the same problem. The solution outline in comment 16 (https://code.google.com/p/coverstory/issues/detail?id=21#c16) did the trick for me too. However I'd like to see a proper fix from the maintainers as I don't feel confident enough to poke in the code.
Jul 21, 2012
Project Member #18 thoma...@gmail.com
The issues with stdout/stderr were reported in https://code.google.com/p/coverstory/issues/detail?id=19&can=1, the but is actually in GTM https://code.google.com/p/google-toolbox-for-mac/issues/detail?id=25.  Please keep this bug on track on if there are problems with opening folders.
Feb 20, 2013
#19 dlre...@gmail.com
The work around from comment 16 is working for me as well. I also submitted a patch to fix this bug to:
https://code.google.com/p/google-toolbox-for-mac/issues/detail?id=25#c3

I'm hoping a project member can take a look.
Mar 7, 2013
#20 naveen.s...@gmail.com
I am facing the same problem as in comment #15. CoverStory freezes with spinner active. The message box says "Found 241 GCDA files to process."

But it is working fine for 160 or less files in my iMac.

I am using Mac OS X 10.7.4, CoverStory 4.3.0 
Jul 12, 2013
Project Member #21 dmaclach
Should be fixed in 4.4
Status: Fixed
Sign in to add a comment

Powered by Google Project Hosting