My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 9653: about:memory doesn't work on OS X
40 people starred this issue and may be notified of changes. Back to list
Status:  Verified
Owner:  viettrun...@chromium.org
Closed:  Nov 2009
Cc:  a...@chromium.org, markus@chromium.org
M-5

Restricted
  • Only users with EditIssue permission may comment.


Sign in to add a comment
 
Reported by viksit, Apr 2, 2009
Chrome Version       : 2.0.172.0 (Developer Build 12913)

What steps will reproduce the problem?
1. Build or download Chromium for Linux/Mac
2. Type about:memory in the address bar

What is the expected result?
On Windows, this results in detailed stats on the browser's memory usage.

What happens instead?
The debug console shows:

:ERROR:renderer/renderer_logging_linux.cc(16)] Not implemented reached in
void renderer_logging::SetActiveRendererURL(const GURL&)


Apr 2, 2009
#1 pinkerton@chromium.org
(No comment was entered for this change.)
Labels: -OS-All -Area-Misc OS-Linux Area-BrowserBackend OS-Mac
Apr 2, 2009
#2 j...@chromium.org
Sorry, too early to expect it to work.  Most bug reports for either of these two
ports will be rejected until we release a dev channel build.  There are simply too
many things left to implement.
Status: Invalid
Apr 2, 2009
#3 viksit
Oh, I filed this bug in conjunction with an email sent out to chromium-dev, based on
Mike Pinkerton's reply.

http://groups.google.com/group/chromium-dev/browse_thread/thread/5ec385301839f8b8

The main purpose of this is to track the development for this feature, rather than a
normal bug report. I'm starting work on this as a developer new to the project.


Apr 3, 2009
#4 pinkerton@chromium.org
This was filed at my request. Please don't pre-triage bugs for us.
Status: Available
Apr 8, 2009
#5 j...@chromium.org
(No comment was entered for this change.)
Labels: Mstone-Linux
Apr 8, 2009
#6 j...@chromium.org
(No comment was entered for this change.)
Labels: Mstone-Mac
May 4, 2009
#7 j...@chromium.org
Removing the MStone:Mac label as this will no longer be used.  It is 
replaced with MStone:MacDev for issues that should be resolved before 
release to testers and the dev channel.  Mstone:MacBeta is for issues that 
should be resolved before the release of a public beta. 

The Mstone:MacBeta list needs to be triaged.  This issue may not be 
required for the Beta.  Any issues that are not required for the beta 
release could be moved to mstone:x where they can wait to be assigned to a 
release.
Labels: Mstone-MacBeta
May 15, 2009
#8 evan@chromium.org
(No comment was entered for this change.)
Labels: Mstone-LinuxDev
May 15, 2009
#9 evan@chromium.org
(No comment was entered for this change.)
Labels: -Mstone-LinuxDev
May 21, 2009
#10 pinkerton@chromium.org
(No comment was entered for this change.)
Labels: Mstone-X
Jun 14, 2009
#11 amis...@google.com
I'd like to look into this one on Linux. Please assign to me.
Jun 15, 2009
#12 phajdan.jr@chromium.org
 Issue 13797  has been merged into this issue.
Jun 15, 2009
#13 evan@chromium.org
Marking started based on comment 11.
Status: Started
Jun 25, 2009
#14 evan@chromium.org
(No comment was entered for this change.)
Labels: Mstone-LinuxBeta
Jun 29, 2009
#15 evan@chromium.org
I pinged #11 today and he is still working on it.
Jul 7, 2009
#16 mikesm...@chromium.org
Not a beta blocker, but nice to have.
Labels: -Mstone-LinuxBeta Mstone-4
Jul 8, 2009
#17 felipe.contreras
No, the ticket itself is not a beta blocker, but decreasing the memory usage is.

Otherwise having more than 4 tabs open will use considerably more memory than
Firefox, and you have seen the comparissons on the web where they trash Chrome based
onn memory usage, right?

I would optimize Chromium to use at least the same ammount of memory than Firefox
with 10 tabs open.
Jul 21, 2009
#18 evan@chromium.org
amistry: ping.  Still working on this?
Jul 21, 2009
#19 amis...@google.com
Yeah, but only on Linux. Someone else can take up the Mac part.  Also, I'm having 
trouble locating the VM private/shared information on Linux (it's not in procfs), any 
ideas?
Jul 22, 2009
#20 evan@chromium.org
+the OS twins for advice on comment #19
Cc: a...@chromium.org mar...@chromium.org
Jul 22, 2009
#21 a...@chromium.org
(I thought I reviewed a change which already did all this.)

#19: what are you looking for? You can get rough data from smaps and a page-by-page 
breakdown in pagemap (although parsing pagemap is overkill for this).
Jul 22, 2009
#22 amis...@google.com
I can get resident memory data from smaps, not virtual.  I'm on Ubuntu Hardy which 
doesn't have the pagemap file in proc (introduced in 2.6.25).
Aug 23, 2009
#23 viettrun...@gmail.com
For interested onlookers, here is a code review for amistry's CL (I don't know if it's the only one):

http://codereview.chromium.org/159777

Given Anand's comment about refactoring (which would touch the common code as well), any work on the Mac 
part should probably wait. (It's not like Apple's making it easy to get useful process information.)
Aug 23, 2009
#24 viettrun...@gmail.com
(Mostly for my own reference....) On Mac, getting process information seems to be a case of picking your poison:
- the kern.proc sysctl (see sysctl(3)) doesn't provide much information (leaving many fields of the kinfo_proc 
structure zero)
- the Mach calls apparently require permissions (see TVL's comment under ProcessMetrics in 
base/process_util_mac.mm); moreover, getting all the VM information would be quite involved
- libproc (see <libproc.h>) is an Apple-private interface which may (and I suspect will) change; apparently, there 
are already problems with (lack of) #pragma pack(4)'s on 64-bit in <sys/proc_info.h>
- running ps seems like a reasonable option, since it's well-standardized; however, it doesn't appear to offer 
information on shared memory size
- running top (in logging mode) is another option (providing more information about memory), but it doesn't let 
you pick out processes by PID; it's also very not-standardized and may change, possibly in incompatible ways
- there really are no good programmatic interfaces, at least as of August 2007: 
<http://lists.macosforge.org/pipermail/macports-users/2007-August/005123.html>
- one could take Apple's libtop <http://www.opensource.apple.com/source/top/top-39/libtop.c> (and .h), but 
this doesn't solve any problems (it's still using a private API, it still requires perms)

Maybe the "top" poison is the tastiest (that, or "ps").
Aug 23, 2009
#25 viettrun...@gmail.com
A not-yet-ready-for-review (I'm waiting on refactoring) patch for the Mac side is here:

http://codereview.chromium.org/173261
Aug 31, 2009
#26 evan@chromium.org
(No comment was entered for this change.)
Labels: -OS-Linux
Sep 2, 2009
#27 j...@chromium.org
Not a blocker for mstone-4 moving to mstone-5
Labels: -mstone-4 mstone-5
Sep 2, 2009
#28 a...@chromium.org
(No comment was entered for this change.)
Summary: about:memory doesn't work on OS X
Sep 4, 2009
#29 parado...@gmail.com
In Chromium Mac build: 4.0.207.0 (25313)

I got a crash when I tried about:memory. (All of Chromium crashed, not just the tab.) 
I'm attaching the dump.
aboutmemorycrash.txt
58.1 KB   View   Download
Oct 21, 2009
#30 kr...@chromium.org
paradoxmo - this bug has gotten a little more stale.  I am unable to reproduce a 
crash with:

Platform:
  Hostname: krisr-macbookpro.local
  Mac OS X Version 10.5.8 (Build 9L31a)
  Processor: 2 Intel 2.40 GHz
  RAM: 2048 MB

Chrome:
  Chrome version: 4.0.223.8  Release
  QuickTime Player: 7.6.2
  QuickTime PlayerX: <unknown>
  Flash Player: 10.0.22.87

If you do see a crash please file a new bug for that issue.
Oct 21, 2009
#31 viettrun...@chromium.org
I'm working on (well, nearly finished) a patch which will provide about:memory on Mac. 
It won't be very good at measuring our own memory usage until we perform some more 
wizardry.
Owner: viettrun...@chromium.org
Oct 22, 2009
#32 parado...@gmail.com
I can confirm it doesn't crash anymore, it just still doesn't work. Looking forward to 
seeing the patch from #31.
Nov 3, 2009
#33 dhw@chromium.org
 Issue 26571  has been merged into this issue.
Nov 3, 2009
#34 dhw@chromium.org
(No comment was entered for this change.)
Blockedon: 25454
Nov 5, 2009
#35 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=31168 

------------------------------------------------------------------------
r31168 | viettrungluu@chromium.org | 2009-11-05 15:37:40 -0800 (Thu, 05 Nov 2009) | 12 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/base/mac_util.h?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/base/mac_util.mm?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/base/mac_util_unittest.mm?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/base/process_util.h?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/base/process_util_posix.cc?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/base/process_util_unittest.cc?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/browser_resources.grd?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/memory_details.cc?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/memory_details.h?r1=31168&r2=31167
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/memory_details_mac.cc
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/process_info_snapshot.h
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/process_info_snapshot_mac.cc
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/process_info_snapshot_mac_unittest.cc
   A http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/resources/about_memory_mac.html
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/chrome.gyp?r1=31168&r2=31167
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/common/temp_scaffolding_stubs.cc?r1=31168&r2=31167

Mac: Implement about:memory.

This implements about:memory on Mac. It calls /bin/ps to obtain information
about processes (this is Apple's officially supported "API"). Unfortunately, ps
provides fairly minimal information (rss and vsize); top is better, but not a
stable API -- it has changed greatly between Mac OS 10.5 and 10.6, and moreover
the 10.6 version is more limited in its output formatting.

BUG=9653
TEST=Go to about:memory under a variety of conditions (with a variety of browsers loaded).

Review URL: http://codereview.chromium.org/333008
------------------------------------------------------------------------

Nov 17, 2009
#36 viettrun...@chromium.org
I'm going to mark this as "Fixed". We still need backend work to measure memory use 
well (issue 25454). But (Mac) about:memory itself is implemented.
Status: Fixed
Blockedon: -25454
Nov 19, 2009
#37 kr...@chromium.org
4.0.249.4 r32475
Status: Verified
Dec 18, 2009
#38 mal.chromium@gmail.com
(No comment was entered for this change.)
Labels: -Area-BrowserBackend Area-Internals
Oct 12, 2012
#39 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Blocking: -chromium:17851
Mar 10, 2013
#40 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -mstone-5 -Area-Internals M-5 Cr-Internals
Mar 13, 2013
#41 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Sign in to add a comment

Powered by Google Project Hosting