My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 95130: Mouse events fail when page includes progress bar
2 people starred this issue and may be notified of changes. Back to list
Status:  Invalid
Owner:  ----
Closed:  Feb 2013

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by chris.a....@gmail.com, Sep 1, 2011
Chrome Version       : 15.0.867.0 (Developer Build 98911)
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 5: ???
  Firefox 4.x: OK
       IE 7/8/9: ???

My HTML5 video controls fail to appear if the page contains a progress element in it. I am using jquery to register when the mouse is over the video element to animate the controls sliding in. Everything works fine, except when the page contains any progress elements. Mousing over the video will sometimes work, but most of the time it will not. Refreshing the page several times will sometimes fix the issue, as will sometimes opening the developers console and browsing through the DOM elements.

main webpage: (example.xhtml)
http://pastebin.com/g4JXVyu5

HTML5 video script: (video.js)
http://pastebin.com/59f9b1in

Video UI xml: (ui.xml)
http://pastebin.com/bGJ0xSau

Video UI css: (theme.css) important?
http://pastebin.com/wL7xrHqJ

Video UI JS: (ui.js) partial
http://pastebin.com/8uYuufTG

Oct 10, 2011
#1 pva...@gmail.com
This (or a related issue) is somewhat more sinister than initially reported.  Not only can progress bars block user interactions with other elements, but it may also preempt parts of the CSS layout process.

Somewhat more disturbingly, CSS rules attached to elements added to the page at a later time are unaffected, and triggering e.g. a :hover on such an element will (may?) cause the previously broken layout to reflow and behave once again.
Nov 21, 2011
#2 imas...@chromium.org
(No comment was entered for this change.)
Labels: Feature-Media
Nov 22, 2011
#3 imas...@chromium.org
Do you have example URL that shows the problem that you described?

Labels: Action-FeedbackNeeded
Dec 1, 2011
#4 imas...@chromium.org
Ping?
Dec 1, 2011
#5 pva...@gmail.com
I do not presently have a public facing project demonstrating this, and I have not yet had time to build a reproduction case.
Dec 6, 2011
#6 imas...@chromium.org
Then, I will close this as invalid.

Status: Invalid
Oct 13, 2012
#7 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mar 9, 2013
#8 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Action-FeedbackNeeded Needs-Feedback
Mar 10, 2013
#9 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-Undefined -Feature-Media Cr-Internals-Media
Sign in to add a comment

Powered by Google Project Hosting