My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 89201: Chrome provides wrong accLocation to MSAA clients for elements after scrolling or resizing
2 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 72318
Owner:  ----
Closed:  Nov 2011

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Project Member Reported by Hans.Hil...@gmail.com, Jul 13, 2011
Chrome Version       : 14.0.821.0
OS Version: 6.1 (Windows 7, Windows Server 2008 R2)

Sometimes when the viewport is resized or scrolled, the accLocation information sent out by Chrome is incorrect. Even after tabbing to other focusable elements, the location indicated by MSAA (which is what screen magnifiers will use to scroll the focused element into view) will be displaced. The significance of the displacement corresponds to the amount of scrolling or resizing that occurred.

The attached screenshot illustrates the issue. The screenshot shows the "services" link being focused in the DOM, but both the MSAA Inspect tool (indicated by the yellow rectangle) and the screen magnifier (indicated by the the 'mnagnifier' window) perceive the focused object as being somewhere else on the screen.

UserAgentString: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/535.1 (KHTML, like Gecko) Chrome/14.0.821.0 Safari/535.1



Screen shot 2011-07-13 at 2.31.13 PM.png
372 KB   View   Download
Jul 19, 2011
#1 dmazzoni@chromium.org
(No comment was entered for this change.)
Labels: -Area-Undefined Feature-Accessibility
Sep 2, 2011
#2 ChintanN...@gmail.com
Hi There,

We are also facing same problem. Kindly let us know when the problem is identified and fixed.

Thanks & Regards,

Chintan.
Sep 5, 2011
#3 onlyjayp...@gmail.com
Hello,

We are also getting wrong location from chrome exe.

But we have noticed that when we clicked in chrome's client area everything rearanged and we get proper location.

Is there any other way to do this externely?

Can we send any message or event to chrome so that it will update its Accessible information automatically without clicking.

Please inform about anything regarding this.

Thank you.

Jay.
Nov 16, 2011
#4 dmazzoni@chromium.org
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 72318
Oct 13, 2012
#5 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:72318
Mar 10, 2013
#6 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Feature-Accessibility Cr-UI-Accessibility
Sign in to add a comment

Powered by Google Project Hosting