My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 78325: console.log() references values before they should be available in scope
1 person starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 50316
Owner:  ----
Closed:  Apr 2011
Cc:  yurys@chromium.org, pfeld...@chromium.org

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by filiptep...@gmail.com, Apr 4, 2011
Chrome Version       : 10.0.648.240
URLs (if applicable) : https://gist.github.com/901816
Other browsers tested:
  Firefox 4.x: OK

What steps will reproduce the problem?
1. Run the script from GitHub.

What is the expected result?
As explained in the Gist.

What happens instead?
As explained in the Gist.

Apr 4, 2011
#1 lukaszko...@gmail.com
Yields same results in 11.0.696.28 beta
Apr 4, 2011
#2 wtc@chromium.org
(No comment was entered for this change.)
Labels: -Area-Undefined Area-WebKit WebKit-JavaScript
Apr 5, 2011
#3 ager@chromium.org
This seems to be related to the point in time when the value is actually converted to a string for display in the console. I would guess that the value is registered for logging and the actual string conversion happens later (after the rest of the script block)? 
Status: Available
Cc: yurys@chromium.org pfeldman%chromium.org@gtempaccount.com
Labels: -Area-WebKit -WebKit-JavaScript Feature-DevTools
Apr 5, 2011
#4 filiptep...@gmail.com
Exactly. This doesn't happen if you wrap iteration in setTimeout (tested with 10000 timeout).
Apr 5, 2011
#5 pfeld...@chromium.org
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 50316
Oct 12, 2012
#6 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:50316
Mar 10, 2013
#7 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Feature-DevTools Cr-Platform-DevTools
Sign in to add a comment

Powered by Google Project Hosting