My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 66628: Checkboxes in CSS Debugger should be to the left side !
9 people starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  pfeld...@chromium.org
Closed:  Feb 2012
Cc:  apav...@chromium.org

Restricted
  • Only users with EditIssue permission may comment.


Sign in to add a comment
 
Reported by popp...@gmail.com, Dec 12, 2010
Chrome Version       : <Copy from: 'about:version'>
URLs (if applicable) :
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
Safari 5:
Firefox 3.x:
IE 7/8:

What steps will reproduce the problem?

When you want to disable/enable style in CSS debugger, checkboxes are right side the css properties.

What happens instead?

This is not handy, it should be to the left side, as FireBug does, near the css properties text !

Dec 12, 2010
#1 temp01...@gmail.com
(No comment was entered for this change.)
Labels: -Type-Bug -Area-Undefined Type-Feature Area-WebKit Feature-DevTools
Dec 20, 2010
#2 ka...@chromium.org
(No comment was entered for this change.)
Labels: Mstone-X
Jan 26, 2011
#3 pfeld...@chromium.org
(No comment was entered for this change.)
Status: Available
Feb 9, 2011
#4 popp...@gmail.com
Please update the css DevTools.css

//////////////////////////////////
#line 4734
///////////////
.styles-section .properties .enabled-button
{
    display:block;   /*modified*/
    float: left;     /*modified*/
    font-size: 10px;
    margin: 1px 2px 0 0px;   /*modified*/
    vertical-align: top;
    position: relative;
    z-index: 1;
}
//////////////////////////////////
Explain:

With the check box always visible and on the left, it is very convenient for developers !
I hope you understand my point of view, this is the main reason I use firebug to debug css, so if you apply this fix, I think more developers will use Chrome DevTools.
Feb 10, 2011
#5 sandholm@chromium.org
Pavel/Alexander, what do you think?
Owner: apav...@chromium.org
Feb 10, 2011
#6 apav...@chromium.org
The issue is being tracked upstream as https://bugs.webkit.org/show_bug.cgi?id=37770.

The suggested solution dramatically breaks the layout of expandable shorthands and invalid properties (having an exclamation mark next to their names). A quick test is:

div {
  height: 100%; /* OK */
  border: 1px solid black; /* Checkbox between arrow and property name */
  width: 100%; /* OK */
  -moz-opacity: 0.5; /* Property not aligned with the others */
}
Feb 10, 2011
#7 popp...@gmail.com
Sure but you can adapt the css for the layout problems

* invalid properties: 

.styles-section .properties li.not-parsed-ok {
margin: 1px 0 0px 13px;
}

* child properties:

.styles-section .properties ol {
margin: 0px 0px 0px 20px; /*modified*/
}


Regards,
Stephane
Feb 10, 2011
#8 apav...@chromium.org
Oh, I don't mean to say it is impossible (otherwise the upstream bug would have been closed as WONTFIX :)). Instead, my comment was intended to link this bug to an upstream one.

If the suggested changes pass a UI review, I believe the issue will be resolved in a positive manner, especially given other similar requests.
Feb 10, 2011
#9 popp...@gmail.com
Ok so many thanks :) I hope this will be done soon ^^
Apr 11, 2011
#10 popp...@gmail.com
No news since two monthes, it didn't pass the UI reviews?
Apr 30, 2011
#11 paulir...@chromium.org
I think the left-aligned checkboxes in IE's devtools are rather ugly, myself and prefer to keep them somewhat out of sight.

A compromise solution may be... to provide a hover background for the row, so its at least easier to associate the form control with the style.

Apr 30, 2011
#12 popp...@gmail.com
The fact is it's not convenient on the right side. It's ugly because there are checkboxes, firebug show an icon hen style are disabled and it's convenient and not ugly (not pretty, just not ugly :) )
May 17, 2011
#13 apav...@chromium.org
 Issue 82660  has been merged into this issue.
Cc: pfeld...@chromium.org apavlov%...@gtempaccount.com
Jun 12, 2011
#14 popp...@gmail.com
To complete my purpose, the actual disposition is opposite to the proximity law in ergonomy, could you reconsidere this issue, it's opened for a while...
Jun 14, 2011
#15 TonightsLastSong
He said it was upstream.  That means its in the Webkit engine, not the core Chrome codebase.  Webkit needs to deal with it, because the Chromium team isn't going to be a big fan of maintaining a forked Webkit deployment.
Jun 14, 2011
#16 popp...@gmail.com
Ok I see, but where can i found and follow this issue at webkit website ? It's not clear...
Jun 14, 2011
#17 cont...@jaygeorge.co.uk
I completely agree on this being unclear - it's like these issues get acknowledged and then lost in the ether.
Jun 14, 2011
#18 dhw@chromium.org
The upstream WebKit bug is noted in Comment 6
Status: ExternalDependency
Jun 14, 2011
#19 cont...@jaygeorge.co.uk
Just a thought - will the Chrome team update on any Webkit progress / resolution on this feed? Or this feed dead now?
Jun 22, 2011
#20 popp...@gmail.com
Got it ! I comment the upstream link in webkit.
Feb 17, 2012
#21 apav...@chromium.org
Upstream bug: https://bugs.webkit.org/show_bug.cgi?id=78780
Patch landed: http://trac.webkit.org/changeset/107933
DEPS rolled
Status: Fixed
Owner: pfeld...@chromium.org
Cc: -pfeld...@chromium.org
Labels: -Mstone-X Mstone-19
Oct 13, 2012
#22 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mar 10, 2013
#23 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-WebKit -Feature-DevTools -Mstone-19 Cr-Content Cr-Platform-DevTools M-19
Mar 13, 2013
#24 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Apr 5, 2013
#25 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content Cr-Blink
Sign in to add a comment

Powered by Google Project Hosting