My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 600: Does not support CAC or smartcard authentication
5 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Owner:  wtc@chromium.org
Closed:  Apr 2009
Cc:  jcam...@chromium.org

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by willi...@gmail.com, Sep 3, 2008
Product Version      : 0.2.149.27
URLs (if applicable) :
Other browsers tested: IE, Firefox
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 3: OK
    Firefox 3: OK
         IE 7: OK

What steps will reproduce the problem?
1. Visit a site that requires PKI authentication using a smart card

What is the expected result?

Successful authentication

What happens instead?

Failed authentication

Please provide any additional information below. Attach a screenshot if 
possible.
 
Sep 5, 2008
#1 trak...@gmail.com
Confirmed.  User is not prompted for the certificate to use to authenticate.  (We 
have two readers attached each with a smart card for different rights.)  Total 
failure to connect without the prompt.

IE 8 beta 2 also works OK.

Middleware is ActivIdentity ActivClient 6.1.3.100 with SCM Microsystems SCR331 USB 
readers.

Thee SSL channel is solid, but site displays this:  (No usual prompt for user's smart 
card certificate)
The page requires a client certificate

The page you are attempting to access requires your browser to have a Secure Sockets 
Layer (SSL) client certificate that the Web server will recognize. The client 
certificate is used for identifying you as a valid user of the resource.
Please try the following:

Contact the Web site administrator if you believe you should be able to view this 
directory or page without a client certificate, or to obtain a client certificate.
If you already have a client certificate, use your Web browser's security features to 
ensure that your client certificate is installed properly. (Some Web browsers refer 
to client certificates as browser or personal certificates.)
HTTP Error 403.7 - Forbidden: SSL client certificate is required.
Internet Information Services (IIS)

Technical Information (for support personnel)

Go to Microsoft Product Support Services and perform a title search for the words 
HTTP and 403.
Open IIS Help, which is accessible in IIS Manager (inetmgr), and search for topics 
titled About Certificates, Using Certificate Trust Lists, Enabling Client 
Certificates, and About Custom Error Messages.

Sep 5, 2008
#2 rudedude@gmail.com
See  issue 318  or  issue 166  I'm not sure which is more applicable here. Search term
"client certificate"
Sep 29, 2008
#3 mal.chromium@gmail.com
(No comment was entered for this change.)
Labels: -area-unknown Area-Misc
Nov 11, 2008
#4 j...@chromium.org
Taking these to triage.
Owner: jon
Nov 11, 2008
#5 j...@chromium.org
See http://en.wikipedia.org/wiki/Common_Access_Card and http://www.cac.mil/CardInfo.html

Status: Available
Labels: -Pri-2 -Area-Misc Pri-3 Area-BrowserBackend Mstone-X
Nov 14, 2008
#6 j...@chromium.org
(No comment was entered for this change.)
Owner: ---
Apr 3, 2009
#7 wtc@chromium.org
This is a duplicate of  issue 318 .  We plan to start implementing
SSL client authentication in this quarter, and will support
both "software" certificates (private keys and certificates
stored on disk) and smartcards.
Status: Duplicate
Owner: w...@chromium.org
Cc: jcam...@chromium.org
Mergedinto: 318
Dec 18, 2009
#8 mal.chromium@gmail.com
(No comment was entered for this change.)
Labels: -Area-BrowserBackend Area-Internals
Mergedinto: -
Oct 11, 2012
#9 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mar 10, 2013
#10 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-Internals Cr-Internals
Sign in to add a comment

Powered by Google Project Hosting