My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 57741: Literal values in shaders cause a pink layer over all html5 videos
47 people starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  vrk@chromium.org
Closed:  Feb 2011
Cc:  vangelis@chromium.org, kbr@chromium.org, jamesr@chromium.org, phajdan.jr@chromium.org, hbridge@google.com, zmo@chromium.org

Blocked on:
issue 62581

Restricted
  • Only users with EditIssue permission may comment.


Sign in to add a comment
 
Reported by leandrosansilva, Oct 3, 2010
Chrome Version       : 7.0.542.0 (Versão do desenvolvedor 61319) Ubuntu 10.04
URLs (if applicable) : Any video on youtube or vimeo with html5 player
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: not tested
  Firefox 3.x: not tested
         IE 7: not tested
         IE 8: not tested
  Firefox 4.0: OK (with youtube+webm)
  
What steps will reproduce the problem?
1. Browse to youtube or vimeo site and enable the html5 player (I don't have flash)
2. Open a video. Any video, I've seen that both webm and mp4 have the problem
3. play the video in the html5 player. The image will be... pink :-)

What is the expected result?
The video as it is

What happens instead?
The video is showed with "pinkscale" colors.

Please provide any additional information below. Attach a screenshot if
possible.

t4.png
119 KB   View   Download
Oct 4, 2010
#1 stuartmorgan@chromium.org
(No comment was entered for this change.)
Labels: -Area-Undefined Area-Internals Feature-Media
Oct 4, 2010
#2 stuartmorgan@chromium.org
 Issue 57671  has been merged into this issue.
Oct 5, 2010
#3 ChoK....@gmail.com
Confirmed on archlinux with nvidia 256.44 with the developper release 7.0.536.2 compiled from source. The build http://aur.archlinux.org/packages.php?ID=37244 has a patch referring to this bug http://aur.archlinux.org/packages/chromium-dev/chromium-dev/webkit-media-player.patch. I will try it.
Oct 5, 2010
#4 ChoK....@gmail.com
Oops I read too fast, the patch was for another bug. Sorry.
Oct 5, 2010
#5 meh...@chromium.org
 Issue 58009  has been merged into this issue.
Oct 5, 2010
#6 scherkus@chromium.org
Looks like a linux issue?

I tried on 7.0.536.2 mac and it didn't repro.. but we're thinking this is due to hardware accelerated video rendering and don't think that's enabled on the version I'm running.
Status: Assigned
Owner: v...@chromium.org
Labels: -Area-Internals Area-WebKit Mstone-8 OS-Linux
Oct 6, 2010
#7 telefran...@gmail.com
How can I check If I do have hardware accelerated video? I tried in "about:" and I don't have any options passed to chromium...
Oct 6, 2010
#8 vangelis@chromium.org
Running chrome with --disable-accelerated-compositing will disable gpu compositing and h/w accelerated video.

Oct 6, 2010
#9 tobu...@gmail.com
With --disable-accelerated-compositing I no longer get the pink layer on html5 vids.
Oct 6, 2010
#10 Pitli...@gmail.com
I still have this problem in 7.0.544.0 dev.
Oct 7, 2010
#11 vrk@chromium.org
I am unable to reproduce this bug, so it's hard to track down.

@Pitlicek, telefrancisco, leandrosansilva, anyone else who has this bug: can you let me know what OS, graphics card, and build number you are using? Thanks!
Oct 7, 2010
#12 tobu...@gmail.com
From https://code.google.com/p/chromium/issues/detail?id=57671#c2

Ubuntu 10.04 x86_64 with nouveau graphics.

Oct 7, 2010
#13 tobu...@gmail.com
Moving from 7.0.547.0~svn20101005r61463-0ubuntu1~ucd1~lucid
to 7.0.548.0~svn20101007r61753-0ubuntu1~ucd1~lucid

Now the tab freezes immediately. I don't get the sad tab icon, just a tab that never repaints. Maybe that is what vrk is seeing too.
Oct 8, 2010
#14 Pitli...@gmail.com
Desktop: Ubuntu 10.04, 64bit, nVidia drivers 260, GeForfe 9600, Chrome 7.0.544.0 dev.
Laptop: Ubuntu 10.10 RC, 32bit, some integrated Intel graphics, Chrome 7.0.544.0 dev.

Both have the issue.

Oct 8, 2010
#15 chato...@gmail.com
I have this problem too.
I am using Ubuntu 10.04 + nvidia 256.53 version graphics driver and google chrome 7.0.544
When I start chrome with "--disable-accelerated-compositing" options , video display correct.
Oct 9, 2010
#16 telefran...@gmail.com
#11 
OS: Ubuntu 10.10 (updated once a day)

Graphics card: 00:0d.0 VGA compatible controller: nVidia Corporation C61 [GeForce 7025 / nForce 630a] (rev a2) (Drivers: 260.19.06-0ubuntu1)

Latest version I've tried with this bug: 8.0.550.0 (62060) Ubuntu 10.10

Like the others, this bug doesn't happen with: --disable-accelerated-compositing

Oct 10, 2010
#17 chato...@gmail.com
I have Ubuntu 10.10 + GeForce nVidia 8600 GT (version driver - 256.53) and Google Chrome 7.0.544 but video display not correct.
Oct 11, 2010
#18 scherkus@chromium.org
Adding some GPU folk to CC because we're a bit stumped on this!  Might be a Linux driver thing.
Cc: vange...@chromium.org k...@chromium.org jam...@chromium.org
Labels: -Pri-2 Pri-1
Oct 12, 2010
#19 kbr@chromium.org
I can not reproduce this issue with Chromium TOT (8.0.553.0). Ubuntu 10.04, 64 bit, NVIDIA Quadro FX 380, driver 195.36.24. Looks like the driver is a fair bit older than ones others are using.

To triage this on a configuration that reproduces the bug, I recommend modifying the shaders in VideoLayerChromium to output a known particular color (like blue) and see whether it comes through unmodified. Also check http://webkit.org/blog/386/3d-transforms/ for proper operation.

Oct 13, 2010
#20 Pitli...@gmail.com
I'm still having this problem after 8.0.552.0 dev update on my laptop (32bit Ubuntu 10.10, Intel (mesa)) and even when GPU acceleration is disabled in about:labs.
Oct 13, 2010
#21 hc...@chromium.org
Pitlicek: what if you run with --disable-accelerated-compositing? Make sure you close all instances of chrome before trying that.
Oct 13, 2010
#22 Pitli...@gmail.com
Than it's ok... I thought the lab feauture does that.
Oct 14, 2010
#23 pat...@gmail.com
Can reproduce with 8.0.554.0 (62496) and nouveau (Mesa 7.9)
Oct 15, 2010
#24 tobu...@gmail.com
With 8.0.555.0~svn20101015r62694-0ubuntu1~ucd1~lucid I noticed many stderr messages like this, that aren't there with --disable-accelerated-compositing. The tab freeze in comment 13 didn't happen with newer versions.

[7498:7498:839434919875:ERROR:chrome/gpu/gpu_main.cc(32)] X Error detected: serial 299, error_code 9 (BadDrawable (invalid Pixmap or Window parameter)), request_code 72 minor_code 0 (X_PutImage)

Oct 15, 2010
#25 vrk@chromium.org
 Issue 59189  has been merged into this issue.
Oct 17, 2010
#26 wbr...@gmail.com
can't reproduce with 8.0.558.0 (62892) and nvidia drivers
Oct 18, 2010
#27 tobu...@gmail.com
Still pink with 8.0.558.0 (62903), nouveau, lucid. These flags may be useful for testing without killing an existing session:

chromium-browser --temp-profile --no-first-run \
    'http://www.youtube.com/watch?v=3hYJRPcPjpI&html5=1'

Oct 18, 2010
#28 scherkus@chromium.org
tobutaz can you try with --disable-accelerated-compositing?

Also is it possible to provide as much GPU/driver info if the above flag makes it work?
Labels: -Mstone-8 Mstone-9
Oct 18, 2010
#29 scherkus@chromium.org
 Issue 58952  has been merged into this issue.
Oct 18, 2010
#30 scherkus@chromium.org
Adding some keywords: magenta pink layer color colour video youtube html5
Oct 18, 2010
#31 tobu...@gmail.com
It still works fine with --disable-accelerated-compositing

I have the nouveau drivers lucid provides.
aptitude search -F'%p# %V#' ~inouveau ~imesa-glx --disable-columns
libdrm-nouveau1 2.4.18-1ubuntu3
libgl1-mesa-glx 7.7.1-1ubuntu3
xserver-xorg-video-nouveau 1:0.0.15+git20100219+9b4118d-0ubuntu5

lspci says the card is a nVidia Corporation G73 [GeForce 7600 GS]
Nouveau classifies the chipset as NV4b, in the NV40 family.
http://nouveau.freedesktop.org/wiki/CodeNames
Oct 18, 2010
#32 bcafa...@gmail.com
Gentoo bug report is here:
http://bugs.gentoo.org/show_bug.cgi?id=340537

Happens with nvidia binary drivers (256.53), xf86-video-fbdev, xf86-video-ati (at least)
Oct 19, 2010
#33 interpon...@gmail.com
Same problem on my laptop with INTEL GPU (Ubuntu 10.10 64bit, Google Chrome 8.0.552.0 dev)
Oct 19, 2010
#34 wrar42@gmail.com
On my both machines (64bit Debian nVidia and 32bit Debian Intel) the issue exists in 8.0.552.0-r62249 without --disable-accelerated-compositing and doesn't exist with it.
Oct 19, 2010
#35 vrk@chromium.org
Looks like this is a linux driver issue. Unfortunately that means there's not much I can do to fix it :( 

So it looks like the other Chrome GPU people and I need to talk about the general problem of how to most elegantly deal with buggy cards/drivers, but for now it seems like the best thing to do is to a) change/upgrade your drivers or b) run chrome with the --disable-accelerated-compositing flag. Sorry about that!
Status: WontFix
Oct 19, 2010
#36 telefran...@gmail.com
So the clarify this: it seems that (reading the comments in this bug), that the noveau nVidia free drivers, nVidia proprietary drivers, Intel drivers, and XF86 ATI drivers all (I suppose) without any relation between them, are suffering the same bug?

I'm not a developer, so I want to know: is this correct or I missed something?

Thanks.
Oct 22, 2010
#37 scherkus@chromium.org
OK we'll keep this open again and try to collect more info.

I will note that we want people to be using accelerated compositing.  It's fast and awesome, but still needs some bug fixing :)

Who here is building Chromium themselves?  Are you using any build config flags like use_system_ffmpeg or use_system_vpx?  Any other command line flags?
Status: Assigned
Labels: -Pri-1 Pri-3
Oct 22, 2010
#38 flokl...@gmail.com
I do. Gentoo ~amd64 here, using xf86-video-ati git, chromium is compiled with use_system_ffmpeg=1 (ffmpeg version is 0.6_p25423)

chromium is version 8.0.552.11, but I also saw this issue with 8.0.552.0. Disabling accelerated compositing worked.
Oct 22, 2010
#40 wbr...@gmail.com
I have Gentoo ~amd64 build 8.0.558.0 similar to floklink, nvidia drivers 256.53, but no pink layer with --enable-accelerated-compositing
Oct 23, 2010
#41 telefran...@gmail.com
Anyone tried what is said in comment #19?
Oct 23, 2010
#42 spayde...@gmail.com
Chromium 9 svn build, catalyst driver, Ubuntu 10.10. Bug still present
Oct 24, 2010
#43 phajdan.jr@chromium.org
For more detailed info how Gentoo builds the package, please take a look at http://sources.gentoo.org/cgi-bin/viewvc.cgi/gentoo-x86/www-client/chromium/chromium-8.0.552.11.ebuild?view=markup
Cc: phajdan...@chromium.org
Oct 25, 2010
#44 fth...@gmail.com
Chrome Version (from the about:version page): 8.0.552.0 (Developer Build 0)
USE flags: gecko-mediaplayer system-sqlite -cups -gnome -gnome-keyring
OS + version: Linux 2.6.35-gentoo-r4 GNU/Linux -- Gentoo Base System release 1.12.13 
CPU architecture (32-bit / 64-bit): 32-bit
Window manager: Kwin

Similar problem here with vesa, fbdev and sis drivers. The tab becomes almost
non-responsive. Sound as well as video have stuttering effect. With
--disable-accelerated-compositing switch however it plays flawless.


Oct 25, 2010
#45 hbridge@google.com
gpu path, adding feature-gpu
Cc: hbri...@google.com
Labels: -Pri-3 Pri-2 Feature-GPU
Oct 26, 2010
#46 vrk@chromium.org
OK, we ordered a GeForce 9600 that should be here tomorrow or Thursday, and when it comes we have a machine we can use to try and test this. I may need to ask people for super specific work conditions if I still can't reproduce it. Will update with progress. Thanks for all your help so far!
Oct 28, 2010
#47 julien.s...@gmail.com
use_system_ffmpeg=1 or use_system_ffmpeg=0 does not matter. Still pink...

Gentoo ~amd64 / Chromium 9.0.567.0 (64227) / nvidia 256.53
Nov 1, 2010
#48 hbridge@google.com
(No comment was entered for this change.)
Labels: -Feature-GPU Feature-GPU-Video
Nov 4, 2010
#49 raindanc...@gmail.com
I have the same problem. But on OS X. Using Google Chrome DEV 9.0.570.0
Videos in HTML5 all have pink overlay. Have not tryed to disable hardware accelleration yet (though I don't think it is used on MacBook 4,1)
Nov 5, 2010
#50 lafo...@chromium.org
Given our current velocity, we need to punt 500 bugs from m9.  Moving p2 bugs, that are not started and have an owner to the next milestone.  If this issue absolutely needs to be fixed in the current milestone please move it back, however, at this time the focus should be on p1 bugs.
Labels: -Mstone-9 Mstone-10
Nov 6, 2010
#51 giordano...@gmail.com
As of version 9.0.574.0 (65301) seems to be working fine again here. The issue used to be present on any html5 video, and now all the one I tested are working fine.
Unfortunately I cannot name the last version which wasn't working for sure...

Ubuntu 10.10 amd64. The builds come from ppa:chromium-daily/ppa
Nov 9, 2010
#54 dbpal...@gmail.com
fixed yesterday and before and still no pink layer but now it crashes the entire page and other youtube tabs. 

Ubuntu 10.10 amd64
Nov 9, 2010
#55 giordano...@gmail.com
I confirm the behaviour described in comment #54.
Don't know if it's related, It has complained about missing libGLESv2.so; I've installed package libgles2-mesa and symlinked libGLESv2.so.2.0.0 libGLESv2.so;
Then I needed to do the same for  libEGL.so (symlinked to libEGL.so.1.0 in package
 libegl1-mesa). Now I have "libEGL warning: unable to load st_GL.so". (file is present in /usr/lib/egl)
Maybe I need to forward this to package mantainer?

The version is 9.0.577.0 (65479) from the daily ppa, on Ubuntu 10.10 amd64
Nov 9, 2010
#56 kbr@chromium.org
There was a regression last night in the GPU process code on Linux causing the compositor, all HTML5 video content and WebGL to hang while loading. It's being fixed under http://crbug.com/62581 and http://codereview.chromium.org/4641003 .

Blockedon: 62581
Nov 16, 2010
#57 vangelis@chromium.org
Nouveau drivers aren't expected to work as, according to the nouveau wiki page (http://nouveau.freedesktop.org/wiki/), 3D functionality isn't yet supported (and the accelerated compositor requires that).  We will black list them as per  issue 59302 . 

Can anyone not running nouveau drivers verify that the issue is still there in 9.0.x nightly builds? 


Labels: -Pri-2 Pri-1
Nov 16, 2010
#58 maxpouli...@gmail.com
On my side, the bug is fixed in the latest build from the Ubuntu PPA

I am running: 9.0.576.0 (Build de développement 65344) Ubuntu 
with latest NVIDIA drivers (260.19.12)

YouTube HTML5 WEBM works just fine (tried 360p, 720p and 1080p) while I had this bug before (subscribed to the issue near Nov 05).

So, no, the issue is NOT still there, at least in 9.0.576.0.
Nov 16, 2010
#59 claudiobastos@gmail.com
For me, is fixed!

Ubuntu 10.10 NVidia 8500GT, Chrome 9.0.576.0 dev

Nov 17, 2010
#60 dbpal...@gmail.com
no pink layer, but sometimes the video crashes and the tab with it using the html5 player on youtube. Probably youtube's issue because on Vimeo it works just fine.
Nov 17, 2010
#61 simon.sc...@gmail.com
html5 video is still pink here.

Ubuntu 10.10 64bit, Intel GMA4500, Chrome 9.0.576.0 (official Build 65344).

I'll test my Radeon HD 3470 later.
Nov 17, 2010
#62 telefran...@gmail.com
No pink layer here.
Nov 17, 2010
#63 simon.sc...@gmail.com
...still pink with the Radeon HD 3470.
The system is the same as above (switchable graphics).
Nov 17, 2010
#64 vange...@google.com
Thanks for the info simom.schaak.  What drivers are you using?
Nov 17, 2010
#65 simon.sc...@gmail.com
I'm using ubuntu's default drivers, so no fglrx or other proprietary ones.
Nov 18, 2010
#66 Pitli...@gmail.com
HTML5 videos now works fine on my desktop with nVidia (acceleration enabled in about:flags) but not on my laptop with integrated Intel (with acceleration disabled).

Chrome 9.0.576.0 dev
Nov 19, 2010
#67 myr...@gmail.com
I have reproduced on 9.0.590.0~svn20101119r66727-0ubuntu1~ucd1~maverick package from daily ppa repository.
Ubuntu 64-bit, intel card. 
"--disable-accelerated-compositing" command-line option works, but puts heavy load on cpu (which is expected if you disable gpu acceleration).
Don't know if it has anything to do with the issue, but console messages appear:
[27886:27886:71467576587:ERROR:base/native_library_linux.cc(32)] dlopen failed when trying to open libGLESv2.so: libGLESv2.so: cannot open shared object file: No such file or directory
[25873:28061:71471403050:ERROR:media/audio/linux/alsa_output.cc(725)] Failed querying delay: Input/output error
[25873:28061:71471403360:ERROR:media/audio/linux/alsa_output.cc(725)] Failed querying delay: Input/output error
Nov 19, 2010
#68 vange...@google.com
simon.schaak, myrcek:  Would you mind trying another page that will trigger the compositor such as this one:

http://webkit.org/blog-files/3d-transforms/poster-circle.html

and tell us whether you're seeing any pink-ness there too?  Trying to figure out if it's an issue with the compositor or the shaders used for video.  Thanks!

Nov 19, 2010
#69 simon.sc...@gmail.com
I don't see any problem for that one.
Nov 19, 2010
#70 pat...@gmail.com
The poster-circle demo also works fine on nouveau with acceleration enabled (with accel disabled it's no longer 3D but the colors are the same).
Nov 20, 2010
#71 giordano...@gmail.com
uhm, here the loading of html5 video still hangs the tab, unless I disable accelerated compositing. Same behaviour for
http://webkit.org/blog-files/3d-transforms/poster-circle.html


9.0.590.0 (66727) Ubuntu 10.10, but I'm experiencing this behaviour since at least 65479. Maybe I need to open another issue, or report on  issue 62581 ?
Nov 20, 2010
#72 ale...@gurianov.com
Still has pink video. Ubuntu 10.10, Chrome 9.0.587.0 dev, Radeoh HD
3470 - without proprietary drivers.
Nov 21, 2010
#73 ryazanov
 Issue 63990  has been merged into this issue.
Nov 24, 2010
#74 vrk@google.com
To the people who used to have the bug, but now do not: Can you reproduce it when you run one of the oldest nightly builds?
http://build.chromium.org/f/chromium/snapshots/
Nov 24, 2010
#75 claudiobastos@gmail.com
Tested with chromiun snapshots: 

63200 (8.0...)
 pink layer with gpu accelerated canvas 2d DEACTIVATED
 pink layer with gpu accelerated canvas 2d activated


67332 (9.0.594.0)
no pink layer with gpu accelerated canvas 2d DEACTIVATED
no pink layer with gpu accelerated canvas 2d activated





Nov 24, 2010
#76 Mikhail....@gmail.com
Ubuntu 10.10, Google Chrome 9.0.587.0 dev
nVidia 8800GT               - no pink layer
ATI Mobility Radeon HD 4225 - no pink layer
Intel 910GM                 - has pink layer
Nov 29, 2010
#77 vrk@google.com
@claudiobastos: If you are willing, could you bisect the builds to find the exact builds at which the pink layer gets fixed? This would be an *enormous* help to fixing the bug!!

By "bisect" I mean you should do binary search on the builds to see which one is the magic revision. So, try the revision roughly in the center between 63200 and 67332 (65264ish), and if that version of Chrome does not have the pink bug, then try the version between 63200 and 65264 to find a version that has the pink bug, etc. until you narrow down the 2 revisions. 

I promise that it shouldn't take more than about 12-13 downloads :) Or if that's too annoying, if you could just download a couple of the versions to help narrow down the range of possible revisions, that would be awesome as well!!

For the life of me I can't seem to reproduce this bug, even with the same hardware and drivers and chrome builds and OS as people above... so if claudiobastos or someone else could do this, we could maybe figure out how to fix it for everyone!
Nov 29, 2010
#78 claudiobastos@gmail.com
Are you serious?
...
some time later

build 65120 fail
pink layer with and without gpu accelerated canvas 2d activated

build 65143 works
No pink layer 
with and without gpu accelerated canvas 2d activated

;-)



Dec 5, 2010
#79 ignacio...@gmail.com
Google Chrome 9.0.597.0 dev
Intel HD Graphics (i.e. the one stuck to the Core i3 CPU)
Kubuntu 10.10 (recently installed)

Guess why I'm here: pink html5 video, both WebM and h264. "Disable accelerated compositing"?? forget it, this is a laptop and I ain't no pyromaniac D:

Also, as any CSS hack out there, that "poster circle" is AWESOME!!!.... oh the irony, the rings are purple!! :P after opening the inspector and changing the colors to brown, I confirm it works fine.
Dec 6, 2010
#80 fth...@gmail.com
In reply to #c44: After some time and the following changes, video and sound all good with/out --enable-accelerated-2d-canvas and/or --disable-accelerated-compositing switches.

Chrome Version: Chrome/8.0.552.215
USE flags: gecko-mediaplayer gnome-keyring system-sqlite -cups -gnome 
OS: Linux 2.6.36-ck-r3 GNU/Linux -- Gentoo Base System release 2.0.1-r1 32-bit
WM: E17

Thanks for the work. 


Dec 12, 2010
#81 Mikhail....@gmail.com
This problem also affects all free nVidia and AMD drivers.
Dec 21, 2010
#82 alejandro.mery.pellegrini
Problem persist in 9.0.570.1 dev Ubuntu 10.10/64
Jan 5, 2011
#83 scherkus@chromium.org
#81 and #82 can you try testing with Chrome 10?
Jan 5, 2011
#84 am...@geeks.cl
@scherkus: If you tell me what to use as ppa/package_name or point me to the .deb I would gladly test (using ubuntu 10.10/amd64)
Jan 6, 2011
#85 simon.sc...@gmail.com
The pink layer is now gone for me.

I also tested with --enable-accelerated-2d-canvas, which seems to work, but I get this message when playing html5 video on youtube:
$ google-chrome --enable-accelerated-2d-canvas
libEGL warning: unable to load st_GL.so
/opt/google/chrome/chrome --type=gpu-process --channel=4262.0x61756e0.42587550: symbol lookup error: /usr/lib/egl/egl_gallium.so: undefined symbol: drmGetMagic

plus, trying to enter a comment here with this flag set ends in a non-responsive tab :(

Ubuntu 10.10 64bit, Intel GMA4500 / Radeon HD 3470 (seens to work fine with both, each time with and without --enable-accelerated-2d-canvas)
Jan 6, 2011
#86 am...@geeks.cl
@scherkus: bug gone in "10.0.628.0 dev" :-) vimeo's and youtube's html5 player show no pink layer for me now.
Jan 6, 2011
#87 Mikhail....@gmail.com
For me nothing changed. Pink layer continues over video. For example: http://www.youtube.com/watch?v=jdqvZ2dP6AQ
Jan 6, 2011
#88 vange...@google.com
@simon.schaak & amery : Would you mind trying it with --enable-accelerated-layers too?  Gpu-accelerated video is currently off by default unless that flag is supplied.  Thanks.


Jan 6, 2011
#89 am...@geeks.cl
I'm not getting the pink either, but I don't know if I'm getting the accelerated layers either because of:

[11325:11325:27068211705:ERROR:native_library_linux.cc(32)] dlopen failed when trying to open libGLESv2.so: libGLESv2.so: cannot open shared object file: No such file or directory

Jan 6, 2011
#90 vange...@google.com
@amery:  Thanks for following up. That warning is benign. There are two ways to verify you're using accelerated compositing/video:
1. (most accurate) Start chrome with --show-composited-layer-borders . You should see red, yellow and blue borders around the composited layers and the video element.
2. Open up the task manager and look for a GPU process in the list of processes.


Jan 6, 2011
#91 am...@geeks.cl
@vangelis: I see red and yellow borders and no pink :-)

Google Chrome	10.0.628.0 (Official Build 70488) dev
WebKit	534.16
V8	3.0.4.1
User Agent	Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.628.0 Safari/534.16
Command Line	 /usr/bin/google-chrome --enable-accelerated-layers --show-composited-layer-borders --flag-switches-begin --flag-switches-end
Jan 6, 2011
#92 vange...@google.com
@amery:  Great! Thanks for confirming that it now works in 10.0 . Did you change anything in your gpu setup?  Would you mind re-confirming that the pink layer is there with a 9.0 release (with --enable-accelerated-layers and --show-composited-layer-borders) ? 
Jan 6, 2011
#93 am...@geeks.cl
no system change, I first confirmed I had pink videos on vimeo and youtube, then  upgraded my google-chrome-unstable 9.whatever with the lastested .deb and restarted chrome three times, once from the icon (no args) then --enable-accelerated-layers and finally --enable-accelerated-layers --show-composited-layer-borders. none of these three runs gave me pink videos.
Jan 6, 2011
#94 am...@geeks.cl
oops, misread. I'll downgrade now and see
Jan 6, 2011
#95 am...@geeks.cl
@vangelis: not sure if it's good or bad news. uninstalled 10.0, installed the lastest beta (9.0.597.44 (Official Build 70439) beta) and couldn't reproduce the bug again.

I had the problem in 9.0.570.1 dev (and before), but I don't have that .deb anymore

Jan 6, 2011
#96 am...@geeks.cl
aarg... this thing is playing with me. I have pink in 9.0.597.44 official build 70439 now too
Jan 6, 2011
#97 Mikhail....@gmail.com
@amery: This bug not reproduce on any youtube videos. I still recommend use my example link for testing.
Jan 6, 2011
#98 am...@geeks.cl
I'm using http://www.youtube.com/watch?v=Pz30WRg2JBo (in html5 mode) for testing.

I'm been able to reproduce the weirdness, If I call "/opt/google/chrome/google-chrome --enable-accelerated-layers --show-composited-layer-borders" from a laucher I get pink every time, but if I do it from a terminal it doesn't....

same with 10.0.628.0 (Build oficial 70488) dev

in both cases (pink and not pink) about: except that the pink one is in spanish and the not-pink in english

Jan 6, 2011
#99 am...@geeks.cl
no pink when:
LANG=es_ES /opt/google/chrome/google-chrome --enable-accelerated-layers --show-composited-layer-borders

pink when:
LANG=es_ES.UTF-8 /opt/google/chrome/google-chrome --enable-accelerated-layers --show-composited-layer-borders
Jan 6, 2011
#100 am...@geeks.cl
@Mikhail: the UTF-8 thing also makes the difference when playing your video, http://www.youtube.com/watch?v=jdqvZ2dP6AQ
Jan 6, 2011
#101 Mikhail....@gmail.com

@amery:
Very interesting because for me too
no pink:   LANG=ru_RU
pink when: LANG=ru_RU.UTF-8
but I think LANG=ru_RU also as LANG=es_ES incorrect in Ubuntu, because list locales by command locale did not contain non UTF-8 locales.
My list:
mikhail@mikhail-P5K:~/www/lvd$ locale
LANG=ru_RU.UTF-8
LANGUAGE=en_US:en
LC_CTYPE="ru_RU.UTF-8"
LC_NUMERIC="ru_RU.UTF-8"
LC_TIME="ru_RU.UTF-8"
LC_COLLATE="ru_RU.UTF-8"
LC_MONETARY="ru_RU.UTF-8"
LC_MESSAGES=en_US.utf8
LC_PAPER="ru_RU.UTF-8"
LC_NAME="ru_RU.UTF-8"
LC_ADDRESS="ru_RU.UTF-8"
LC_TELEPHONE="ru_RU.UTF-8"
LC_MEASUREMENT="ru_RU.UTF-8"
LC_IDENTIFICATION="ru_RU.UTF-8"
LC_ALL=
And when you launch Google Chrome with LANG=es_ES you should see error message:

(process:2476): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.

(process:2598): Gtk-WARNING **: Locale not supported by C library.
	Using the fallback 'C' locale.
Jan 7, 2011
#102 simon.sc...@gmail.com
@vangelis (#88)

With --enable-accelerated-layers the whole tab hangs (unresponsive page dialog pops up), waiting won't help. The page looks like it's loaded over a slow connection, only parts of it are displayed. Scrolling is ignored. Even this page hangs this way.

This is what I get on my terminal btw:
libEGL warning: unable to load st_GL.so
/opt/google/chrome/chrome --type=gpu-process --channel=18421.0x560eb00.1041490253: symbol lookup error: /usr/lib/egl/egl_gallium.so: undefined symbol: drmGetMagic
Jan 7, 2011
#103 am...@geeks.cl
@vangelis: does it make any sense to you that Mikhail and I get pink in the lastest 10.0 when using UTF-8 encoding but working fine when falling back to C regardless if it's webm or h264?
Jan 7, 2011
#104 vange...@google.com
@simon (#88):  Thanks for reporting. Is that with the GMA or the Radeon GPU ? 
@amery (#103): It makes no sense at all but it's a great find! :) We'll look into it
Jan 7, 2011
#105 simon.sc...@gmail.com
that was with the GMA only
Jan 7, 2011
#106 vange...@google.com
Thanks, Simon.
zmo: another blacklist candidate! (see #102, #105)
Cc: z...@chromium.org
Jan 12, 2011
#108 am...@geeks.cl
In my case 10.0.634.0/70875 gives me pink (when LANG=es_ES.UTF-8) even when using --disable-accelerated-layers!!

no pink when locale falls back to C

driver is i915, ubuntu 10.10/64
Jan 20, 2011
#109 simon.sc...@gmail.com
...the pink is back again :(

I updated today to 10.0.642.2 (Official Build 71689) dev
Jan 20, 2011
#110 simon.sc...@gmail.com
I just downgraded to 10.0.634.0, r70875 and everything is fine again.
Jan 20, 2011
#111 vange...@google.com
@simon: Are you running with or without --enable-accelerated-layers ? 
Also, does the LANG setting affect what you're seeing, as reported in #101 and others? 

Thanks
Jan 20, 2011
#112 simon.sc...@gmail.com
back with 10.0.642.2 - yep, LANG is affecting this for me as well.
works with LANG=en_US.utf8, doesn't work with de_DE.utf8.

--enable-accelerated-layers doesn't change anything (with de_DE it's still broken, with en_US it's still working)
Jan 20, 2011
#113 am...@geeks.cl
@vangelis:
please notice (at least in ubuntu) you only get installed the english locales + your own, and everything else falls to C (or posix) for which it works pinkless, so for reproducing the bug you'll have to explicitly install the locales for a second language.
Jan 20, 2011
#114 am...@geeks.cl
and I wanted to add that --disable-accelerated-layers is still broken as of "10.0.642.2 (Build oficial 71689) dev" so we can't workaround this issue in the launchers anymore
Jan 20, 2011
#115 vange...@google.com
@amery: Recent trunk releases have accelerated video enabled by default. Turning it off requires using: --disable-accelerated-video  (there's no --disable-accelerated-layers flag)  .  Thanks for the tip regarding locales!

Jan 20, 2011
#116 am...@geeks.cl
thank you too, now my launcher opens a pinkless chrome again :-)
Jan 21, 2011
#117 Pitli...@gmail.com
If locale is affecting it, just try to set just LC_NUMERIC to en_US instead of whole LANG.

It seems related to similar issue in Google Earth: https://code.google.com/p/earth-issues/issues/detail?id=542 and 330.
Jan 21, 2011
#118 am...@geeks.cl
#117: I confirm LANG=es_ES.UTF-8 LC_NUMERIC=C works well here, so there is something chrome is parsing which is been affected by the comma decimal delimiter in es_ES, de_DE, ru_RU, ...
Jan 21, 2011
#119 *sjl@chromium.org
Could it be that the shader is being parsed incorrectly?
http://www.google.com/search?q=shader+LC_NUMERIC yields lots of (old) issues...
Jan 21, 2011
#120 towolf
Respecting LC_NUMERIC and its decimal separator is also the problem in  issue #39964 .
It’s the reason I set LC_NUMERIC=C because it remains unfixed. Mabye a general solution is needed.
Jan 22, 2011
#121 Pitli...@gmail.com
But it's probably also driver or architecture dependent. I'm using cs_CZ locale, where comma is decimal separator, and I'm not having this issue with my nVidia card on 64bit Ubuntu.
Jan 24, 2011
#122 scherkus@chromium.org
We've previously had really strange issues with locales but I wasn't sure how to repro the bug.

See  issue 39964 .
Jan 27, 2011
#123 kerz@google.com
Move to M11 from M10, as we've now branched.  If you believe this bug was moved in error, please come talk to me.
Labels: -Mstone-10 Mstone-11 MovedFrom-10
Jan 27, 2011
#124 am...@geeks.cl
sad choice
Jan 27, 2011
#125 kerz@google.com
Moving back.
Labels: -Mstone-11 -MovedFrom-10 Mstone-10 ReleaseBlock-Stable
Jan 28, 2011
#126 vrk@chromium.org
I CAN REPRODUCE THE BUG NOW!!

True story: Yesterday night I tried to boot into my personal linux box. Gdm was messed up and wouldn't load. Tried a bunch of things to get it working, reinstalling gdm and xorg, installing kdm and seeing if that would work, trying different drivers, etc. The best I could do was get "failsafe mode" working. Then after all that mucking around, I was like, hmm, wonder if I can reproduce pink bug now.

Yes, yes I can. I can reproduce it on 8.0.552.237 with LC_NUMERIC=ru_RU! Seems to be fixed in later versions and ToT. 

Anyway, I am downloading the src for 552 on my home machine and going to try to debug, see what the heck is/was causing the problem. Since it's fixed on the most recent chrome, my guess is it's some combination of driver + the way we were handling locale.
Jan 28, 2011
#127 vrk@chromium.org
(No comment was entered for this change.)
Status: Started
Jan 28, 2011
#128 am...@geeks.cl
great news! hunt it down! :D
Jan 30, 2011
#129 nhopf...@htwm.de
Got the same problem here by updating to Ubuntu 10.10 Maverick and Chromium 11.0.652. Never had it before, but using Chromium for around half a year, cause of the html5-support.
Feb 2, 2011
#130 scherkus@chromium.org
vrk has a fix in the works!!!!!!
Feb 3, 2011
#132 vrk@chromium.org
FYI to the audience: the problem I was encountering was because my driver didn't like having literal values in the shader code, and in particular screwed up when the locale was changed because it read 0.5 -> 0,5 and then just ignored the 5, took the 0.

So if anyone *still* has a problem after this patch lands (hasn't landed quite yet - currently in WebKit CQ, then I have to merge into m10), they should open a new bug because it is from a different cause.
Summary: Literal values in shaders cause a pink layer over all html5 videos
Feb 3, 2011
#133 am...@geeks.cl
btw, there is a tiny in the patch, a missing ')' in:
gl_FragColor = vec4(rgb, float(1) * alpha;
Feb 3, 2011
#134 vrk@google.com
Whoops, thanks for the catch! Fixed!
Feb 4, 2011
#135 nhopf...@htwm.de
How to enable the patch? Or is it in all the latest daily-builts included? I still got the problem with 11.0.659.0 (73746) Ubuntu 10.10 - is it another bug?
Feb 8, 2011
#136 nhopf...@htwm.de
great - bug's gone :-)
Feb 8, 2011
#137 vrk@chromium.org
Merged into 648!

And should be fixed as of Chromium r73795.
Status: Fixed
Feb 9, 2011
#138 am...@geeks.cl
At least in 10.0.648.45 (Build oficial 74092) dev, I'm still getting pink with:

LANG=es_ES.UTF-8 /opt/google/chrome/google-chrome --show-composited-layer-borders --flag-switches-begin --flag-switches-end

:(

Feb 9, 2011
#139 Pitli...@gmail.com
Yup, still pink on my laptop with Intel card and cs_CZ locale.
Feb 9, 2011
#140 vrk@chromium.org
Oops, sorry, I gave misleading information! Should be fixed in 10.0.648.49 and later. Dev channel hasn't gotten this update yet.

(It's fixed in 73746 and later if you are building from source code)
Feb 17, 2011
#141 am...@geeks.cl
10.0.648.82 (Build oficial 75062) dev
LANG=es_ES.UTF-8 /opt/google/chrome/google-chrome --show-composited-layer-borders

working pinkless in vimeo and youtube with html5 player! thanks! (and yes, the borders are there)
Feb 17, 2011
#142 Pitli...@gmail.com
Yup, fixed for me too.
Mar 3, 2011
#143 pat...@gmail.com
Using 11.0.679.0 and nouveau drivers, everything works fine when I run chromium with LC_ALL=C. Pink appears over everything including flash when using pl_PL.utf8.
Mar 9, 2011
#144 Pitli...@gmail.com
Pink HTML5 video is back in 11.0.686.3! :(

Again, Intel is pink, nVidia is ok.
Mar 9, 2011
#145 Pitli...@gmail.com
Flash YouTube video is pink too.
Mar 9, 2011
#146 vrk@chromium.org
If you're seeing pink again, please make a new bug with new screenshots! :) It is highly unlikely to be from the same root problem caused by this original bug, so this will make triaging easier.

(Also, can you make extra sure that this is happening on Flash _and_ HTML5 videos?)
Mar 9, 2011
#147 lucian.g...@gmail.com
I also experienced the html5 bug described here and am now seeing the new flash-related one.

I opened  issue #75528  for the new pink-flash bug, and have provided reproduction info + screenshots there.

I'm sending a notice here so that we don't open too many bugs for this issue, and so that the interested parties can easily find the new bug.
Apr 3, 2011
#148 naeem...@gmail.com
Hi, I was facing the same problem, but it is now resolved after the installation on "Flash Player 10.3.180.65 Beta 2".

Oct 12, 2012
#149 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Blockedon: -chromium:62581 chromium:62581
Mar 10, 2013
#150 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-WebKit -Feature-Media -Feature-GPU-Video -Mstone-10 Cr-Content Cr-Internals-Media M-10 Cr-Internals-GPU-Video
Mar 13, 2013
#151 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Apr 5, 2013
#152 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content Cr-Blink
Sign in to add a comment

Powered by Google Project Hosting