My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 51926: 'Open tab in new window' in tab-menu
4 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 207971
Owner:  ----
Closed:  Aug 2013


Sign in to add a comment
 
Reported by Gabor.Ah...@googlemail.com, Aug 12, 2010
Chrome Version       : 5.0.375.125
URLs (if applicable) :
Other browsers tested:

  Firefox 3.x:OK


In the right-click-menu of a tab there should be an option "Open this tab in new window."
Aug 12, 2010
#1 megazzt
What's wrong with clicking the dragging the tab out of the window?
Aug 13, 2010
#2 Gabor.Ah...@googlemail.com
@megazzt:
1. Usability:
Some people don't like dragging. And on some UI-configurations in Windows it's even problematic.

2. Accessibility:
Handicaped / impaired people often have big problems or even are not move the mouse while holding a mouse key pressed.

Some of them can't even use the mouse and move the cursor with the keyboard.

The same for older people: 
E.g. my grandma: she can move the mouse, click, and so on. But she has big problems with dragging (keep the mouse key pressed while moving the mouse). (And she has problems with double-clicks, but that's another story.) And many older users have exactly the same problems.

And I strongly believe, that a product should not only be for young and healthy people, but also for older and/or handicaped and impaired people.

Aug 15, 2010
#3 stuartmorgan@chromium.org
(No comment was entered for this change.)
Labels: -Type-Bug -Area-Undefined Type-Feature Area-UI Feature-TabStrip
Aug 16, 2010
#4 Gabor.Ah...@googlemail.com
And also remember, that even some young and healthy people don't like to drag. And with some devices (trackball, touchpad, ...) it's even not as easy as with a mouse.

Sep 12, 2010
#5 ctg...@chromium.org
(No comment was entered for this change.)
Labels: Feature-Accessibility
Jan 31, 2011
#6 tfar...@chromium.org
(No comment was entered for this change.)
Status: Available
Labels: OS-All
Mar 10, 2013
#7 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-UI -Feature-TabStrip -Feature-Accessibility Cr-UI-Accessibility Cr-UI-Browser-TabStrip Cr-UI
May 15, 2013
#8 nadira...@gmail.com
Any chance this can come with a shortcut as well.
Aug 27, 2013
#9 kenjibaheux@chromium.org
The a11y aspects should be addressed by mouse lock (This is issue 207971) and the existing tap dragging feature found in the a11y section of settings.


tap dragging: 
 1. "tap - release finger - tap - maintain finger on trackpad steady for a split second" to trigger the tap dragging mode. 
 2. from there move your finger to drag around.


Let me close this as a duplicate of 207971 (same root cause).
Status: Duplicate
Mergedinto: 207971
Sign in to add a comment

Powered by Google Project Hosting