My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 49621: some downloaded files are saved with double extension (ex: file.arj.arj)
28 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Owner:  thakis@chromium.org
Closed:  Sep 2010
Cc:  kinuko@chromium.org, phajdan.jr@chromium.org, abarth@chromium.org, est...@chromium.org

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by cony2you@gmail.com, Jul 20, 2010
Chrome Version       : 6.0.472.0 (53017)
URLs (if applicable) :
Other browsers tested: IE8
Add OK or FAIL after other browsers where you have tested this issue:
Safari 4:
Firefox 3.x:
IE 7:
         IE 8: OK

What steps will reproduce the problem?
1. Open for example ftp.microsoft.com
2. go to folder /MISC/ for example
3. try to download file PRODUCT.TBL

What is the expected result?
file PRODUCT.TBL to be shown in the download manager / folder

What happens instead?
file PRODUCT.TBL.TBL is shown in the download manager / folder

Please provide any additional information below. Attach a screenshot if
possible.

This is not happening for txt or exe files

error.png
49.6 KB   View   Download
Jul 20, 2010
#1 mkte...@gmail.com
 Issue 49480  has been merged into this issue.
Jul 20, 2010
#2 mkte...@gmail.com
 Issue 49480  reported this happening on 6.0.466.0 with .zip and .rar extensions as well.
Status: Untriaged
Labels: Feature-Downloads
Jul 20, 2010
#3 marfabi...@gmail.com
Just to be clear: 

Reported by marfabilis, Jul 18 (41 hours ago) 6.0.466.0
Reported by cony2you, Today (11 hours ago) 6.0.472.0

30 hours later and I've got a duplicate post LOL..OK
The most important thing is that it can be fixed.

Regards,

Marco

Jul 20, 2010
#4 thakis@chromium.org
Related to your renaming CL?
Cc: kin...@chromium.org
Labels: -Pri-2 -Area-Undefined Pri-1 Area-UI Regression
Jul 20, 2010
#5 est...@chromium.org
once again, not related
Status: Duplicate
Mergedinto: 48346
Jul 20, 2010
#6 thakis@chromium.org
I'll just blame every new download bug on kinuko :-P
Jul 22, 2010
#7 marfabi...@gmail.com
Not fixed yet.
This issue is also occuring with .KEY and .OTF files
Jul 22, 2010
#8 est...@chromium.org
my mistake, I don't think this is actually related to  bug 48346 
Status: Unconfirmed
Labels: -Pri-1 -Regression Pri-2 OS-Windows
Mergedinto: -48346
Jul 22, 2010
#9 dhw@chromium.org
 Issue 49903  has been merged into this issue.
Jul 22, 2010
#10 est...@chromium.org
on second thought, I am siding with thakis. I guess I got this mixed up with 48346; should have been more careful about duping it.
Status: Assigned
Owner: kin...@chromium.org
Cc: -kin...@chromium.org
Labels: -Pri-2 Pri-1 Regression
Jul 22, 2010
#11 kinuko@chromium.org
Hmm the original bug was reported before I submitted my patch, so I don't think this is a regression of my change - or so I hope.  (Trying to look at it but currently I have some problems on my Windows build)

Jul 22, 2010
#12 marfabi...@gmail.com
Google Chrome	6.0.472.0 (53024) dev
WebKit:	534.3
V8:	2.3.1
Jul 22, 2010
#13 kinuko@chromium.org
Seems like I hit another bug ( issue 49997 ) while testing this.

Jul 22, 2010
#14 marfabi...@gmail.com
I can´t reproduce that bug here.
Jul 22, 2010
#15 kinuko@chromium.org
I don't know why but I cannot reproduce this (double extension) on my build.   Does that have some other conditions to reproduce?

Tested url: ftp://ftp.microsoft.com/MISC/PRODUCT.TBL
Chromium:	6.0.475.0 (Developer Build 53413)
WebKit:	534.3
V8:	2.3.2

Owner: ---
Cc: kin...@chromium.org
Jul 22, 2010
#16 marfabi...@gmail.com
Maybe coz you´re using the version 6.0.475.0 (Developer Build 53413)
This issue occurs in 6.0.466 & 6.0.472 (.zip, .rar, .otf, .key and others)
Jul 22, 2010
#17 guo888x...@gmail.com
if you choose 'all files', chromium won't automatically add extension.
Jul 22, 2010
#18 est...@chromium.org
I was able to repro with the steps from one of the other reports. Right click->save as on one of the .emp links at http://empop.org/modules/downloads/ on Windows (not Linux), it will save with .emp.emp. I managed it with r53429.
Status: Available
Jul 23, 2010
#19 est...@chromium.org
a bisection reveals the regression to have occurred between r51869 and r51878; I strongly suspect r51870: http://codereview.chromium.org/2893001

Status: Assigned
Owner: pkast...@chromium.org
Jul 23, 2010
#20 pkasting@chromium.org
I just committed this on behalf of an external contributor.  It would be nice if someone else could debug this as I'm really way overwhelmed right now.
Labels: Mstone-6 ReleaseBlock-Stable
Jul 23, 2010
#21 est...@chromium.org
If that's the case, I'd say reverting is the best option, and letting the external contributor fix it and resubmit.
Jul 24, 2010
#22 mkte...@gmail.com
 Issue 50122  has been merged into this issue.
Jul 26, 2010
#23 dhw@chromium.org
 Issue 50202  has been merged into this issue.
Jul 26, 2010
#24 dhw@chromium.org
 Issue 50158  has been merged into this issue.
Jul 26, 2010
#25 thakis@chromium.org
This needs to be fixed for m6. I'll see that I at least get the regressing CL reverted on the branch.
Owner: tha...@chromium.org
Cc: phajdan...@chromium.org
Jul 26, 2010
#26 mkte...@gmail.com
 Issue 50270  has been merged into this issue.
Jul 27, 2010
#27 est...@chromium.org
 Issue 50449  has been merged into this issue.
Jul 28, 2010
#28 marfabi...@gmail.com
6.0.472.11 dev
Not fixed.
Jul 29, 2010
#29 mkte...@gmail.com
 Issue 50614  has been merged into this issue.
Jul 29, 2010
#30 correnthean@gmail.com
Can confirm this issue on 6.0.472.11 dev on win7 x64
Aug 1, 2010
#31 Satoshi.Matsuzaki@gmail.com
 Issue 50889  has been merged into this issue.
Aug 1, 2010
#32 a.rain...@gmail.com
6.0.472.14 dev not fixed :(
Aug 2, 2010
#33 thakis@chromium.org
Guys, nobody says this has been fixed. Silently star bugs you're interested in. Saying "not fixed" on bugs that are still open doesn't help anyone.
Status: Started
Aug 2, 2010
#34 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=54625 

------------------------------------------------------------------------
r54625 | thakis@chromium.org | 2010-08-02 15:56:40 -0700 (Mon, 02 Aug 2010) | 6 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/views/shell_dialogs_win.cc?r1=54625&r2=54624
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/views/shell_dialogs_win_unittest.cc?r1=54625&r2=54624

Win: Don't give some downloads duplicate extensions like .arj.arj

BUG=49621
TEST=See bug. Also unittests.

Review URL: http://codereview.chromium.org/3069018
------------------------------------------------------------------------

Aug 2, 2010
#35 thakis@chromium.org
(No comment was entered for this change.)
Labels: ForMerge
Aug 3, 2010
#36 thakis@chromium.org
As usual, "Fixed" means that the fix has landed. It does not mean that the landed fix is on the dev channel yet. That will take a week or two.
Status: Fixed
Aug 3, 2010
#37 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=54803 

------------------------------------------------------------------------
r54803 | thakis@chromium.org | 2010-08-03 13:10:29 -0700 (Tue, 03 Aug 2010) | 9 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/472/src/chrome/browser/views/shell_dialogs_win.cc?r1=54803&r2=54802
   M http://src.chromium.org/viewvc/chrome/branches/472/src/chrome/browser/views/shell_dialogs_win_unittest.cc?r1=54803&r2=54802

Merge 54625 - Win: Don't give some downloads duplicate extensions like .arj.arj

BUG=49621
TEST=See bug. Also unittests.

Review URL: http://codereview.chromium.org/3069018

TBR=thakis@chromium.org
Review URL: http://codereview.chromium.org/2868101
------------------------------------------------------------------------

Aug 4, 2010
#38 bengmedi...@gmail.com
why is that google chrome not load  the specific sight...i mean  nothing at all
Aug 5, 2010
#39 logosZ...@gmail.com
fixed with version 6.0.472.22
http://googlechromereleases.blogspot.com/2010/08/dev-channel-update.html

...and confirming, just checked.

Aug 22, 2010
#40 BoEllisA...@gmail.com
This has only been partially fixed. Could this be re-opened?

Steps to reproduce problem:

1. Right-click a .tar.bz2 file 
2. Click Save link as...
2. Save it.
3. You will see it has a duplicate file extension (.tar.bz2.tar.bz2)

PDF Files are OK but I've not tested any other file extension. Downloading the file without using Save link as... does not give a duplicate file extension.
Aug 22, 2010
#41 BoEllisA...@gmail.com
(Quick Note) I am using 6.0.495.0 (Official Build 56152) dev.
Aug 22, 2010
#42 BoEllisA...@gmail.com
(Another Quick Note) Checking "Ask where to save each file before downloading" in Options also gives duplicate extensions (.tar.bz2.tar.bz2)
Aug 22, 2010
#43 thakis@google.com
boellisa…: are you on linux?
Aug 22, 2010
#44 BoEllisA...@gmail.com
No. I'm using Windows XP SP3.
Aug 22, 2010
#45 thakis@google.com
Thanks. Can you check if the problem happens with http://build.chromium.org/buildbot/continuous/win/2010-07-06/51698/chrome-win32.zip as well?
Aug 22, 2010
#46 BoEllisA...@gmail.com
Are you wanting me to test that download or test a file using that version of Chomium?
Aug 22, 2010
#47 thakis@google.com
Please download that version of chromium and then using that version of chromium, download a tar.bz2 file and see if you get a duplicate tar.bz2 extension.
Aug 22, 2010
#48 thakis@google.com
Please download that version of chromium and then using that version of chromium, download a tar.bz2 file and see if you get a duplicate tar.bz2 extension.
Aug 23, 2010
#49 BoEllisA...@gmail.com
Nope. That version doesn't have the .tar.bz2 problem. 

While testing this, I ran into 2 other bugs. They are  Issue 53105  (which does not happen in chromium r51698, only Chrome 6.0.495.0 dev) and  Issue 53106  (which happens in both chromium r51698 and Chrome 6.0.495.0 dev).
Aug 23, 2010
#50 thakis@chromium.org
(No comment was entered for this change.)
Status: Available
Labels: -Mstone-6 Mstone-7
Aug 23, 2010
#51 kerz@chromium.org
(No comment was entered for this change.)
Labels: -ReleaseBlock-Stable
Aug 23, 2010
#52 kerz@chromium.org
(No comment was entered for this change.)
Labels: -ForMerge
Aug 23, 2010
#53 kerz@chromium.org
(No comment was entered for this change.)
Labels: ReleaseBlock-Stable
Aug 23, 2010
#54 kerz@chromium.org
(No comment was entered for this change.)
Labels: -ReleaseBlock-Stable
Aug 27, 2010
#55 thakis@chromium.org
Reprioritizing since double-extensions files aren't all that common in the windows world.
Labels: -Pri-1 -Mstone-7 Pri-3 Mstone-X HelpWanted GoodFirstBug
Sep 25, 2010
#56 rkat...@gmail.com
Another issue related to double extension:

What steps will reproduce the problem?
Case 1. Open the address: http://www.kattanweb.com/chrome/bug1.zip
Case 2. Open the address: http://www.kattanweb.com/chrome/bug2.ZIP (notice the capital letter extension)

What is the expected result?
In both cases you should download the desired file, keeping the same name

What happens instead?
Case 1: works as expected
Case 2: a file named " bug2 .ZIP.zip" is downloaded
Sep 26, 2010
#57 pnettles...@gmail.com
Relating to the zip extension bug....what version of windows and what version of chromium? 

I'm windows 7 and just built/ran the latest svn build and I can't reproduce it. Both bug1.zip and  bug2 .ZIP are downloaded, with no additional extension. 
Sep 27, 2010
#58 est...@chromium.org
I think this is another one that would be fixed if we got rid of the extension renaming code. Adam, before we go down that path, do we need a security review?
Cc: aba...@chromium.org est...@chromium.org
Sep 27, 2010
#59 abarth@chromium.org
I'm happy to review the patch for security.  :)
Sep 30, 2010
#60 est...@chromium.org
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 57080
Mar 18, 2011
#61 lafo...@chromium.org
Chrome Version       : 6.0.472.0 (53017)
<b>URLs (if applicable) :</b>
Other browsers tested: IE8
<b>Add OK or FAIL after other browsers where you have tested this issue:</b>
<b>Safari 4:</b>
<b>Firefox 3.x:</b>
<b>IE 7:</b>
         IE 8: OK

<b>What steps will reproduce the problem?</b>
1. Open for example ftp.microsoft.com
2. go to folder /MISC/ for example
3. try to download file PRODUCT.TBL

<b>What is the expected result?</b>
file PRODUCT.TBL to be shown in the download manager / folder

<b>What happens instead?</b>
file PRODUCT.TBL.TBL is shown in the download manager / folder

<b>Please provide any additional information below. Attach a screenshot if</b>
<b>possible.</b>

This is not happening for txt or exe files
Labels: -GoodFirstBug bulkmove Hotlist-GoodFirstBug
Mergedinto: -0
Mar 18, 2011
#62 lafo...@chromium.org
Chrome Version       : 6.0.472.0 (53017)
<b>URLs (if applicable) :</b>
Other browsers tested: IE8
<b>Add OK or FAIL after other browsers where you have tested this issue:</b>
<b>Safari 4:</b>
<b>Firefox 3.x:</b>
<b>IE 7:</b>
         IE 8: OK

<b>What steps will reproduce the problem?</b>
1. Open for example ftp.microsoft.com
2. go to folder /MISC/ for example
3. try to download file PRODUCT.TBL

<b>What is the expected result?</b>
file PRODUCT.TBL to be shown in the download manager / folder

<b>What happens instead?</b>
file PRODUCT.TBL.TBL is shown in the download manager / folder

<b>Please provide any additional information below. Attach a screenshot if</b>
<b>possible.</b>

This is not happening for txt or exe files
Labels: -Regression Type-Regression
Oct 12, 2012
#63 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mar 9, 2013
#64 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-UI -Feature-Downloads -Type-Regression Type-Bug-Regression Cr-UI Cr-UI-Browser-Downloads
Sign in to add a comment

Powered by Google Project Hosting