My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 4769: "Waiting for cache" message
388 people starred this issue.
Comments by non-members will not trigger notification emails to users who starred this issue.
Back to list
Status:  Fixed
Owner:  rvargas@chromium.org
Closed:  Jun 2010
Cc:  wtc@chromium.org, vandebo@chromium.org

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by phistuck, Nov 24, 2008
Chrome Version       : 0.4.154.25 (and long before)
URLs (if applicable) : any https with SSL errors
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 3: N\A
    Firefox 3: OK
         IE 7: OK

What steps will reproduce the problem?
1. Go to a website with SSL errors.
2. Do not proceed to the site.
3. Open a new tab with the same website.

What is the expected result?
The SSL interstitial will be shown.

What happens instead?
There is a "Waiting for cache" message in the 'status bar' and nothing is being 
loaded, until you decide what to do with the other interstitial is answered.


Nov 24, 2008
#1 phistuck
Also, there should be a possibility to ignore the SSL errors for specific websites that 
you always trust.
It exists in FireFox, though not in IE7. And since the FireFox approach is way better, 
please follow it.
( Issue 2010 )
Dec 8, 2008
#2 sroger...@gmail.com
I get this "waiting for cache" message trying to access Yahoo Mail, specifically when 
composing or reply to an email.  Using Chrome - 0.4.154.31
Dec 10, 2008
#3 pkasting@chromium.org
I just tried to mail my comments on a Chromium code review page, and got the throbber 
spinning forever with a "Waiting for cache..." message displayed indefinitely in the 
status bubble.

If it matters, I cleared my whole cache about a week ago, though I've been using the 
code review site quite a bit since then.
Summary: "Waiting for cache" message
Status: Untriaged
Owner: rvar...@chromium.org
Dec 10, 2008
#4 wtc@chromium.org
(No comment was entered for this change.)
Cc: w...@chromium.org
Dec 10, 2008
#5 lafo...@chromium.org
(No comment was entered for this change.)
Labels: -Area-Misc Area-BrowserUI
Dec 10, 2008
#6 rvargas@chromium.org
I looked at Peter's computer when we could reproduce the problem.

This message ("waiting for cache") is displayed when there is a request for resource 
xxx that is queued after another request for the same resource; the second request 
should be started when the first request completes.

The problem that I saw was that the first request is gone, as in the memory is now 
something else, not an HttpCache::Transaction, so it will never finish (any action 
will operate on random fields on the object).

This could be because we deleted the request and somehow didn't remove it from the 
list of active entries, or because some other piece of code simply overwrote the 
object.

For completeness, the object now appears to be related to ICU. the first part of the 
vtable is:

icu_3_8::AndConstraint::`scalar deleting destructor'
icu_3_8::RuleParser::`scalar deleting destructor'
icu_3_8::PluralKeywordEnumeration::`scalar deleting destructor'
icu_3_8::PluralKeywordEnumeration::getDynamicClassID 
WebCore::Event::clipboard 
icu_3_8::PluralKeywordEnumeration::count 
icu_3_8::StringEnumeration::next 
icu_3_8::StringEnumeration::unext 
icu_3_8::PluralKeywordEnumeration::snext 
icu_3_8::PluralKeywordEnumeration::reset 
icu_3_8::StringEnumeration::operator== 
icu_3_8::StringEnumeration::operator!= 
icu_3_8::PluralFormat::`scalar deleting destructor'
icu_3_8::PluralFormat::getDynamicClassID

Under normal circumstances, this message should be fairly short-lived, so most likely  
this issue is just the manifestation of some other bug (maybe something related to 
bugs 4731, 4749, 5325, or any other memory corruption).
Dec 12, 2008
#7 mic...@gmail.com
Several times over the past week or two I have received the "waiting for cache" 
message in Chrome 0.4.154.33.  When this happens attempting to do anything on any tab 
results in "waiting for cache" on that tab.  Restarting chrome seems to be the only 
resolution to the problem.
Dec 16, 2008
#8 lafo...@chromium.org
Based on the comments I'm going to reclassify this as a BrowserBackend bug, and set 
this to assigned.  Any sense if this issue will be resolved by the NewHTTP stack?
Status: Assigned
Labels: -Area-BrowserUI Area-BrowserBackend
Dec 16, 2008
#9 rvargas@chromium.org
This should not be related directly to the lower part of the network stack (so 
probably the new http stack wont help). However, there are a few fixes to potential 
memory corruptions on trunk that are not on the 154 branch.

A more likely cause is some interaction between the http cache and upper components 
of the chain (resource dispatcher host etc).
Dec 31, 2008
#11 ronhyoung@gmail.com
My PHP code/script reloads itself several times as I first copy a record (give it a 
new key) and then edit that same record when the script reloads.  Two or three 
iterations like that and the Waiting for Cache... message appears and I must close 
all instances of Chrome to get it to load any page related to that site.

This bug has forced me to halt development on Chrome and begin developing for IE 
again...YUK!
Dec 31, 2008
#12 twonky...@gmail.com
Happened once a while ago, but now three times in three days.  Clearing the cache 
manually is a workaround, but I've stopped using the browser until this is fixed.


Dec 31, 2008
#13 eoin.sco...@gmail.com
I also get "waiting for cache" interminably on some sites..... so it doesn't appear to be 
site specific problem. A lot of people have experienced the same problem... the page just 
will not load...so its back to IE for most of us. Unfortunately ... until its sorted. 
Jan 3, 2009
#14 kenley...@gmail.com
This problem's getting more severe for me. A lot of pages that I go to has this
problem now.
Jan 4, 2009
#15 andy...@gmail.com
I had this issue with https://mail.google.com/a/google.com.
- And it wouldn't go away (even when closing the tab, opening a new one for the same 
URL).
- And it didn't appear for other https services like docs or calendar.
- Neither for https://mail.google.com/ (my gmail account).
- Clearing cookies and browser cache, removing gears for google.com, mail.google.com, 
all did not help.
- I could still use corporate gmail in gmail's fallback, non AJAX mode.
- Firefox 3 did not show the same problem.
- Restarting the browser helped. I could access corporate gmail normally again.

Chrome version: 1.0.154.36
Jan 6, 2009
#16 CoinMag...@gmail.com
Same problem with waiting for cache. It could be related to advertising on the site 
however as it seems specific to only one website of mine: www.coinhunting.net
Jan 7, 2009
#17 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=7669 

------------------------------------------------------------------------
r7669 | rvargas@google.com | 2009-01-07 10:30:57 -0800 (Wed, 07 Jan 2009) | 11 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/net/http/http_cache.cc?r1=7669&r2=7668
   M http://src.chromium.org/viewvc/chrome/trunk/src/net/http/http_cache_unittest.cc?r1=7669&r2=7668

When there are multiple requests for the same resource, it is
possible that cancelling a request that is currently a reader
may be racing with another reader being completed.  In that
case, we were not removing the transaction for the cancelled
request so all queued requests were blocked forever. 

R=wtc
BUG=4769
TEST=unittest

Review URL: http://codereview.chromium.org/17217
------------------------------------------------------------------------

Summary: "Waiting for cache" message
Jan 7, 2009
#18 wtc@chromium.org
(No comment was entered for this change.)
Summary: "Waiting for cache" message
Jan 7, 2009
#19 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=7719 

------------------------------------------------------------------------
r7719 | mal@chromium.org | 2009-01-07 23:01:40 -0800 (Wed, 07 Jan 2009) | 12 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/chrome_official_branch/src/net/http/http_cache.cc?r1=7719&r2=7718
   M http://src.chromium.org/viewvc/chrome/branches/chrome_official_branch/src/net/http/http_cache_unittest.cc?r1=7719&r2=7718

Merge r7669 to a 154.43 release branch.

When there are multiple requests for the same resource, it is
possible that cancelling a request that is currently a reader
may be racing with another reader being completed.  In that
case, we were not removing the transaction for the cancelled
request so all queued requests were blocked forever. 

BUG=4769
TEST=unittest
TBR=rvargas
Review URL: http://codereview.chromium.org/17405
------------------------------------------------------------------------

Summary: "Waiting for cache" message
Jan 8, 2009
#20 rholthui...@live.nl
Really annoying bug! Using XAMPP (on localhost) and "waiting on cache..." all the 
time.
Unable to test my PHP projects on chrome now!!!!!!!!

Please fix quickly!
Jan 8, 2009
#21 wtc@chromium.org
(No comment was entered for this change.)
Summary: "Waiting for cache" message
Jan 8, 2009
#22 phistuck
Withdrawn from the release branch due to a non-compiling test. I guess we will have 
to wait.


Thank you, anyway.


PhistucK
Jan 8, 2009
#23 divyaa...@gmail.com
Same message for the orkut site.
Jan 12, 2009
#24 fxsu...@gmail.com
I get this message when composing an email in Yahoo! Web mail.
Jan 12, 2009
#25 andreab...@gmail.com
Please fix, this is so annoying!
Jan 12, 2009
#26 shapiroa...@sbcglobal.net
Same problem with Yahoo Mail cannot reply and "waiting for Cache" 
Jan 13, 2009
#27 stuartke...@gmail.com
Same problem opening a new message in Yahoo Mail 
Jan 15, 2009
#28 chrl...@gmail.com
This bug is a show stopper in my opinion.  It needs to be fixed ASAP.
Jan 15, 2009
#29 mmauws@gmail.com
Love this browser but, until this problem is fixed, I'll be using Firefox.
Jan 15, 2009
#30 phistuck
mmauws - if you are willing to let FireFox (3) take up all of your memory - go for it. :P
Jan 15, 2009
#31 ACook...@gmail.com
OK everyone check out the dev-channel Release Notes.  http://dev.chromium.org/getting-involved/dev-channel/release-notes

*[r7669]Fixes an issue where Chrome hangs "Waiting for cache" (Issue: 4769)

The commit is in.  I just hope the "Stable is a quarterly release" I saw somewhere 
isn't set in stone, so this can get pushed out soon rather than later.
Jan 15, 2009
#32 phistuck
They meant that new features will be released quarterly, though bug fix releases will still 
be rolled out whenever anything that matters is in.
Jan 15, 2009
#33 wtc@chromium.org
If you're still seeing this bug, please type "about:version"
in the location bar to get the version of Google Chrome you're
using.  Comment 19 shows that the latest Stable channel release
1.0.154.43 (Official Build 7746) should have the fix for this
bug.  Please let us know if you're still seeing this bug with
1.0.154.43.

Jan 15, 2009
#34 phistuck
Actually (unless it is not documented) - it should not be on 1.0.154.43 according to the 
release notes.
http://googlechromereleases.blogspot.com/2009/01/stable-beta-update-new-gears.html
Jan 15, 2009
#35 rvargas@chromium.org
A small correction to the last message:

The fix is included in the latest Dev channel release (2.0.157.0).
It is NOT part of the latest Stable channel release (1.0.154.43).
Jan 15, 2009
#36 dannydu...@gmail.com
i am running 2.0.157.0 on xp, and i have about a dozen tabs right now waiting on 
cache.
Jan 15, 2009
#37 rvargas@chromium.org
dannydulai: could you close Chrome and tell me if you see this problem after starting 
again?
Jan 15, 2009
#38 dannydu...@gmail.com
it was still broken (i had auto-start last visited tabs)

however, i closed the tabs and reopened them, and they seem to work now
Jan 15, 2009
#39 bill.van...@gmail.com
I get this a lot in Yahoo! mail.  Sometimes provoked by composing a message, 
sometimes not.  Sometimes closing Chrome and restarting fixes it, other times not.

At the moment, I've restarted Chrome, and am not getting the cache waiting message, 
but it's still not working right.  I'm trying to compose a message, but it won't 
focus the message body area for me to type into.  And that's only after switching 
between the Inbox and composition tabs to get it to display even the header fields.

Oh, and hotmail doesn't work at all.  Of course, that might be a different bug.

This is pretty much a showstopper for me.  So it's back to Firefox, where I have to 
restart it a lot just to take care of the leaking memory, but at least I can read my 
mail.

Running 1.0.154.43.
Jan 16, 2009
#40 LordSqu...@gmail.com
I'm using Chrome with all the cache and setting on a RAM disk.
I've notice this bug once before, when the RAM disk became full, and so increased the 
ram disk size, and the bug went away for a while.(until the ram disk got full again.)
I then manualy deleted old history files, and that seemed to fix it.
Now I got this bug again, and the RAM disk is full.


Jan 16, 2009
#41 phistuck
Still occurs in 2.0.157.2.
Thought it was fixed already...
Jan 16, 2009
#42 ij.syna...@gmail.com
None of the proposed fixes work. Drats. Plus I am having the problem reported by
bill.van.melle -- i.e., on trying to compose a message in yahoo mail, the area to
type into is not presented on screen. Back to Firefox. 
Jan 18, 2009
#43 john.lat...@gmail.com
This bug is starting to really annoy me.
Jan 18, 2009
#44 tweak...@gmail.com
the fixes do not work.. :( hello chrome team..do the needful to quash this bug ;)
Jan 19, 2009
#45 fshel...@gmail.com
craigslist gives the same "waiting for cache" error (and hotmail won't allow me to 
read mail, though it does load).

true that this forces one to use chrome as the browser of last resort (or second-to-
last resort, anyway)

good night, and good luck
Jan 20, 2009
#46 tbragin
Really annoying... happens for *a lot* of sites... causing a lot of frustration
Jan 20, 2009
#47 rvargas@chromium.org
phistuck: I created issue 6697 to track your original bug. Having "waiting for cache" 
while waiting for the interstitial page is sort of the expected behavior and it has 
not been fixed. As you pointed out, everything goes back to normal after making a 
selection on the interstitial page.

This issue is tracking an unrecoverable error (ok, recoverable by restarting the 
application) that prevent access to a random page. As mentioned in comment 35, the 
problem should be fixed ONLY on the dev channel. If somebody is still having this 
problem with that build (2.0.157.x) please let us know (a reproduction scenario would 
be great).
Jan 20, 2009
#48 chris.ely@gmail.com
I'm not sure when I first noticed this problem but I think it was around the time 
stable went from .36 to .39. It's really annoying because it prevents me from logging 
into a control panel I need to use every day at work.

I've discovered a workable solution and I'm using a chromium build without any 
problems... Maybe this will help others that are finding the stable builds too much 
to deal with.

Here is the output I get from chromium when I type "about:version" in the location 
bar:

Chromium	1.0.155.0 (Developer Build 7178)
WebKit	528.7
V8	0.4.6
User Agent	Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US) AppleWebKit/528.7 
(KHTML, like Gecko) Chrome/1.0.155.0 Safari/528.7
Jan 21, 2009
#49 phajdan.jr@chromium.org
 Issue 6695  has been merged into this issue.
Jan 21, 2009
#50 owenblac...@gmail.com
This isn't just with SSL pages. I get this with a substantial proportion of the 
Internet and it's getting to the point where I might have to ditch Chrome and go back 
to Firefox, which I really don't want to do. This bug prevents me from doing quite a 
few things I do regularly.

Will someone please actually fix this please?!
Jan 21, 2009
#52 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=8418 

------------------------------------------------------------------------
r8418 | rvargas@google.com | 2009-01-21 15:54:07 -0800 (Wed, 21 Jan 2009) | 8 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/release_154.next/src/net/http/http_cache.cc?r1=8418&r2=8417
   M http://src.chromium.org/viewvc/chrome/branches/release_154.next/src/net/http/http_cache_unittest.cc?r1=8418&r2=8417

Merge r7669 into 154 branch:

When there are multiple requests for the same resource, it is possible that cancelling a request that is currently a reader may be racing with another reader being completed.  In that case, we were not removing the transaction for the cancelled request so all queued requests were blocked forever. 

BUG=4769
TEST=unittest

Review URL: http://codereview.chromium.org/18469
------------------------------------------------------------------------

Jan 21, 2009
#53 newton.j...@gmail.com
I'm having this problem with a substantial proportion of the Internet too. I am 
running version 1.0.154.43 on XP. Neither clearing the cache nor deleting the cache 
folder helped. I'm wondering if this is related to another problem I started noticing 
around the same time: fully-rendered pages are marked as continuing to load.

Chrome has been great, but I may have to switch back to Firefox until this is fixed.
Jan 23, 2009
#54 megan.su...@gmail.com
I'm also having this problem on a number of different websites, both secure and 
unsecure.  I'm also running the most recent version on XP.  Clearing the cache 
doesn't help.  The sites will load in other browsers or even in incognito windows.

I am also showing that fully rendered pages continue to show that they are loading.
Jan 23, 2009
#55 roman.sh...@gmail.com
This issue is still present in 1.0.154.43, the Yahoo mail is unusable.
Jan 24, 2009
#56 brycesto...@gmail.com
The chromium release notes for 2.0.157.0 (alpha version - not released yet) says this 
is fixed - [r7669]Fixes an issue where Chrome hangs "Waiting for cache" (Issue: 
4769). This should be marked as fixed?

Jan 24, 2009
#57 phistuck
No, still rising every now and again.
Jan 24, 2009
#58 Blacken...@gmail.com
Google Chrome	1.0.154.43 (Official Build 7746)
WebKit	525.19
V8	0.3.9.3
User Agent	Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/525.19 
(KHTML, like Gecko) Chrome/1.0.154.43 Safari/525.19

Ok, reproduction is simple. My usage of chrome is as a research browser, so its 
mostly as follows. Multiple tabs of a single website, as well as related sites are 
left open for *ages*. The websites which hang tend to have a massive amount of ads. 
About 3 windows of that. Normally when the com is restarted, everything is reloaded 
back up(from scratch, pls change this. Get the browser to save state). The problem immediately occurs then, or very soon. However, it not ALL tabs from a site will be 
affected, just certain pages, and they are *quite* random.

Btw, it would be nice if chrome can be released with a snapshot tool, which allows us 
to send the entire state of chrome in. Then just use a statistical attack on the bugs 
to quash them.
Jan 24, 2009
#59 Andrew.P...@gmail.com
Ummm...this bug sucks!  Other than this bug this browser is awesome.  Google, get on 
your horse and fix this one! Please!
Jan 25, 2009
#60 fountofu...@gmail.com
I get the "waiting for cache" fairly frequently and amusingly just got it on a 
www.google.com/support/chrome. It's not too big of a deal, but it does make me switch 
back to other browsers on occasion.
Jan 26, 2009
#61 jpmasse...@gmail.com
I'm having this problem with mail.google.com!
Jan 27, 2009
#62 pimr...@gmail.com
I also have the bug.. I'm forced to switch to another browser because sites wont work 
anymore..
Jan 27, 2009
#63 Haru...@gmail.com
I'm also having the problem. I can't open www.google.com!  It just says "waiting for 
cache" forever. Very frustrating and it's made me pull out firefox again and start 
using it. This is definitely one of those bugs that needs to get fixed asap. Anything 
that starts heavily turning users away from your product ( And not being able to load 
even google.com and other commonly used sites that people are reporting does this) 
calls for a high-priority fix.
Jan 28, 2009
#64 brycesto...@gmail.com
Update your Google Chrome version to 1.0.154.46 (public release) and report back here 
if the problem persists.
Note: Click the wrench icon, click About Google Chrome then update now.
Jan 28, 2009
#65 rvargas@chromium.org
(No comment was entered for this change.)
Status: Fixed
Jan 29, 2009
#66 owenblac...@gmail.com
This certainly seems to have resolved the issues I was experiencing.

Thank you, guys!
Jan 30, 2009
#67 twonky...@gmail.com
After two days, this does appear hopeful.  Back 100% on Chrome on both my computers, 
so far so good.  Thanks for the fix.  
Jan 31, 2009
#68 chris.ely@gmail.com
My repeatable test case is now working as well. Thanks everyone!
Apr 11, 2009
#69 phistuck
This is still not alright.
Go to this website - http://www.giveawayoftheday.com
Click on "Proceed to download page".
Download the file ("Download XXXXXX now" where XXXXXX is the name of the 
application).
Download the file from the mirror (one link after the aforementioned link).

"Waiting for cache" until the download is over.


:(
Apr 29, 2009
#70 rvargas@chromium.org
phistuck: if the second link redirects to the same resource, that is the expected 
behavior.
Apr 29, 2009
#71 phistuck
And why is that?
It might be waiting for the cache to have the full file, but is that the purpose of "waiting for 
cache"? not sort of "loading from existing cache"?
Apr 30, 2009
#72 rvargas@chromium.org
That is the meaning of "waiting for cache": the second request is waiting to have a 
stable resource stored on the cache before reading from it. We don't want to start 
reading from the cache while the first request is still writing.
Apr 30, 2009
#73 wtc@chromium.org
The "waiting for cache" message is technically correct.  But
to a user it doesn't make sense, and it is especially confusing
when "waiting for cache" is displayed for a long time, such
as waiting for a large download to complete or waiting for the
user to click a button on an SSL interstitial page in another
window/tab.
Apr 30, 2009
#74 rvargas@chromium.org
wtc: I totally agree with you. This particular message is not user friendly at all, and 
if everything goes well, it is never displayed. What I mean is that most of the time, 
none of the LoadState messages are displayed, and only when something is taking too 
long we show them. At that time, most users will have no idea what any of the messages 
mean. And yet, we need to provide some feedback and a way for people to tell us what is 
not working well for them :(
Aug 25, 2009
#75 electron...@gmail.com
looks like if there's 302 redirect, Chrome will wait for cache next time. Maybe the 
source code confused 301 with 302?
Aug 26, 2009
#76 jamesgil...@gmail.com
This is not fixed :/ It's still awful!
Aug 26, 2009
#77 manishjh...@gmail.com
even i see the issue with version 2.0.172.43 (Official Build )
Sep 3, 2009
#78 mac...@gmail.com
Windows XP SP3
Chrome 4.0.203.2

Not sure if it's the same bug or not, but I'm encountering something similar.

I currently have a single page on a MediaWiki site that just gives the "Waiting for 
Cache" message now when I try to load it.  Neither closing the browser nor opening 
the cache clear it.

I upgraded today, but I'm pretty sure I saw this last week (not sure if it was the 
same page) when I was still on whatever the latest Beta (3.x) was.  However, I either 
closed the browser or cleared the cache and it cleared it up.

Yesterday, I know I wasn't having the issue, and I started today from a fresh boot  
before I upgraded. I had not tried to load this particular page before I upgraded. I 
started getting the message the first time I loaded the page after the upgrade.

In case it matters, the page is on an internal https site with a self signed SSL 
certificate.
Sep 3, 2009
#79 mac...@gmail.com
Right after posting that I realized the page was open from my session yesterday and I 
had not accepted the bad certificate warning yet. So, it's just Bug 6697. Sorry for the 
spam.

However, I am fairly certain I had the issue I mentioned from last week, but it only a 
single occurrence and I don't have anymore real information to provide.
Oct 18, 2009
#80 brballinger
This happens to me on Facebook often, facebook is practically unusable in Chrome.  It's 
utterly unacceptable.
Dec 15, 2009
#81 rogerpack2005
I get this still sometimes, but I think it might actually mean that my internet 
connection is temporarily down...
Dec 18, 2009
#82 mal.chromium@gmail.com
(No comment was entered for this change.)
Labels: -Area-BrowserBackend Area-Internals Internals-Network
Dec 19, 2009
#83 john.she...@gmail.com
Sooooo frustrating. Browser loads faster, but pages load slower and less predictably 
than Internet Explorer.
Feb 8, 2010
#84 pasamio
I note that this is closed but I encountered this bug in 4.0.249.49 (35163) beta on Mac 
OS X 10.6.2 - not quite sure what the replication conditions are however. Has this been 
resolved in this build or do I need a nightly?
Feb 9, 2010
#85 rvargas@chromium.org
This is fixed on any current release.

The most common way to see this message is having another tab waiting for 
authentication on the same site.
Feb 10, 2010
#86 john.she...@gmail.com
I'm running the most current release. My PC is several years old and underpowered -- 
not enough RAM. Mostly no other active applications, tho running a firewall (doesn't 
seem to matter), AVG. Memory is surely part of the problem, tho Chrome shouldn't 
behave the way that it does.

Most times, after opening the second or third tab, I have to reload (F5) repeatedly 
to get the web page to load. This happens 90+% of the time.

>> This is fixed on any current release.

The symptom is clearly not fixed. Do y'all moonlight for Toyota?
Feb 10, 2010
#87 Arte...@gmail.com
To john.shelby, try to COMPLETELY reinstall the Chrome, with register cleaning and full 
deleting user files of Chrome. It were only one thing wich helped me with the same 
problem.
Feb 23, 2010
#88 jryan...@gmail.com
Sorry Guys, I love Google Chrome, but this is driving me crazy - so much so I'm using
Firefox to record this error.

Chrome hangs with "Waiting for..." often "Waiting for Cache".

Version: 4.0.249.89 (38071)

To my mind this seriously damages Google's reputation - so far pretty impressed with
all Google branded software - but this is just painful!
Feb 23, 2010
#89 glasw...@gmail.com
Yesterday i experienced the 'waiting for cache' problem while opening a (long 
running, > 6 minutes) Adobe Coldfusion script in multiple tabs. 
My goals was to spawn 10 instances of the .cfm script, testing if this would enhance 
the speed of the application. 
Since Chrome runs every tab in a separate memory space (right?) and these tabs can 
hang & crash independantly (right?) i assumed that my .cfm script would run 10x but 
this was not the case. One tab processed while all other tabs where spinning their 
little wheels, saying 'waiting for the cache'.

Adobe Coldfusion 9 dev ed. with MySQL on Sun Virtualbox (XP guest on Win 7 host).



Feb 23, 2010
#90 rvargas@chromium.org
glaswerk: That behavior is by design (at least for the time being).

There are some circumstances when we re-use one process to host more than one tab... 
that depends on how the tab is created, the URL (if it is the same one), the number 
of current processes etc.

However, even if each tab is running in a separate process, when they access any 
resource (fetch any URL), that resource is at the end routed through a central cache, 
and in order to keep that cache consistent we only allow one request to be writing to 
a given entry... in other words, we allow the remaining n tabs to read the resource 
from the cache only after the resource is fully downloaded (by the first tab).

That's why you may see n tabs with this message... because there is one tab that is 
stuck downloading something needed by the other tabs: it may be that there is an 
authentication going on (quite common), the server is stuck, or for some reason the 
download is taking a long time.

For the record, bug 6697 is about modifying that behavior... this bug is about 
requests getting stuck when they should not.
Feb 28, 2010
#91 john.she...@gmail.com
Again, this is clearly not fixed. Added memory to PC, now running with 1.5GB AND NO 
OPEN APPLICATIONS EXCEPT CHROME, roughly 50% of the page loads hang waiting for cache.
Mar 1, 2010
#92 rvargas@chromium.org
@john.shelby: Could you navigate to about:net-internals and post the result here 
whenever you have pages struck with this message?.

Thanks.
Mar 7, 2010
#93 orhan.mulayim
Having the same issue for nearly all sites. 
Mar 28, 2010
#94 alton...@gmail.com
Same problem here. Gets annoying. Google.com takes about 10-15 seconds to load after 
the "waiting for cache".. After that, it goes fine, until later.
Apr 6, 2010
#95 aussi...@gmail.com
I'm getting this on a non SSL page. It was working fine earlier today, and I tried to access the page and its 
"waiting on cache". The site works in firefox and safari (I'm on a mac). My chrome version is 5.0.366.0 dev
Apr 7, 2010
#96 pavs.ma
Having the same issue on some site, clearing caches didnt help. Using Chrome Dev 
builds.
Apr 7, 2010
#97 willchan@chromium.org
If you have this problem, please attach your about:net-internals output and indicate 
which URLs are stalled on waiting for cache.
Apr 19, 2010
#98 stevebou...@gmail.com
Seeing this now trying to access Twitter.com

I don't want to post my full about:net-internals since it lists a lot of sites I 
visit, but here is the twitter related entries.

www.twitter.com	IPV4	128.242.240.148		-44542

http://twitter.com/
t=1712162245: +REQUEST_ALIVE                         [dt=123]
t=1712162245:   +URL_REQUEST_START                   [dt=123]
                   url: http://twitter.com/
t=1712162246:      HTTP_CACHE_OPEN_ENTRY             [dt=  0]
t=1712162246:      HTTP_CACHE_CREATE_ENTRY           [dt=  0]
t=1712162246:      HTTP_CACHE_WAITING                [dt=  0]
t=1712162246:      PROXY_SERVICE                     [dt=  0]
t=1712162246:     +SOCKET_POOL                       [dt=122]
t=1712162368:        CANCELLED
t=1712162368:       -SOCKET_POOL_CONNECT_JOB
t=1712162368:     -SOCKET_POOL
t=1712162368:      HTTP_TRANSACTION_SEND_REQUEST     [dt=  0]
t=1712162368:     +HTTP_TRANSACTION_READ_HEADERS     [dt=  0]
t=1712162368:       +HTTP_STREAM_PARSER_READ_HEADERS [dt=  0]

Browser justs shows "Waiting for cache..." and the page never loads.
Apr 19, 2010
#99 stevebou...@gmail.com
http://twitter.com/
t=1718679853: +REQUEST_ALIVE               [dt=0]
t=1718679853:   +URL_REQUEST_START         [dt=0]
                   url: http://twitter.com/
t=1718679853:     +URL_REQUEST_START       [dt=0]
                     url: http://twitter.com/
t=1718679853:        HTTP_CACHE_OPEN_ENTRY [dt=0]
t=1718679853:       +HTTP_CACHE_WAITING    [dt=0]
Apr 27, 2010
#100 gregg.th...@gmail.com
Seeing this on twitter, as well.
May 23, 2010
#101 chanchal...@gmail.com
Since last 1 week I am facing this Problem that whenever I open some site, my computer 
stops working and following message appears:
"waiting for cache........"
And I am completely failed to open that site at that time. Just now I was opening site 
www.masuta.org and again problem occurred. 
Though few site are running perfectly.
Dont know how this problem can be fixed.

May 28, 2010
#102 garrid...@gmail.com
I have the same problem. My Chrome version is: 5.0.375.55
Jun 1, 2010
#103 val.kul...@gmail.com
Same problem here. Chrome 5.0.375.55
Jun 7, 2010
#104 the.tic...@gmail.com
I've had the same problem for four days now. It began in FireFox, so I tried, IE and 
got the same result, so then I downloaded Google Chrome and still have the same problem 
and it's only with one site, Writing.com. I log into this site daily and I've cleaned 
caches, I've defragged, and used ccleaner and Spybot, and rebooted my router trying to 
find what the problem might be. The site also does the same thing from my husband's 
computer which is attached to the same router.
If it's some sort of BUG it's a very strange one!
I've run out of ideas on what else to try. Any advice would help.
Jun 8, 2010
#105 xami...@gmail.com
Problem happened right after I changed network settings to use a SOCKS proxy.  Happens for all connections.  Socks proxy is on my local host and I have no lag through it in FF.

Running XP SP3 and chromium 5 build 47977
Jun 17, 2010
#106 meshaima...@gmail.com
I'm running chrome version 5.0.375.70, Windows XP SP3, and just started getting the waiting for cache message. I deleted the cache files per previous comments. It worked so far except now I'm having a problem with yahoo not displaying correctly. 
Jun 23, 2010
#107 torste...@gmail.com
Version 6.0.437.3 dev for OSX, issue not fixed - Jun 23, 2010.
Jun 24, 2010
#108 vandebo@chromium.org
 Issue 37729  has been merged into this issue.
Cc: rvar...@chromium.org vand...@chromium.org
Jun 24, 2010
#109 vandebo@chromium.org
A dump from chrome://net-internals may help debug this issue.
Status: Assigned
Jun 24, 2010
#110 rvargas@chromium.org
Also, refer to  issue 37729  if you are experiencing these symptoms (with the requested dump).
Status: Fixed
Cc: -rvar...@chromium.org
May 2, 2011
#111 jrobbins@google.com
(No comment was entered for this change.)
Labels: Restrict-AddIssueComment-Commit
Mar 10, 2013
#112 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-Internals -Internals-Network Cr-Internals Cr-Internals-Network
Sign in to add a comment

Powered by Google Project Hosting