My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 41992: Location bar breaks URLs by removing http:// prefix
10 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 41467
Owner:  ----
Closed:  Apr 2010

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by p...@google.com, Apr 19, 2010
Chrome Version       : 5.0.375.3 (Official Build 44229) dev
URLs (if applicable) : Any HTTP protocol URL
Other browsers tested:
Add OK or FAIL after other browsers where you have tested this issue:
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK

What steps will reproduce the problem?
1. Go to any insecure (not HTTPS) web site on the Internet.

What is the expected result? The Location bar should show the URL of the 
site you are visiting.

What happens instead? The Location bar mangles the URL of any web site you 
go to and drops the "http:// prefix from the URL, making it an invalid 
URL. This breaks one's ability to easily cut and paste URLs from the 
Location bar.


Please provide any additional information below. Attach a screenshot if
possible.

Apr 19, 2010
#1 stuartmorgan@chromium.org
The intent is for copy and paste to include http:// even though it's not displayed in the bar.

I'm not sure which specific copy/paste bug you are seeing, so I'll dup this to the general http removal bug. See 
comment 19 there, among others, for links to specific copy/paste bugs.
Status: Duplicate
Mergedinto: 41467
Apr 20, 2010
#2 william....@gmail.com
I am disappointed that Google has closed commenting on  issue #41467 , are they not interested in user 
feedback?
Apr 20, 2010
#3 marcega...@gmail.com
apt-get remove chromium-browser

It's not mainly this (mis)feature, but the arrogant and stupid way the  issue #41467  was handled that 
prompts me to not use it anymore.

Apr 20, 2010
#4 tszm...@gmail.com
Why you guy closed the  issue #41467  ?

http://www.google.com/corporate/tenthings.html

Focus on the user and all else will follow.

Since the beginning, we've focused on providing the best user experience possible. 
Whether we're designing a new Internet browser or a new tweak to the look of the 
homepage, we take great care to ensure that they will ultimately serve you, rather 
than our own internal goal or bottom line ... And when we build new tools and 
applications, we believe they should work so well you don't have to consider how they 
might have been designed differently.
Oct 12, 2012
#5 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:41467
Mar 10, 2013
#6 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-Undefined
Sign in to add a comment

Powered by Google Project Hosting