My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 38588: Logging into CHASE.COM account crashes browser.
19 people starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Owner:  ----
Closed:  Apr 2010
Cc:  joth@chromium.org, bul...@chromium.org

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Reported by iam...@gmail.com, Mar 18, 2010
Chrome Version       : 5.0.356.0 (Official Build 41818) dev
URLs (if applicable) : https://www.chase.com/Chase.html
Other browsers tested:
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK

What steps will reproduce the problem?
1. Visit https://www.chase.com/Chase.html
2. Login with a valid account.

What is the expected result?

Normal login.

What happens instead?

The browser crashes with the famous "Aw Snap!" message.

This worked in previous versions of Chrome... I believe 5.0.342.2 and 
prior.

Mar 18, 2010
#1 iam...@gmail.com
The only way I am able to successfully get around the problem is to use the Chrome 
Extension "IETab" which uses the Internet Explorer renderer to render the page. The 
website, however, worked fine in previous versions of Chrome and only started crashing 
recently, which leads me to believe that an update of some kind has led to this 
instability and, for whatever reason, is only affecting this one site... and only right 
after a successful login.

Mar 29, 2010
#2 iam...@gmail.com
AHA... so, in my case at least, I determined the culprit to this problem.

I was using the --enable-geolocation switch.

It appears the --enable-geolocation switch causes Chrome to crash upon logging into a 
Chase account at Chase.com. Weird.

Hopefully the geolocation functionality won't become official until this is sorted 
out.

Mar 29, 2010
#3 pkasting@chromium.org
joth, you may want to take a look at this
Cc: j...@chromium.org
Mar 30, 2010
#4 joth@chromium.org
I don't have a chase.com account, but I will note this with the QA team in case they have 
access.
Quite a few things have changed on the trunk since the dev channel build, but would be 
good to resolve this anyway. Some questions:
Is it expected that there is chase.com would be using geolocation?
Does running with --log-level=0 produce any useful output at the point of the crash?
Apr 7, 2010
#5 jston...@gmail.com
This is once again an issue with the latest builds of Chromium.  I had been able to log into my Chase 
account with earlier versions, but with version 5.0.370.0 (43826) , the browser crashes with the "Aw 
Snap" message upon log-in.
Apr 7, 2010
#6 iam...@gmail.com
@jstonezz,

Are you using the --enable-geolocation switch?

If not, maybe in version 5.0.370.0 this is now on by default?

On a whim, try using the --disable-geolocation (not sure if it exists) and see if 
this changes anything.

Apr 8, 2010
#7 jston...@gmail.com
Adding the the --disable-geolocation switch does not appear to fix the problem.
Apr 8, 2010
#8 iam...@gmail.com
That's unfortunate. I visit chase.com nearly every day. There have been two separate 
issues in the past regarding Chrome with chase.com ... one which needed to be fixed 
in the build... the other which involved keeping geolocation disabled... and now a 
third problem?

I am on the dev channel and it still sees 5.0.366.2 as the latest, so I am not 
experiencing it yet. However, once I end up with the next update to the dev channel, 
if I have a problem with chase.com, I'll report my findings here.

In the past, to get around chase.com problems until Chrome is fixed, I use the IETab 
extension and have a bookmark to the corresponding chrome-extension://... path for 
chase.com. This way, I am only one bookmark away from using chase.com and avoiding 
crashes until the problem is fixed (again). It's a bit slower (due to using IE's 
rendering engine), but at least I don't have to load IE separately.

Apr 8, 2010
#9 iam...@gmail.com
OK, today I upgraded from 5.0.366.2 to 5.0.371.0 (Official Build 43900) dev.

5.0.366.2 worked just fine when logging into chase.com, unless you have the --enable-
geolocation flag set... if that were the case, the browser would immediately crash 
upon  a successful login attempt.

With 5.0.371.0, it crashes immediately upon login, without the --enable-geolocation 
flag.

For the Chromium developers out there... is the geolocation feature now activated in 
this build?

If not, it looks like chase.com is an unfortunate victim of several different bugs 
which keep getting introduced into Chrome. Help!

Apr 9, 2010
#10 iam...@gmail.com
@jstonezz

Upgrade to 5.0.371.0 and try the --disable-geolocation switch and see if logging into 
chase.com works for you.

Apr 9, 2010
#11 joth@chromium.org
Looks very likely this is a duplicate of  bug 40478 , however without logs / call stack it's hard to tell.
Apr 9, 2010
#12 ghost...@gmail.com
I can reproduce this error in 5.0.371 and am trying to produce a log file for you using 
--log-level=0 but I can't find chrome_debug.log

In answer to your question, I would not expect chase.com would be using geolocation 
(it's a credit card company) but I suppose it's possible they're using it to send you 
to the right country-specific website.
Apr 9, 2010
#13 joth@chromium.org
Looks like you also need --enable-logging, see  http://dev.chromium.org/for-testers/enable-logging for more

Also, if you can get a call stack as per http://dev.chromium.org/for-testers/bug-reporting-
guidelines/reporting-crash-bug that would be great too.

Thanks!

Apr 9, 2010
#14 rcdai...@gmail.com
I'm getting this issue as well. Running build 5.0.371
Apr 9, 2010
#15 ghost...@gmail.com
Debug log attached.  The Windows event log said "Crash uploaded. Id=437c6777c2c56f0d.", 
I assume you can get the call stack from that?
chrome_debug.log
28.8 KB   View   Download
Apr 9, 2010
#16 joth@chromium.org
Looks like that call stack is still working it's way through the system, can't seem to load it yet.
(Apparently there should be a copy on your machine too, in 
%LOCALAPPDATA%\Google\CrashReports\Chrome-last.dmp)

Anyway, in looking for it I saw there's now several other examples of this crash in the system, and all of them 
point to this being a duplicate of  bug 40478  as suspected, which is good. (e.g. http://crash/reportdetail?
reportid=1571edf00180c02d)


Status: Available
Cc: bul...@chromium.org
Labels: -Pri-2 -Area-Undefined Pri-1 Area-WebKit OS-All Crash
Apr 9, 2010
#17 ghost...@gmail.com
Do you want me to attach the dump from my machine?
Apr 9, 2010
#18 joth@chromium.org
No it's OK thanks, the stack made it's way through in the end.

Copying relevant part here. It is indeed a duplicate of 40478 so merging this one into that.


0x5ef0c1c5	 [chrome.dll	 - webgeolocationservicebridgeimpl.cpp:128]	
WebKit::WebGeolocationServiceBridgeImpl::stopUpdating()
0x5eec4101	 [chrome.dll	 - geolocation.cpp:226]	WebCore::Geolocation::disconnectFrame()
0x5ee528fe	 [chrome.dll	 - navigator.cpp:68]	WebCore::Navigator::disconnectFrame()
0x5ed5cda6	 [chrome.dll	 - domwindow.cpp:441]	WebCore::DOMWindow::clear()
0x5ecdccdc	 [chrome.dll	 - frame.cpp:212]	WebCore::Frame::~Frame()
0x5ecdb528	 [chrome.dll	 - passrefptr.h:53]	WTF::derefIfNotNull<WebCore::Frame>(WebCore::Frame *)
0x5ed70487	 [chrome.dll	 - frameview.cpp:177]	WebCore::FrameView::~FrameView()
0x5ed702db	 [chrome.dll	 + 0x000c02db]	WebCore::FrameView::`scalar deleting destructor'(unsigned int)
0x5ed5e373	 [chrome.dll	 - refcounted.h:109]	WTF::RefCounted<WebCore::Widget>::deref()
Status: Duplicate
Mergedinto: 40478
Apr 14, 2010
#20 brott...@gmail.com
Running with --disable-geolocation appears to fix the problem for me. I can now login 
to chase.com once again.
Apr 14, 2010
#21 joth@chromium.org
 Issue 40618  has been merged into this issue.
Apr 14, 2010
#22 joth@chromium.org
 Issue 40568  has been merged into this issue.
Apr 15, 2010
#23 iam...@gmail.com
For what it's worth, this seems to work for me now. I am not using --disable-
geolocation anymore... also, as a test, I used --enable-geolocation (in case it was 
disabled by default in the latest dev channel build). When using version 5.0.375.7 
(Official Build 44408) [dev channel], I am able to login to chase.com without any 
crashes.

In any case, this is great news!

Apr 15, 2010
#24 joth@chromium.org
@iambob, great news, thanks very much for confirming the fix.
Mar 18, 2011
#25 lafo...@chromium.org
Chrome Version       : 5.0.356.0 (Official Build 41818) dev
URLs (if applicable) : https://www.chase.com/Chase.html
<b>Other browsers tested:</b>
     Safari 4: OK
  Firefox 3.x: OK
         IE 7: OK
         IE 8: OK

<b>What steps will reproduce the problem?</b>
1. Visit https://www.chase.com/Chase.html
2. Login with a valid account.

<b>What is the expected result?</b>

Normal login.

<b>What happens instead?</b>

The browser crashes with the famous &quot;Aw Snap!&quot; message.

This worked in previous versions of Chrome... I believe 5.0.342.2 and 
prior.
Labels: -Crash bulkmove Stability-Crash
Mergedinto: -0
Oct 12, 2012
#26 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mar 10, 2013
#27 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-WebKit Cr-Content
Apr 5, 2013
#28 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content Cr-Blink
Sign in to add a comment

Powered by Google Project Hosting