My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 29662: Chromium should be more aware of wifi status
1 person starred this issue and may be notified of changes. Back to list
Status:  Duplicate
Merged:  issue 18673
Owner:  willchan@chromium.org
Closed:  Aug 2010
Cc:  wtc@chromium.org, pinkerton@chromium.org
M-7

Restricted
  • Only users with EditIssue permission may comment.


Sign in to add a comment
 
Reported by CalebEgg, Dec 7, 2009
What steps will reproduce the problem?
1. Boot/un-suspend/start connect to a network
2. Before the wifi is connected, open Chrome
Expected: Tabs continue "loading" until the wifi is connected
Actual: All tabs show inaccurate error page

1. Disconnect from the network
2. Try to load a page
Expected: Error page says "You are not connected to the internet. Connect and try again."
Actual: Error page suggests you check the spelling, or says the site might be down.

Please use labels and text to provide additional information.
It's annoying to have to wait for the wifi to connect to open chrome unless you want to manually refresh 
each page once it does connect.

This specifically affects chromium os on boot.
Jul 9, 2010
#1 kerz@chromium.org
(No comment was entered for this change.)
Labels: -Area-Misc Area-Internals
Jul 15, 2010
#2 lafo...@chromium.org
(No comment was entered for this change.)
Labels: Internals-Network
Jul 19, 2010
#3 wtc@chromium.org
This is similar to the detection of network changes that willchan worked in Q1 or Q2.

pinkerton: I remember you filed a feature request to automatically refresh network
error pages after network comes back up.

Status: Assigned
Owner: willc...@chromium.org
Cc: w...@chromium.org pinker...@chromium.org
Labels: Mstone-7
Aug 17, 2010
#4 willchan@chromium.org
This seems very similar to 18673.  I don't know that browser should be aware that we are "connecting" to a network, as I'm not sure what OS interfaces are available for this.  I think it's simpler and good enough to just show an "offline" error (see  issue 18673 ) while we are connecting, and to perhaps reload tabs when the connection completes (see issue 40826).

With that in mind, I'm tempted to close this bug as WontFix.  wtc, what do you think?
Aug 17, 2010
#5 wtc@chromium.org
Closing this bug as WontFix to consolidate similar bugs is fine, as
long as we don't close all of them as WontFix by mistake.

You can also mark this bug as a duplicate of  issue 18673  or
issue 40826.
Aug 17, 2010
#6 willchan@chromium.org
Duping to 18673 then.
Status: Duplicate
Mergedinto: 18673
Oct 12, 2012
#7 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mergedinto: chromium:18673
Mar 10, 2013
#8 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-Internals -Internals-Network -Mstone-7 M-7 Cr-Internals Cr-Internals-Network
Mar 13, 2013
#9 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Restrict-AddIssueComment-Commit Restrict-AddIssueComment-EditIssue
Sign in to add a comment

Powered by Google Project Hosting