My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 251245: Dependency problem with libX11
6 people starred this issue and may be notified of changes. Back to list
Status:  WontFix
Owner:  ----
Closed:  Jun 2013


Sign in to add a comment
 
Reported by bloody.a...@gmail.com, Jun 18, 2013
UserAgent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36

Steps to reproduce the problem:
1. in Fedora 16 x86_64, use yum repo: http://dl.google.com/linux/chrome/rpm/stable/x86_64
2. sudo yum update

What is the expected behavior?
Chrome update will be installed.

What went wrong?
Error: google-chrome-stable conflicts with libX11-1.4.3-1.fc16.x86_64

Full log:
$ sudo yum update 
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package google-chrome-stable.x86_64 0:27.0.1453.110-202711 will be updated
---> Package google-chrome-stable.x86_64 0:28.0.1500.45-205727 will be an update
--> Processing Conflict: google-chrome-stable-28.0.1500.45-205727.x86_64 conflicts libX11 < 1.4.99
--> Processing Conflict: google-chrome-stable-28.0.1500.45-205727.x86_64 conflicts libX11 < 1.4.99
--> Finished Dependency Resolution
Error: google-chrome-stable conflicts with libX11-1.4.3-1.fc16.x86_64
Error: google-chrome-stable conflicts with libX11-1.4.3-1.fc16.i686
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Did this work before? Yes The last time when there where an update.

Chrome version: 28.0.1500.45  Channel: stable
OS Version: Fedora 16 x86_64

Does Chrome *really* need libX11 1.4.99 or is this dependency an error? What's new to libX11 1.4.99 that is really needed?
Jun 18, 2013
#1 thestig@chromium.org
We have new requirements as noted in the release notes for 28.x: http://googlechromereleases.blogspot.com/2013/06/stable-channel-update_17.html

Fedora 16's end of life was 4 months ago. You probably have not been getting security updates for a while. Please consider upgrading.
https://fedoraproject.org/wiki/End_of_life
https://lists.fedoraproject.org/pipermail/announce/2013-February/003144.html
Status: WontFix
Jun 18, 2013
#2 dhirenpa...@gmail.com
Same problem here, so i just downloaded the rpm file from ftp://ftp.pbone.net/mirror/apt.unl.edu/apt/fedora/fedora/14/i386/unl/RPMS/google-chrome-stable-21.0.1180.81-151980.i386.rpm and install the required dependencies and its working fine.
Jun 18, 2013
#3 thestig@chromium.org
You really shouldn't use old version of Google Chrome. They likely have known security problems. Please upgrade to the latest version of Fedora and enjoy the latest version of Google Chrome.

There is also no guarantee that a random RPM package from some random server labelled as Google Chrome really is Google Chrome.
Jun 21, 2013
#4 bill.bau...@gmail.com
Obviously the Chrome maintainers have never compared the excessively bloated resource requirements of Fedora 15+ to <Fedora 14. All of my Fedora VMs are Fedora 14. So, based on this feedback, I'll freeze Chrome at Version 27.0.1453.110 on my Fedora 14 frozen VMs.

At least Oracle has maintained Java compatibility/security updates so I don't have to worry about the major security exploits. I can't "blame" the Chrome maintainers here, but I do appreciate any group that figures out how not to force us to "downgrade" by increasing version numbers to newer versions of OS bloatware.
Jun 21, 2013
#5 thestig@chromium.org
Bill: Please remember this is a bug tracker and not a discussion forum.

You are free to run any version of Fedora you like and any version of Chromium you like. All the Chromium source code is open, so if you have the right build tools, you can also build version newer than 27 for yourself. There also exists other distros that may better meet your needs and also be receiving security updates.

Google Chrome, because it is distributed as a binary and not source code, has to set some system requirements. Supporting major Linux distros that themselves are still supported is approximately where we draw the line in the sand.
Sign in to add a comment

Powered by Google Project Hosting