My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 237391: Frequent Chrome automation timeouts in SkipToLogin in VMTest
4 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by posciak@chromium.org, May 1, 2013
VMTests on various boards are failing seemingly randomly with the following error:

Unhandled AutomationCommandTimeout: Chrome automation timed out after 45 seconds for {"skip_image_selection": true, "command": "SkipToLogin"}


Example: http://chromegw/i/chromeos/builders/x86-zgb%20canary/builds/3312

May 2, 2013
#1 garn...@chromium.org
Happened again: http://chromegw/i/chromeos/builders/x86-alex%20canary/builds/3530/steps/VMTest%20%5Bx86-alex%5D/logs/stdio
Labels: Hotlist-TreeCloser
May 7, 2013
#2 cmp@chromium.org
I'm not sure how to triage a automation timeout failure report.  Usually sheriffs investigate the issue and disable failing tests.  Pawel, can you figure out what the next step should be here?
Status: Assigned
Owner: phajdan.jr@chromium.org
Labels: -Pri-1 Pri-2
May 10, 2013
#3 phajdan.jr@chromium.org
Please redirect this to people working on autotest. Chrome automation is known to be flaky, and new recommended solution is Telemetry.

I'd like to help, but 1) this is really not an issue with something I worked on, 2) I can't fix all test issues for everyone.
Owner: posciak@chromium.org
Cc: phajdan.jr@chromium.org
Jun 4, 2013
#4 s...@chromium.org
I think this bug is still closing the tree - see e.g.:

http://chromegw/i/chromeos/builders/stumpy%20canary/builds/2971/steps/VMTest/logs/stdio

Cc: davidjames@chromium.org
Labels: -Pri-2 Pri-1
Jun 4, 2013
#5 davidjames@chromium.org
This seems to be happening a lot. Zel, can you take a look since you're the Chrome gardener?

Here's another two occurrences (both in VMTest stage):
  http://chromegw.corp.google.com/i/chromeos/builders/x86-alex%20canary/builds/3662    
  http://chromegw.corp.google.com/i/chromeos/builders/stumpy%20canary/builds/2971
Summary: Frequent Chrome automation timeouts in SkipToLogin in VMTest (was: Frequent Chrome automation timeouts in VMTests)
Status: Untriaged
Owner: zelidrag@chromium.org
Labels: -Build-Infrastructure Cr-UI
Jun 4, 2013
#6 davidjames@chromium.org
 Issue 246602  has been merged into this issue.
Jun 4, 2013
#7 achuith@chromium.org
(No comment was entered for this change.)
Status: Assigned
Owner: achuith@chromium.org
Cc: zelidrag@chromium.org te...@chromium.org
Jun 4, 2013
#8 achuith@chromium.org
(No comment was entered for this change.)
Cc: xiyuan@chromium.org
Jun 4, 2013
#9 achuith@chromium.org
(No comment was entered for this change.)
Status: Started
Jun 4, 2013
#10 achuith@chromium.org
Unable to reproduce locally with the build artifacts. 

One idea was that the hwid screen was blocking us from logging in (https://codereview.chromium.org/16206022/), but this is actually not the case.

We don't have any good ideas on why this should be failing, so we're going to add more logging to TestAutomation to try and figure out what's going on.


Jun 6, 2013
#14 achuith@chromium.org
 Issue 246754  has been merged into this issue.
Cc: achuith@chromium.org
Jun 6, 2013
#15 achuith@chromium.org
Turns out the incognito tests have a dependance on gaia - the auth server is not used for bwsi tests. 

https://gerrit.chromium.org/gerrit/#/c/57826/

This fix should hopefully take care of the failures for login_Incognito* and security_ProfilePermissions.BWSI, but it doesn't help with securityProfilePermissions.login or any other tests that use normal login.

Cc: -achuith@chromium.org
Jun 10, 2013
#16 achuith@chromium.org
(No comment was entered for this change.)
Labels: Iteration-84
Jun 13, 2013
#17 thie...@chromium.org
Hit this again today:
http://chromegw/i/chromeos/builders/x86-mario%20canary/builds/3699
Jun 14, 2013
#18 quiche@chromium.org
#c17 has timeout in desktopui_ScreenLocker.
Jun 14, 2013
#19 quiche@chromium.org
again here: http://cautotest/tko/retrieve_logs.cgi?job=/results/3367975-chromeos-test/chromeos2-row3-rack6-host5/desktopui_ScreenLocker
Jun 14, 2013
#20 quiche@chromium.org
 Issue 249871  has been merged into this issue.
Cc: i...@chromium.org hungte@chromium.org
Jun 24, 2013
#21 zelidrag@chromium.org
(No comment was entered for this change.)
Labels: Iteration-85
Jun 25, 2013
#22 achuith@chromium.org
This is actually a number of different bugs with the same symptom (SkipToLogin failure). I'm not able to work on this actively right now, but I'll try to pick it up at a future point. 

This should be a bug for the cros gardener to investigate during their shift.
Status: Available
Jul 17, 2013
#23 zelidrag@chromium.org
(No comment was entered for this change.)
Labels: Iteration-86
Aug 19, 2013
#24 kar...@google.com
Moving all non essential bugs to the next Milestone.
Status: Assigned
Labels: M-31 MovedFrom-30
Sep 6, 2013
#25 sna...@google.com
Another instance of "AutomationCommandTimeout: Chrome automation timed out after 45 seconds", although the failure is for "{"command": "LockScreen"}".  Since it is a different command that is failing, I am not sure whether it is the same root cause or not. Here's the failure log:

http://cl12-16-410.mtv.corp.google.com/results/4590015-chromeos-test/chromeos2-row2-rack6-host7/desktopui_ScreenLocker/
Sep 26, 2013
#26 bugdro...@chromium.org
This issue is Pri-1 but has already been moved once, therefore lowering to Pri-2 and moving to next milesone.
Labels: -Pri-1 -M-31 M-32 MovedFrom-31 Pri-2
Nov 7, 2013
#27 kar...@google.com
This issue has already been moved once and is lower than Priority 1,therefore removing mstone.
Labels: -M-32 MovedFrom-32
Apr 24, 2014
#28 achuith@chromium.org
RIP pyauto
Status: WontFix
Sign in to add a comment

Powered by Google Project Hosting