My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 20117: Chrome doesn't respect http-equiv refresh with space instead of semicolon
26 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by d...@chromium.org, Aug 24, 2009
Chrome doesn't redirect on load of
http://exploration.nasa.gov/programs/station/index.html
like Firefox does.
The line
-- snip --
<meta http-equiv="Refresh" content="0
url=http://www.nasa.gov/mission_pages/station/science/experiments/Summary.html">
-- snip --
is not being obeyed.  Note the space where a semicolon usually is.

This is almost a dup of  bug 3162 , but that one was merged into
a big-ball-o-hair bug, let's have a nice simple separate bug for this.
Sep 23, 2009
#2 jshin@chromium.org
Safari has the same problem. Firefox and IE are generous in the same situation. 

This was also reported in the Google Korean U2U group ( 
http://groups.google.com/group/google-kr-
Search/browse_thread/thread/c2743deeb993d003# ). The url in question is 

http://www.sweetmong.com/community/comm_05.php 

Although I think Webkit has to be changed to be compatible with Firefox and IE, I'm 
adding Johny in case he wants to see how widespread this problem is with his 
compat-check tool. 


I've just tried one line patch to the webkit 
(WebCore/platform/network/HTTPParser.cpp) and it worked for both Chrome and 
Safari

I upstreamed this to https://bugs.webkit.org/show_bug.cgi?id=29674 (I thought our 
http stack might have its own code to deal with this, but couldn't find and it doesn't 
seem to have one given that  the aforementioned patch works with both Chrome and 
Safari)

Status: Upstream
Cc: j...@chromium.org w...@chromium.org da...@chromium.org gwil...@chromium.org
Labels: -Type-Bug
Sep 23, 2009
#3 j...@chromium.org
Thanks, Jungshik! I will detect this bug and record how many pages have this problem in 
further detections.
Sep 23, 2009
#4 jshin@chromium.org
Thank you, Johny. 

I'm now testing whether IE/Firefox are generous with HTTP Refresh header as well (and 
other characters than 'space', comma and semicolon). 
Owner: js...@chromium.org
Labels: -Area-Misc -Size-Medium Area-WebKit Size-Small
Sep 28, 2009
#7 j...@chromium.org
Hello nickjohns2k5. 
I tested your case on my Chrome, it worked well. (4.0.206.1 (official Build 25376))
Would you please attach a test case file which was failed on your Chrome. Also would 
you please provide your chrome version info.

Thanks!
Oct 2, 2009
#9 gwil...@chromium.org
 Issue 14861  has been merged into this issue.
Oct 5, 2009
#10 McGuire...@gmail.com
I have perhaps the simplest example of Chrome (3.0.195.24) ignoring meta refresh, and
Safari ignores it as well:

<html><head><meta http-equiv="refresh" content="1;url=/public"
/></head><body></body></html>
Oct 15, 2009
#11 ka...@chromium.org
it looks like this is moving upstream, i'll put this in mstone 4 for now.
Labels: Mstone-4
Nov 6, 2009
#12 dglazkov@chromium.org
Fixed?
Nov 6, 2009
#13 daniel.r...@gmail.com
Not quite fixed.  The original case is still broken.  Minimal test case (from #10
with; replaced by space):

<html><head><meta http-equiv="refresh" content="1 
url=/public"/></head><body></body></html>


Nov 7, 2009
#14 ver...@gmail.com
(reply to comments, 10 and 13, by MsGuireV110 and daniel.r.kegel)

The HTTP "Refresh:" header is not supposed to be honorred if it is not an absolute 
URL, but here you used a relative URL "/public" (relative to the current document's 
URL ?). Is it supposed to work anyway when the Refresh is specified in a HTML <meta> 
element instead?

My opinion is that the <meta> element should not accept what the HTTP header also 
does not accept as valid.

If you make the HTTP implementation generous (accepting the comma or space instead of 
semicolon, or accepting relative URLs), the same patch should be applied to the HTML 
renderer within its support for <meta> (but the HTTP header will still have higher 
precedence for the header with the same "Refresh" name, ignoring case, if it is also 
present, as this Refrsh header type is not cumulative).

Nov 7, 2009
#15 ver...@gmail.com
Note that the HTTP "Refresh" header was not specified in any RFC; it was tolerated with 
HTTP/1.0 as a vendor extension, but it is disallowed with HTTP/1.1, i.e. RFC 2616; it 
has been replaced with the standard "Location" header with some restrictions and 
semantics (to comply with HTTP proxies). The "location" header also requires an 
absolute URI and can only be returned with specific HTTP status for redirects.

Nov 7, 2009
#17 dhw@chromium.org
Hi Johnny,

As a measure of prevalence, "refresh with space" is used by Discuz forum software, 
which means it's widely used in Chinese websites.

See also other issues:  https://code.google.com/p/chromium/issues/list?can=1&q=discuz
Nov 17, 2009
#18 darin@chromium.org
Firefox supports the Refresh response header, and so should we.
Nov 21, 2009
#19 mal.chromium@gmail.com
I'd rather Jungshik worked on I18N bugs for 4 rather than completing the tests for this 
bug upstream. 

If someone else wants to pick up the WebKit bug, that's OK. Otherwise, I think we can 
safely release another version of Chrome with this issue.

Moving to Mstone-5 so I don't block 4 on the upstream changes.
Cc: dglaz...@chromium.org ero...@chromium.org
Labels: -Mstone-4 Mstone-5
Feb 25, 2010
#20 ka...@chromium.org
(No comment was entered for this change.)
Status: Assigned
Labels: Upstream karenchanged
Apr 1, 2010
#21 bhu...@gmail.com
any update on this fix?
May 13, 2010
#22 lafo...@chromium.org
Raising priority for next round.
Labels: -Pri-2 -Mstone-5 Pri-1 Mstone-6
Aug 6, 2010
#23 evan@chromium.org
(No comment was entered for this change.)
Status: ExternalDependency
Labels: -upstream
Aug 31, 2010
#24 dglazkov@chromium.org
This issue is marked as M6. Are you sure it is? Dear owner, please update the milestone accordingly.
Sep 3, 2010
#25 kerz@chromium.org
Moving out of 6, please retarget as needed.
Labels: -Mstone-6 Mstone-X
Jan 20, 2012
#26 cbentzel@chromium.org
 Issue 41136  has been merged into this issue.
Jan 20, 2012
#27 dhw@chromium.org
(No comment was entered for this change.)
Labels: WebKit-ID-29674
Jan 20, 2012
#28 bugdro...@chromium.org
https://bugs.webkit.org/show_bug.cgi?id=29674
Labels: -WebKit-ID-29674 WebKit-ID-29674-ASSIGNED
Jun 9, 2012
#29 dbo...@gmail.com
My Chrome (recent version on Mac OS X) has the same problem at http://www.dougscripts.com/ where the semicolon is correct:

<meta http-equiv="Refresh" content="1; URL=http://dougscripts.com/itunes/">
Nov 20, 2012
#30 kar...@google.com
P1 bugs that have been moved 3+ times. Downgrading to P2
Labels: -Pri-1 Pri-2
Feb 12, 2013
#31 dbo...@gmail.com
This happens all the time for me. Last time was one minute ago when I tried to logout from GMail (!). I ended up being stuck on a page with the following source


<html><head><meta http-equiv="Refresh" content="0;URL=https://accounts.google.com/Logout?service=mail&amp;continue=https://accounts.google.com/ServiceLogin?service%3Dmail%26passive%3Dtrue%26rm%3Dfalse%26continue%3Dhttps://mail.google.com/mail/%26ss%3D1%26scc%3D1%26ltmpl%3Ddefault%26ltmplcache%3D2%26hl%3Den&amp;hl=en" /></head><body><script type="text/javascript" language="javascript"><!--
location.replace("https://accounts.google.com/Logout?service\75mail\46continue\75https://accounts.google.com/ServiceLogin?service%3Dmail%26passive%3Dtrue%26rm%3Dfalse%26continue%3Dhttps://mail.google.com/mail/%26ss%3D1%26scc%3D1%26ltmpl%3Ddefault%26ltmplcache%3D2%26hl%3Den\46hl\75en")
--></script></body></html>

After decoding the URL and pasting it in the address field I logged out successfully.

Very annoying.
Feb 13, 2013
#32 dbo...@gmail.com
Here is another example that does not wor


<html>
	<body onload="document.location.replace('http://www.svd.se/nyheter/inrikes/varg-pa-bilprovningen-i-gislaved_7896474.svd')">
		<form method="get" action="http://www.svd.se/nyheter/inrikes/varg-pa-bilprovningen-i-gislaved_7896474.svd">
			
		</form>
	</body>
</html>
Mar 10, 2013
#33 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-WebKit Cr-Content
Apr 5, 2013
#34 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content Cr-Blink
Apr 10, 2013
#35 schen...@chromium.org
Bulk status change for WebKit-ID-? bugs with ExternalDependency. These are now all Available. Feel free to return the status if the dependency is not on a WebKit contributor, but some other third party.
Status: Available
Oct 9, 2013
#36 danielk...@gmail.com
The error lies in the parseHTTPRefresh in the HTTPParsers.cpp 

The loop should probably accept spaces as delimiter:

while (pos != len && refresh[pos] != ',' && refresh[pos] != ';' && refresh[pos] != ' ')

See: 
https://code.google.com/p/chromium/codesearch#chromium/src/third_party/WebKit/Source/core/platform/network/HTTPParsers.cpp&q=parseHTTPRefresh&sq=package:chromium&dr=C&l=179
Jan 13, 2014
#37 VexenCrabtree
Page: view-source:http://www.vexen.co.uk/religion/islam.html
Source: <html><head><meta http-equiv="refresh" name="refresh" content="0; URL=http://www.humanreligions.info/islam.html"></head></html>

Correct semicolon; same as poster #29. I'm using Win8, Google Chrome v. 32.0.1700.72 m.
Jan 22, 2014
#38 rajeev.v...@gmail.com
Remove the attribute name="refresh" ,it will WORK

<html><head><meta http-equiv="refresh"  content="0; URL=http://www.humanreligions.info/islam.html"></head></html>
Sign in to add a comment

Powered by Google Project Hosting