My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 176703: <input type=file> "Failed to open selected file"
39 people starred this issue and may be notified of changes. Back to list
 
Reported by aykevanl...@gmail.com, Feb 16, 2013
Device name: HTC Desire S

From "Settings > About Chrome"
Application version: 25.0.1364.87 (Chrome Beta for Android)
OS: Android 4.0, developer version from HTC

URLs (if applicable):
 * For example, http://www.cs.tut.fi/~jkorpela/forms/file.html#example

Behavior in Android Browser (if applicable):
 * Stock HTC browser works.
 * Chrome 18 (the current stable version for Android) works.
 * Firefox (current version) works.

Steps to reproduce:
1. Upload any file via <input type="file">

Expected result:
File is inserted in form and ready to be uploaded.

Actual result:
After selecting a file, a Toast appears with the text "Failed to open selected file".
For example, for Dropbox the steps would be:
1. Click on 'Choose File'.
2. Select Dropbox from the list of apps.
3. Select a file.
4. The error message ("Failed to open selected file") appears.

This happens with Dropbox and File Manager (https://play.google.com/store/apps/details?id=com.rhmsoft.fm)
This does not happen with Camera, Documents To Go, Gallery, HTC Music app, musiXmatch, etc.
I restarted the device to make sure that wasn't the problem, but that didn't help (I didn't expect it, but who knows.)

A thing that might be a clue: I tried the non-working apps right after I installed Chrome Beta in private mode. After the reboot, I tried other apps and they worked, somehow.
I tried force stopping and wiping data, but that didn't work.

I traced it down to this file:
https://code.google.com/p/chromium/source/search?q=opening_file_error&origq=opening_file_error&btnG=Search+Trunk (SelectFileDialog.java, line 184).
Feb 28, 2013
#1 pul...@gmail.com
I have the same problem!
Mar 5, 2013
#2 rbeze...@softwarebyrichard.com
I'm noticed this with both Dropbox and ES File Explorer. File Explorer works with opening it the "normal Android way" but not the "File way" other. This only started happening after the update from Chrome v.24 to v25.
Mar 11, 2013
#3 richard....@gmail.com
Chrome version 25.0.1364.169
Having the same issue. Since the Chrome update. I cannot upload files to Chrome from Dropbox. From any website.

Works with Firefox.
Apr 5, 2013
#4 simon.d...@firstpersonview.co.uk
I am also having this problem on my Nexus 7, Chrome v26.

It happens with the "Attach file" function on this page for instance! 
Apr 17, 2013
#5 rbeze...@softwarebyrichard.com
Also get this behavior when there is a % or # in the filename.
Apr 27, 2013
#6 sforne...@gmail.com
works fine with firefox
May 27, 2013
#7 andrew.p...@gmail.com
I experience the same toast error when attempting to upload "subscriptions.xml".
Jun 21, 2013
#8 gl...@glennfu.com
+1 for Droid Razr M, Android 4.1.2, using Chrome.
Jul 18, 2013
#9 d...@mainstreetmower.com
Droid Razr M.  Major road block in development.
Aug 21, 2013
#10 EricTaa...@gmail.com
Same problem nexus 7 1st gen. 16gb wifi android 4.3
Aug 25, 2013
#11 HenryOff...@gmail.com
Is there a fix for this yet? 
Aug 26, 2013
#12 krav...@chromium.org
Same issue with Nexus7/JDQ39 and Galaxy Nexus JWR66Y
Status: Untriaged
Aug 26, 2013
#13 kamak...@chromium.org
Similar to  issue 278640 .
Status: Available
Cc: vino...@chromium.org
Labels: M-30 Type-Bug-Regression
Aug 28, 2013
#14 vino...@google.com
(No comment was entered for this change.)
Status: ExternalDependency
Labels: ReleaseBlock-Stable
Aug 28, 2013
#15 jesus.da...@gmail.com
What does the ExternalDependency status mean? that it's not a Chromium issue? 
Aug 30, 2013
#16 vino...@google.com
Nope. It's a chromium issue. Reassigning. 
Status: Assigned
Owner: peter@chromium.org
Cc: migu...@chromium.org
Labels: -M-30 -ReleaseBlock-Stable M-X
Sep 3, 2013
#17 isawc...@gmail.com
nexus 7 1st gen.  Major road block in development.
Sep 19, 2013
#18 libraryl...@gmail.com
Same here! I've had my Nexus 7 and Dropbox since January 2013 and have always been able to attach photos and files from Dropbox to emails. Now I get the error message of doom when I try to attach to my virginmedia emails, but can attach to my gmail emails with no trouble. I also have the same message when trying to upload a photo from my Gallery to a website, e.g. as a profile picture. Yet I can open them all! 
Sigh ... It all worked fine, why did They have to mess about with it?! I have to abandon the Nexus and use the laptop for attachments and uploads now. Very inconvenient and frustrating. :-( 
Nov 5, 2013
#19 calumcon...@gmail.com
I've been having the same issues since Oct 2013. Any updates on a fix? Very frustrating.
Nov 5, 2013
#20 migu...@chromium.org
(No comment was entered for this change.)
Owner: migu...@chromium.org
Nov 6, 2013
#22 migu...@chromium.org
I looked into the associated issue crbug.com/278640 but I think they are not related. This bug is for raw file schemas wheres the other one involves the new kit kat api.
Nov 8, 2013
#23 bugdro...@chromium.org
------------------------------------------------------------------------
r233965 | miguelg@chromium.org | 2013-11-08T20:27:22.664759Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/ui/android/java/src/org/chromium/ui/SelectFileDialog.java?r1=233965&r2=233964&pathrev=233965

Allow file: uris for <file> input types
Also changed all the if/else to early returns

BUG=176703

Test:
Installed File Manager from play

 Loaded GMail in html mode (mail.google.com/?ui=html) verified that the Attach file is in fact a <file> tag. Sent myself a mail with an attachment. Verifed that the file was properly sent

Review URL: https://codereview.chromium.org/60673003
------------------------------------------------------------------------
Nov 8, 2013
#24 migu...@chromium.org
(No comment was entered for this change.)
Status: Fixed
Dec 19, 2013
#25 andrew.g...@gmail.com
I have The same problem on my nexux 7 gen2 with android 4.4.2(stock) in google chrome on any site with file upload.
Dec 19, 2013
#26 just.pe...@gmail.com
After the latest update, selecting <input type=file> and using the native
camera as the source seems to work now. However, I'm getting the same when
selecting a file via the file browser: 'Failed to open selected file'
Dec 26, 2013
#27 boxmon...@gmail.com
What version should we expect to see ship with this? Still seeing bad behavior in 32.0.1700.58
Dec 27, 2013
#28 chukwuma...@gmail.com
I am having the same problem. Urgent resolution is needed. 
Dec 27, 2013
#29 krav...@chromium.org
This is got fixed in M33.We need to merge into M32 Branch.
Cc: tedchoc@chromium.org
Dec 27, 2013
#30 vino...@chromium.org
(No comment was entered for this change.)
Status: Started
Labels: -M-X M-32 ReleaseBlock-Stable Merge-Requested
Dec 29, 2013
#31 migu...@chromium.org
Some informartion to consider for the merge.

The patch only adds extra behaviour so it shoul
d not break the upload cases that used to work. The refactoring I mention in the patch is very minimal.

On the other hand this has been broken for a very long time so not sure if it qualifies for a merge.


Jan 2, 2014
#32 kar...@google.com
let's wait and have it go through normal baking process.
Labels: -Merge-Requested Merge-Rejected
Jan 3, 2014
#33 vino...@chromium.org
(No comment was entered for this change.)
Status: Fixed
Labels: -M-32 -Merge-Rejected M-33
Jan 3, 2014
#34 bugdro...@chromium.org
Is there a merge required here?
Labels: Merge-TBD
Jan 8, 2014
#35 migu...@chromium.org
(No comment was entered for this change.)
Labels: -Merge-TBD
Jan 13, 2014
#36 DanielGB...@gmail.com
I have this problem when trying to upload pics to Blogger using Chrome on Nexus 7.  My solution: use Firefox browser.  Google is losing their edge. 
Jan 24, 2014
#37 agm1...@gmail.com
This happens to me every time I attempt to post a photo comment to m.Facebook.com from Chrome
Jan 25, 2014
#38 migu...@chromium.org
You can now try this in Chrome Beta from play store 
https://play.google.com/store/apps/details?id=com.chrome.beta
Jan 27, 2014
#39 mproco...@google.com
FYI I was having this issue in Chrome 32, but things work properly in Chrome Beta 33.
Jan 28, 2014
#40 migu...@chromium.org
Issue 336851 has been merged into this issue.
Jan 28, 2014
#41 oxg...@gmail.com
Seems to be mostly fixed in Chrome Beta 33 on my stock Android 4.4.2 Nexus 10; however, the fix seems to have created an issue where some websites won't react when you choose to upload a file using the "Documents" option. It seems that some JS event is not being properly thrown unless you use the "Camera" or "Camcorder" options. If I try to upload an image on m.imgur.com/upload, it works fine when I use the "Camera" option, but if I use the "Documents" option, the page doesn't recognize when I've selected a file, and thus nothing happens. I suppose I should make a new bug report for this...
Jan 28, 2014
#42 krav...@chromium.org
 Issue 338711  has been merged into this issue.
Jan 28, 2014
#43 oxg...@gmail.com
Update: just reported the bug I described in my previous comment: https://code.google.com/p/chromium/issues/detail?id=338929
Feb 9, 2014
#44 daWild...@gmail.com
I'm using Nexus 4... File upload(<input type="file"...>) from camera works fine, but from document? I only see it working long long time ago when I just bought Nexus 4. My colleague next to me is using Nexus 5 and having same problem with google chrome. 
Feb 10, 2014
#45 Anirudha...@gmail.com
Facing similar issue
Feb 10, 2014
#46 mproco...@google.com
Hi daWildone@ and AnirudhaSharmaa@. If you would like, it would be helpful to try your repro case using Chrome Beta for Android, v33, which is available on Google Play. This bug, as noted above, we believe has been fixed in v33 Beta but it would be helpful to get some additional verification. Thanks!
Feb 10, 2014
#47 cyr...@google.com
Fixed for me (Chrome Beta 33.0.1750.70)
Feb 28, 2014
#48 beller...@gmail.com
Same issue on LG Nexus 5 D821. Cannot upload anything from suggested Documents folder via Chrome in any form that accepts files as input.
Feb 28, 2014
#49 just.pe...@gmail.com
Fixed for me on Chrome Beta 32.1750.132 on LG Nexus 5.
Sign in to add a comment

Powered by Google Project Hosting