My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 16346: Browser process hangs with cocoa exception about images
3 people starred this issue and may be notified of changes. Back to list
Status:  Verified
Owner:  darin@chromium.org
Closed:  Jul 2009
Cc:  j...@chromium.org, rohitrao@chromium.org, kr...@chromium.org

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Project Member Reported by pinkerton@chromium.org, Jul 9, 2009
- load gmail
- wait a couple seconds

It's intermittent, but fairly reproducible. In the OS console, you'll see:

Thu Jul  9 12:00:54 dhcp-172-29-45-134.her.corp.google.com Chromium[43087]
<Error>: CGImageCreate: invalid image size: 0 x 0.
2009-07-09 12:00:54.354 Chromium[43087:10b] *** Assertion failure in
-[NSBitmapImageRep initWithCGImage:],
/SourceCache/AppKit/AppKit-949.46/AppKit.subproj/NSBitmapImageRep.m:508

And then the browser process will peg at 100% cpu in the message pump. It's
unable to load pages from here on out and needs to be quit (even though you
can open new tabs, they're useless).

It's probably related to favicons and us getting a bad one somewhere and
not dealing with it correctly. Note the favicon for gmail does correctly
display in the tab. NOt sure when this regressed.
Jul 9, 2009
#1 pinkerton@chromium.org
(No comment was entered for this change.)
Labels: Regression Mstone-MacBeta
Jul 9, 2009
#2 pinkerton@chromium.org
I think this is probably related to

http://src.chromium.org/viewvc/chrome?view=rev&revision=20194

-> darin
Owner: da...@chromium.org
Jul 9, 2009
#3 brycesto...@gmail.com
Add label: Assigned.
Jul 9, 2009
#4 pinkerton@chromium.org
(No comment was entered for this change.)
Status: Assigned
Jul 9, 2009
#5 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=20327 

------------------------------------------------------------------------
r20327 | darin@chromium.org | 2009-07-09 15:25:07 -0700 (Thu, 09 Jul 2009) | 11 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/api/src/WebImageCG.cpp?r1=20327&r2=20326
   M http://src.chromium.org/viewvc/chrome/trunk/src/webkit/glue/webcursor_mac.mm?r1=20327&r2=20326

Fix custom cursors on Mac.  Null and 0 turn out not to be opposites.

I also added an assertion to webcursor_mac.mm that is probably a bit
redundant with the one in AppKit, but this way the assertion is more
visible to someone reading this file.

BUG=16346
TEST=load a page that uses a custom css cursor.
R=pinkerton

Review URL: http://codereview.chromium.org/155320
------------------------------------------------------------------------

Jul 9, 2009
#6 darin@chromium.org
(No comment was entered for this change.)
Status: Fixed
Jul 12, 2009
#7 rohitrao@chromium.org
 Issue 16513  has been merged into this issue.
Cc: kr...@chromium.org
Jul 13, 2009
#8 rohi...@chromium.org
Verified with Chromium version: 3.0.194 SVN Revision: 20513.
Status: Verified
Mar 18, 2011
#9 lafo...@chromium.org
- load gmail
- wait a couple seconds

It's intermittent, but fairly reproducible. In the OS console, you'll see:

Thu Jul  9 12:00:54 dhcp-172-29-45-134.her.corp.google.com Chromium[43087]
&lt;Error&gt;: CGImageCreate: invalid image size: 0 x 0.
2009-07-09 12:00:54.354 Chromium[43087:10b] *** Assertion failure in
-[NSBitmapImageRep initWithCGImage:],
/SourceCache/AppKit/AppKit-949.46/AppKit.subproj/NSBitmapImageRep.m:508

And then the browser process will peg at 100% cpu in the message pump. It's
unable to load pages from here on out and needs to be quit (even though you
can open new tabs, they're useless).

It's probably related to favicons and us getting a bad one somewhere and
not dealing with it correctly. Note the favicon for gmail does correctly
display in the tab. NOt sure when this regressed.
Labels: -Regression bulkmove Type-Regression
Oct 12, 2012
#10 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Mar 9, 2013
#11 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Type-Regression Type-Bug-Regression
Sign in to add a comment

Powered by Google Project Hosting