My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 160316: Cannot load NaCl on canary
13 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by mukai@chromium.org, Nov 9, 2012
Version: 25.0.1321.0 (Official Build 166868) canary
OS: 3175.0.0 (Official Build) canary-channel stumpy

What steps will reproduce the problem?
1. open SecureShell
2. Enter

What is the expected output? What do you see instead?
Stopped at "Loading NaCl plugin..."
The devtool message says "NativeClient: NaCl module load failed: ServiceRuntime: failed to start"

I also tried to boot another NaCl app (https://chrome.google.com/webstore/detail/cordy/dgjbkahdllcckjbjijejpmcgkkjpnnfk), but it also fails too.  Seems NaCl is not working at all.

Please use labels and text to provide additional information.
Nov 9, 2012
#1 mukai@chromium.org
(No comment was entered for this change.)
Cc: cstefan...@google.com erik...@chromium.org
Nov 9, 2012
#2 bradchen@chromium.org
I can repro this on the stumpy on my desk. From the JavaScript console:
  NativeClient: NaCl module load failed: ServiceRuntime: failed to start
I tried with AngryBots and with the Native Client SDK examples.
I've CCed a few folks who have been landing scary stuff lately...
Cc: bbudge@chromium.org dmichael@chromium.org brettw@chromium.org
Nov 9, 2012
#3 bradchen@chromium.org
From chrome://system chrome_user_log:
[1566:1694:1109/160011:ERROR:nacl_browser.cc(208)] Failed to open NaCl IRT file "/opt/google/chrome/nacl_ipc_irt_x86_64.nexe": -4
[1566:1566:1109/160011:INFO:CONSOLE(0)] "NativeClient: NaCl module load failed: ServiceRuntime: failed to start", source:  (0).
...
[1566:1566:1109/161314:INFO:CONSOLE(0)] "NativeClient: NaCl module load failed: ServiceRuntime: failed to start", source:  (0).

The IRT message happened only on the first load. The "failed to start" message happens with every failed load.

Nov 9, 2012
#4 bradchen@chromium.org
(No comment was entered for this change.)
Owner: bbudge@chromium.org
Nov 9, 2012
#5 bbudge@chromium.org
This makes me wonder if the IRT files are being packaged correctly. Adding Mark, who did this for the original NaCl IRT files.
Cc: mseaborn@chromium.org
Nov 9, 2012
#6 mukai@chromium.org
let me mark this as ReleaseBlock-Dev too
Labels: ReleaseBlock-Dev
Nov 9, 2012
#7 dd...@chromium.org
(No comment was entered for this change.)
Status: Assigned
Nov 9, 2012
#8 mseaborn@chromium.org
You'll need to update the file svn://svn.chromium.org/chrome-internal/trunk/chrome/installer/linux/internal/common/installer.include, assuming this file is still being used.

I made the following changes to it last year:

Add NaCl's IRT library to the Chrome .deb/.rpm package
https://chromereviews.googleplex.com/2865029/
http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=15250

Don't strip the NaCl IRT binaries
https://chromereviews.googleplex.com/2895028/
http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=15387

Nov 11, 2012
#9 bbudge@chromium.org
Added IPC IRT files to Linux installer.
https://chromereviews.googleplex.com/5763013/
Status: Fixed
Nov 13, 2012
#10 cronos...@gmail.com
I'm still seeing this on 25.0.1323.1 dev.. any idea when this will be released?
Nov 14, 2012
#11 bbu...@google.com
I had to update src-internal/DEPS to bring this change in. It should appear in the next build.
Nov 14, 2012
#12 mseaborn@chromium.org
Note that the version at https://dl.google.com/linux/direct/google-chrome-unstable_current_i386.deb doesn't contain the fix yet.  There's no nacl_ipc_irt there:

$ dpkg-deb -c dl.google.com/linux/direct/google-chrome-unstable_current_i386.deb | grep -i nacl
-rw-r--r-- root/root   2951181 2012-11-11 21:04 ./opt/google/chrome/nacl_irt_x86_32.nexe
-rw-r--r-- root/root    516300 2012-11-11 21:04 ./opt/google/chrome/libppGoogleNaClPluginChrome.so
-rwxr-xr-x root/root      8688 2012-11-11 21:04 ./opt/google/chrome/nacl_helper_bootstrap
-rw-r--r-- root/root   3207231 2012-11-11 21:04 ./opt/google/chrome/nacl_irt_x86_64.nexe
-rwxr-xr-x root/root    803940 2012-11-11 21:04 ./opt/google/chrome/nacl_helper

It can take a while for that package to be updated, because there's no Linux Chrome Canary build.

BTW, the fact that that package contains both x86_32 and x86_64 versions of the IRT is a bug.

Bill, how do you know that when this package is fixed, Chrome OS will be fixed too?  I said that I didn't remember having to make any changes to the Chrome OS build to get the IRT packaged for Chrome OS last year (when the IRT was introduced), but maybe someone else made a change.
Nov 14, 2012
#13 mseaborn@chromium.org
"BTW, the fact that that package contains both x86_32 and x86_64 versions of the IRT is a bug." - I have filed  issue 160988  for that.
Nov 14, 2012
#14 bbu...@google.com
I actually don't know that my changes will fix this bug. If there is a "secret" installer file somewhere that has to be modified, then the next version will still be broken. I do have src-internal in my gclient file and I grepped for 'nacl_irt_' and didn't see any other files, so I'm hopeful.
Nov 14, 2012
#15 bugdro...@chromium.org
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=30718

------------------------------------------------------------------------
r30718 | bbudge@google.com | 2012-11-11T20:57:43.445411Z

------------------------------------------------------------------------
Nov 14, 2012
#16 bugdro...@chromium.org
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=30749

------------------------------------------------------------------------
r30749 | bbudge@google.com | 2012-11-13T00:55:45.462914Z

------------------------------------------------------------------------
Nov 14, 2012
#17 mseaborn@chromium.org
It looks like you will need to change chromeos-base/chromeos-chrome/chromeos-chrome-9999.ebuild in the chromiumos/overlays/chromiumos-overlay.git repo:
http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=blob;f=chromeos-base/chromeos-chrome/chromeos-chrome-9999.ebuild;h=850c7ca21c9c99a9f1bdbb05f82dff8d8b631e38;hb=HEAD

It contains this code:

1106         # add non-executable NaCl files
1107         if use_nacl; then
1108                 doins "${FROM}"/nacl_irt_*.nexe || die
1109                 doins "${FROM}"/nacl_helper || die
1110         fi

It looks like someone *did* fix Chrome OS to include the IRT without telling me. :-)
Status: Assigned
Nov 14, 2012
#18 bbu...@google.com
Can we find out who is responsible for this? It sounds like they can fix it much better and faster than I can.
Nov 14, 2012
#19 mseaborn@chromium.org
How about you rename the IRT files so that the default IRT is always called "nacl_irt_$arch.nexe"?  You can rename the old IRT to "nacl_srpc_irt_$arch.nexe".  Then the packaging doesn't need to be changed for NaCl to work.  The packaging only needs to be changed for a user to be able to run the non-default configuration.
Nov 14, 2012
#20 mseaborn@chromium.org
@Bill: The IRT was originally added to Chrome OS in this change:
http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=commitdiff;h=938ae4ce58ae061cf9500a2f8fa2ad9dec3e988a
"Added NaCl binaries to chrome ebuild file" (Zelidrag Hornung <zelidrag@chromium.org>)
Nov 14, 2012
#21 mukai@chromium.org
then isn't it a single line patch like https://gerrit.chromium.org/gerrit/#/c/38057/ ?
Nov 14, 2012
#22 mukai@chromium.org
adding zel just in case
Cc: zelidrag@chromium.org
Nov 14, 2012
#23 yoz@chromium.org
 Issue 160842  has been merged into this issue.
Nov 14, 2012
#24 bugdro...@chromium.org
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=167787

------------------------------------------------------------------------
r167787 | bbudge@chromium.org | 2012-11-15T00:30:31.012576Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/tools/build/win/FILES.cfg?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/installer/mini_installer.gypi?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/tools/build/chromeos/FILES.cfg?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/tools/build/linux/FILES.cfg?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/chrome_dll.gypi?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/nacl_host/nacl_browser.cc?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/chrome_installer.gypi?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/installer/mini_installer/chrome.release?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/ppapi/native_client/native_client.gyp?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/installer/mini_installer.gyp?r1=167787&r2=167786&pathrev=167787
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/nacl.gypi?r1=167787&r2=167786&pathrev=167787

Change the names of the NaCl IRT files to solve ChromeOS packaging issue.
The old SRPC IRT nexes now take the form 'nacl_irt_srpc_*', while the new IPC
IRT nexes take the form 'nacl_irt_*'.
BUG=116317,160316
TEST=builds
Review URL: https://codereview.chromium.org/11275326
------------------------------------------------------------------------
Nov 14, 2012
#25 bugdro...@chromium.org
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=167810

------------------------------------------------------------------------
r167810 | ddrew@chromium.org | 2012-11-15T01:24:53.161312Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/tools/build/chromeos/FILES.cfg?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/tools/build/linux/FILES.cfg?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/chrome_dll.gypi?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/browser/nacl_host/nacl_browser.cc?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/chrome_installer.gypi?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/installer/mini_installer/chrome.release?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/ppapi/native_client/native_client.gyp?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/installer/mini_installer.gyp?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/nacl.gypi?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/tools/build/win/FILES.cfg?r1=167810&r2=167809&pathrev=167810
   M http://src.chromium.org/viewvc/chrome/branches/1324/src/chrome/installer/mini_installer.gypi?r1=167810&r2=167809&pathrev=167810

Merge 167787 - Change the names of the NaCl IRT files to solve ChromeOS packaging issue.
The old SRPC IRT nexes now take the form 'nacl_irt_srpc_*', while the new IPC
IRT nexes take the form 'nacl_irt_*'.
BUG=116317,160316
TEST=builds
Review URL: https://codereview.chromium.org/11275326

TBR=bbudge@chromium.org
Review URL: https://codereview.chromium.org/11312258
------------------------------------------------------------------------
Labels: merge-merged-1324
Nov 15, 2012
#26 bradchen@chromium.org
This morning my stumpy auto-updated; I'm still seeing the same failure.
Google Chrome: 25.0.1325.0 (Official Build 167602) canary.
Platform: 3203.0.0

From about:system chrome_user_log: "[...] Failed to open NaCl IRT file "/opt/google/chrome/nacl_ipc_irt_x86_64.nexe": -4

From go/chromeos-images it looks like 3203.0.0 was built on Wednesday 14 Nov at 17:55pm, and includes Chromium revisions through r167602, so it doesn't include Bill's change at r167787 that should hopefully fix this.
Nov 15, 2012
#27 mukai@chromium.org
Confirmed that this is fixed at 25.0.1326.0 (Official Build 167880) canary
Nov 15, 2012
#28 bugdro...@chromium.org
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=30881

------------------------------------------------------------------------
r30881 | bbudge@google.com | 2012-11-15T18:53:34.153092Z

------------------------------------------------------------------------
Nov 15, 2012
#29 bugdro...@chromium.org
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=30883

------------------------------------------------------------------------
r30883 | bbudge@google.com | 2012-11-15T19:24:59.776748Z

------------------------------------------------------------------------
Nov 15, 2012
#31 abod...@chromium.org
no more "NativeClient: NaCl module load failed: ServiceRuntime: failed to start" error

But We can see "Failed to load resource" error on JS console with reproduce steps from the bug. 
Chrome OS:3196.1.0/chrome:25.0.1324.1
Nov 15, 2012
#32 mukai@chromium.org
I think that's a different issue.  Secure Shell is working correctly on my environment and it shows the same error message of "Failed to load resources".

Also please try another app using NaCl, like https://chrome.google.com/webstore/detail/cordy/dgjbkahdllcckjbjijejpmcgkkjpnnfk

Here is my environment:
chrome: 25.0.1326.0 (Official Build 167880) canary
os: 3207.0.0 (Official Build) canary-channel stumpy
secure shell version: 0.8.7

Nov 15, 2012
#33 tturche...@chromium.org
(No comment was entered for this change.)
Cc: ka...@chromium.org
Nov 15, 2012
#34 abod...@chromium.org
Verified on TOT, its working as excepted 

Google Chrome	25.0.1326.0 (Official Build 167880) dev
Platform	3207.0.0 (Official Build) dev-channel parrot
WebKit	537.19 (@134630)
JavaScript	V8 3.15.3

Secure Shell (dev) version 0.8.8.6
Nov 16, 2012
#35 vapier@chromium.org
not specific to ChromeOS.  my current Goobuntu is also broken.

be nice if the canary builds could be manually bumped when there are known bugs in them that can make them unusable for a good number of devs rather than just waiting for the next timebased canary snapshot.
Labels: OS-Linux
Nov 17, 2012
#36 jmeu...@google.com
I have the same issue on Ubuntu Precise with 25.0.1323.1 dev.  Secure Shell does not work.  I tried Cordy as suggested and it fails with the same console error.
Nov 21, 2012
#37 mukai@chromium.org
Side note: I noticed another issue on SecureShell in the latest dev channel.
I found a note at https://groups.google.com/a/chromium.org/forum/#!msg/chromium-hterm/8xot9dw6tSw/cNkaC-6ghPoJ
> Top of the tree Chrome has issue with DNS host resolution in Secure Shell. So you can try to use IP address instead of hostname to check if it is know issue with host resolution. We are working on the solution for the problem.

So it'll be stuck *after* "loading" of NaCl has finished.

I don't know how this bug is tracked, but anyway it's a separate issue.  It's better to verify this issue with another NaCl app, such like Cordy game (https://chrome.google.com/webstore/detail/cordy/dgjbkahdllcckjbjijejpmcgkkjpnnfk)
Nov 21, 2012
#39 bbudge@chromium.org
This should be fixed. I'm merging it to 161757 because it's so similar.
Status: Duplicate
Mergedinto: 161757
Nov 26, 2012
#40 bugdro...@chromium.org
The following revision refers to this bug:
    http://goto.ext.google.com/viewvc/chrome-internal?view=rev&revision=31139

------------------------------------------------------------------------
r31139 | bbudge@google.com | 2012-11-26T22:10:29.417960Z

------------------------------------------------------------------------
Jan 8, 2013
#41 tturche...@chromium.org
(No comment was entered for this change.)
Cc: abod...@chromium.org
Mar 10, 2013
#42 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-UI -Feature-NaCl -Mstone-25 Cr-Platform-NaCl Cr-UI M-25
Sign in to add a comment

Powered by Google Project Hosting