My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 160128: Plugins get clubbed in "PDF" after issuing Ctrl+P command
3 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by mbo...@chromium.org, Nov 8, 2012
Chrome Version       : <from About Google Chrome/Chromium> 25.0.1320.0 
URLs (if applicable) :
OS version               : <from About This Mac> Mac 10.8.2
Behavior in Safari 3.x/4.x (if applicable):
Behavior in Firefox 3.x (if applicable):
Behavior in Chrome for Windows: Reproducible

What steps will reproduce the problem?
1. Start Chrome.
2. Go to chrome://plugins
3. You will see all plugins installed.
4. Open new tab and go to any web page.
5. Ctrl+P. Print Preview opens.
6. Go to chrome ://plugins and refresh page.

What is the expected result?
Same as Step 3.

What happens instead?
Most of the plugins go under PDF section. See attachment.

Reproducible on 25.0.1317.0
Reproducible on 24.0.1312.5
Not reproducible on 23.0.1271.64 

Regression window:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=157509:164863&mode=html

I will update the bisect info.
Nov 8, 2012
#1 mbo...@chromium.org
(No comment was entered for this change.)
Screen Shot 2012-11-08 at 1.40.35 PM.png
75.8 KB   View   Download
Labels: -Type-Bug Type-Regression
Nov 8, 2012
#2 megazzt
I am seeing Silverlight, the Chrome Remote Desktop Host, and the Native Client plugin under there.  The problem occurs even if the print dialog is closed (I am not sure it wasn't occurring before it was open) or if the tab that had it was closed, or if you close and reopen the plugins tab... etc.

Mine is also a lowercase "pdf" instead of "PDF".

Flash, Java, the Remote Desktop Client plugin, Adobe Reader, and the REAL PDF plugin are all in their proper groups.

24.0.1312.5 Dev, Windows 7 SP3 x64.
Nov 8, 2012
#3 mbo...@chromium.org
Yes, on windows 7 it's shown as you mentioned.
Nov 9, 2012
#4 mbo...@chromium.org
Bad build: 24.0.1290.0
Good build: 24.0.1289.1

Unable to give bisect info as print preview not present on chromium builds.

This is the closest range I could find for regression window:
http://build.chromium.org/f/chromium/perf/dashboard/ui/changelog.html?url=/trunk/src&range=160583:160763&mode=html
Nov 12, 2012
#5 mark@chromium.org
Looks like r160653 fsamuel or r160660 ibraaaa.
Status: Assigned
Owner: fsam...@chromium.org
Cc: fsam...@chromium.org ibra...@google.com
Labels: -OS-Mac -Mstone-25 -ReleaseBlock-Beta -OS-Windows OS-All Mstone-24 ReleaseBlock-Stable
Nov 12, 2012
#6 bauerb@chromium.org
(No comment was entered for this change.)
Cc: -ibra...@google.com ibra...@gmail.com
Nov 12, 2012
#7 bauerb@chromium.org
(No comment was entered for this change.)
Cc: bauerb@chromium.org
Nov 13, 2012
#8 bauerb@chromium.org
This might also be fixed by https://codereview.chromium.org/11364202.
Labels: Feature-PrintPreview
Nov 13, 2012
#9 ibra...@gmail.com
Hi Bernhard,

How can I trigger the print preview on chromium? ctrl+p works fine for
chrome but on chromium it opens the system's print dialog.
Nov 13, 2012
#10 bauerb@chromium.org
Yeah, that's the problem -- Print Preview requires the PDF plug-in, which isn't part of Chromium :(

Installing a recent (Dev channel) version of Chrome and using the plug-in from there with --register-pepper-plugins="/opt/google/chrome/libpdf.so;application/x-google-chrome-print-preview-pdf" *might* work.
Nov 13, 2012
#11 abodenha@chromium.org
You can copy in the PDF plugin from a Chrome installation and run Chromium with --enable-print-preview.
Nov 15, 2012
#12 fsam...@chromium.org
Unassigning myself as OWNER as I'm unfamiliar with this code.
Owner: ---
Nov 15, 2012
#13 bauerb@chromium.org
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 159902
Mar 9, 2013
#14 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-UI -Type-Regression -Feature-Plugins -Mstone-24 -Feature-PrintPreview Type-Bug-Regression Cr-UI M-24 Cr-Content-Plugins Cr-UI-Browser-PrintPreview
Apr 5, 2013
#15 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: Cr-Blink
Apr 5, 2013
#16 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content-Plugins Cr-Internals-Plugins
Sign in to add a comment

Powered by Google Project Hosting