My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 157723: Pages do not load on the first attempt.
4 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by deep...@chromium.org, Oct 24, 2012
Chrome Version     :  24.0.1303.0
OS Version         :  3078.0.0
Type of computer   :  All Platforms
Network info       :  Wifi

Please specify Area- Network

Steps I followed when I saw this issue:
1. Connect to GoogleGuest or any good open network.
2. Suspend the device for a while and resume it.
3. Load a webpage, say "www.yahoo.com".

What is the expected output?
The page should load if the network doesn't have any issues.

What do you see instead?
The page does not load on the first attempt. We get the "Your device offline" page with "Try loading the page anyway" link. Clicking on this link will load the page.

How frequently does this problem reproduce? (Always, sometimes, hard to
reproduce?)
Sometimes. We don't have any good reproduction steps.

What is the impact to the user, and is there a workaround? If so, what is
it?
The user has to reboot the device for it to start behaving normally again.

Please provide any additional information below.
Logs will be attached.

Oct 29, 2012
#2 Kusc...@chromium.org
@Trond, something you are looking into I believe.

@LaForge, should we get a Feature-Network or so label in Chromium? Do we have something similar?
Status: Assigned
Owner: tr...@chromium.org
Cc: lafo...@chromium.org zelidrag@chromium.org
Labels: Feature-Network
Oct 29, 2012
#3 tr...@chromium.org
+gauravsh who is leading the CONFUSE investigation
Owner: gauravsh@chromium.org
Cc: tr...@chromium.org gregsimon@chromium.org stevenjb@chromium.org
Oct 29, 2012
#4 lafo...@google.com
We have Internals-Network.
Labels: -Feature-Network Internals-Network
Oct 29, 2012
#6 xiaow...@chromium.org
(No comment was entered for this change.)
Cc: xiaow...@chromium.org
Labels: confuse
Oct 31, 2012
#7 dd...@chromium.org
(No comment was entered for this change.)
Labels: -Mstone-24 bulkmove MovedFrom-24 Mstone-25
Nov 1, 2012
#8 xiaow...@chromium.org
(No comment was entered for this change.)
Labels: Iteration-68
Nov 6, 2012
#10 gauravsh@chromium.org
I don't see anything of interest in the net-internals dump. Did you collect it while having the problem reported in #1?
Nov 12, 2012
#11 ps...@google.com
Issue chrome-os-partner:16125 has been merged into this issue.
Cc: jaso...@google.com patri...@google.com tr...@google.com zelid...@google.com joshwood...@google.com vw...@google.com t...@google.com yongj...@google.com caes...@google.com
Nov 12, 2012
#12 deep...@chromium.org
Yes, this was collected when I saw the issue.
Nov 13, 2012
#13 xiaow...@chromium.org
(No comment was entered for this change.)
Labels: Iteration-69
Nov 20, 2012
#14 bugdro...@chromium.org
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=168961

------------------------------------------------------------------------
r168961 | gauravsh@chromium.org | 2012-11-21T04:02:37.397002Z

Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/chromeos/net/network_change_notifier_chromeos.cc?r1=168961&r2=168960&pathrev=168961

Also update active network state in response to manager events

NetworkChangeNotifierChromeos currently relies on service
property signals from shill to handle state changes on active
network once the active network has been added. Under certain
circumstances, we may not get correctly notified of these
service-specific signals.

So, be a bit more robust and have NCNCros opportunistically update
the active network state from manager updates instead
of just relying on service signals.

BUG=chromium-os:34399, chromium:157723



Review URL: https://chromiumcodereview.appspot.com/11420076
------------------------------------------------------------------------
Nov 26, 2012
#15 gauravsh@chromium.org
Issue 150606 has been merged into this issue.
Cc: pstew@chromium.org gauravsh@chromium.org wi...@chromium.org r...@chromium.org cbentzel@chromium.org quiche@chromium.org gspencer@chromium.org gauravsh@chromium.org pauljensen@chromium.org mmenke@chromium.org r...@google.com qui...@google.com james...@google.com
Nov 26, 2012
#16 gauravsh@chromium.org
See also: crosbug.com/34399 for details on the dbus-related fixes.
Status: Fixed
Dec 6, 2012
#17 abod...@chromium.org
Chrome OS:3359.0.0/Chrome:25.0.1351.0
Status: Verified
Mar 9, 2013
#18 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Type-Bug -Regression Type-Bug-Regression
Mar 9, 2013
#19 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-UI -Internals-Network -Mstone-25 Cr-UI Cr-Internals-Network M-25
Sign in to add a comment

Powered by Google Project Hosting