My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 15334: Completion popups don't redraw correctly
3 people starred this issue and may be notified of changes. Back to list
Status:  Verified
Owner:  avi@chromium.org
Closed:  Jul 2009

Restricted
  • Only users with Commit permission may comment.


Sign in to add a comment
 
Project Member Reported by thakis@chromium.org, Jun 25, 2009
Chrome Version       : 3.0.190.0
URLs (if applicable) :
OS version               : 10.5.7
Behavior in Safari 3.x/4.x (if applicable): Works fine

What steps will reproduce the problem?
1. Go to a website with a text field that remembers its input (e.g. 
crbug.com)
2. Enter a few characters

What is the expected result?

As more characters are entered, the completion menu should get shorter.

What happens instead?

The completion menu _does_ get shorter, but it doesn't get redrawn 
correctly: The long completion menu is still visible in the background.

Screenshots attached (you might need to rename them to .png)
Picture 40
14.1 KB   View   Download
Picture 41
12.8 KB   View   Download
Jul 2, 2009
#1 mikesm...@chromium.org
(No comment was entered for this change.)
Labels: Mstone-MacBeta
Jul 8, 2009
#2 mikesm...@chromium.org
(No comment was entered for this change.)
Status: Duplicate
Jul 10, 2009
#3 thakis@chromium.org
Duplicate of what other bug? I tried to find the original, but couldn't find it.
Jul 10, 2009
#4 thakis@chromium.org
Reopening, because no dup bug # was entered.
Status: Untriaged
Jul 14, 2009
#5 thakis@chromium.org
Ah, this is probably a dupe of the "find bar paints badly when scrolling" bug.
Status: Duplicate
Mergedinto: 16124
Jul 15, 2009
#6 thakis@chromium.org
No, this is still broken, while the find bar repaints fine by now.
Status: Untriaged
Mergedinto: -16124
Jul 17, 2009
#7 rohitrao@chromium.org
 Issue 13020  has been merged into this issue.
Jul 17, 2009
#8 avi@chromium.org
This is a consequence of our creation story for RenderWidgetHostViewMacs, related to
http://crbug.com/8285. My code; taking.
Owner: a...@chromium.org
Jul 17, 2009
#9 bugdroid1@gmail.com
The following revision refers to this bug:
    http://src.chromium.org/viewvc/chrome?view=rev&revision=20959 

------------------------------------------------------------------------
r20959 | avi@chromium.org | 2009-07-17 09:53:22 -0700 (Fri, 17 Jul 2009) | 6 lines
Changed paths:
   M http://src.chromium.org/viewvc/chrome/trunk/src/chrome/browser/renderer_host/render_widget_host_view_mac.mm?r1=20959&r2=20958

Implement SetSize for valid size requests.

BUG=http://crbug.com/15334
TEST=type in a popup containing more than one item; as the number of items decreases, the list should properly shrink and draw itself.

Review URL: http://codereview.chromium.org/155694
------------------------------------------------------------------------

Jul 17, 2009
#10 avi@chromium.org
Done.
Status: Fixed
Jul 20, 2009
#11 deep...@chromium.org
3.0.195.0 rev: 21075
Status: Verified
Oct 11, 2012
#12 bugdro...@chromium.org
This issue has been closed for some time. No one will pay attention to new comments.
If you are seeing this bug or have new data, please click New Issue to start a new bug.
Labels: Restrict-AddIssueComment-Commit
Sign in to add a comment

Powered by Google Project Hosting