My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 150937: Empty lines when caption size is 0%
1 person starred this issue and may be notified of changes. Back to list
Status:  Fixed
Owner:  ----
Closed:  Jan 2013
Cc:  silvi...@chromium.org, vcarb...@chromium.org


Sign in to add a comment
 
Project Member Reported by yiho...@chromium.org, Sep 19, 2012
Version: 23.0.1270.0 (Official Build 157306) canary
OS: Mac

What steps will reproduce the problem?
1. Go to https://www.corp.google.com/~yihongg/testmatrix/index.html?track=1
2. Select buck2.webm
3. Select captions/size/en, check default, add the track

What is the expected output? What do you see instead?

Caption show nicely when size is 0%. Instead, it shows one word per line and one empty line between two word lines. It would be good to remove the empty lines.

Please use labels and text to provide additional information.

WEBVTT

1
00:00:00.000 --> 00:00:30.000 size:0%
One word per line

2
00:00:31.000 --> 00:00:40.000 size:100%
The cue size should be equal to the video width. The cue size should be equal to the video width. The cue size should be equal to the video width. The cue size should be equal to the video width. 

3
00:00:41.000 --> 00:00:50.000 size:50%
The cue size should be half of the video width. The cue size should be half of the video width. The cue size should be half of the video width. The cue size should be half of the video width.


Screen shot 2012-09-19 at 5.56.21 PM.png
606 KB   View   Download
Sep 28, 2012
#1 silvi...@chromium.org
(No comment was entered for this change.)
Cc: silvi...@chromium.org
Oct 2, 2012
#2 yiho...@chromium.org
(No comment was entered for this change.)
Labels: track
Oct 10, 2012
#3 ka...@chromium.org
Moving all non essential bugs to the next Milestone
Labels: -Mstone-23 MovedFrom-23 Mstone-24
Oct 24, 2012
#4 victor.carbune
This issue comes from using white-space:pre-wrap in the Shadow DOM CSS for cues (and it should not be at all specified).
Oct 24, 2012
#5 silvi...@google.com
Cues lines indeed need no white-space property. When fixing this, just note that the spec says to use pre-line on the root cue div.

Oct 29, 2012
#6 scherkus@chromium.org
(No comment was entered for this change.)
Status: Available
Labels: -Pri-2 -MovedFrom-23 -Mstone-24 Pri-3 Mstone-25
Oct 29, 2012
#7 scherkus@chromium.org
(No comment was entered for this change.)
Labels: -track Feature-Media-Track
Oct 29, 2012
#8 scherkus@chromium.org
(No comment was entered for this change.)
Labels: -Feature-Media
Jan 7, 2013
#9 kerz@google.com
Punting non-releaseblocking bugs in M25.  You can find the list via MovedFrom-25
Labels: -Mstone-25 Mstone-26 MovedFrom-25
Jan 18, 2013
#10 vcarb...@chromium.org
This bug has been fixed by applying word-break: break-word in
http://trac.webkit.org/changeset/138282

For applying properly white-space: pre-line, a different bug is here:
https://bugs.webkit.org/show_bug.cgi?id=79916
CaptionOnMultipleLines.png
92.1 KB   View   Download
Status: Fixed
Cc: vcarb...@chromium.org
Mar 10, 2013
#11 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Area-WebKit -Feature-Media-Track -Mstone-26 Cr-Content M-26 Cr-Internals-Media-Track
Apr 5, 2013
#12 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content Cr-Blink
Sign in to add a comment

Powered by Google Project Hosting