My favorites | Sign in
Project Home Downloads Wiki Issues Code Search
New issue   Search
for
  Advanced search   Search tips   Subscriptions
Issue 128870: Pepper flash broken audio
35 people starred this issue and may be notified of changes. Back to list
 
Project Member Reported by f...@sofaraway.org, May 19, 2012
When using the Pepper Flash plugin on Ubuntu, the sound of most flash videos is broken (all jerky, kind of metallic and sometimes going twice as fast as expected).

In the console, i always get a few:
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream

I can reproduce with most youtube videos, and on different computers.
Also reproducible with Chromium trunk.

I notice that when it's broken, the stream/app is not visible in the Gnome Sound Settings / Applications tab. It's supposed to be called "ALSA plug-in [chromium-browser]" in there. It's sometimes appears very briefly (or flashing very fast).

If i disable the Pepper flash (it's a 11.2.* btw) and use the system flash instead (NPAPI, also 11.2.*), it's all fine for the same videos.

May 19, 2012
#1 piman@chromium.org
(No comment was entered for this change.)
Cc: viettrun...@chromium.org
May 27, 2012
#2 rktesser
I seem to be having the same problem. Specifically, my issue is similar to what was reported in  Issue 54224 . That is, the problem disappears when I disable the integrated Flash plugin. It may not be the same problem (that issue is form 2010), but the symptoms and workaround are similar.
May 27, 2012
#3 rktesser
Some info I forgot to put in my comment:
Operating System: Ubuntu 12.04
Google Chrome version 20.0.1132.17 beta
PulseAudio version: 20.0.1132.17 beta

May 29, 2012
#4 cherrot...@gmail.com
I exactly have the same issue :(
google-chrome 20.0.1132.17 beta
flash-plugin 11
Ubuntu 11.10 with gnome-shell
Jun 12, 2012
#5 lars.ot...@gmail.com
Same here. I have actually had this issue for a few weeks now. Temporary workaround for me is to disable the PepperFlash under chrome://plugins and go back to the stand-alone libflashplayer.so from Adobe.

Xubuntu 12.04 LTS

$ google-chrome --version
Google Chrome 20.0.1132.27 bet
$ pulseaudio --version
pulseaudio 1.1

Jun 13, 2012
#6 pde...@gmail.com
Disabling PepperFlash fixed it for me too

$ cat /etc/issue.net 
Ubuntu 12.04 LTS
$ pulseaudio --version
pulseaudio 1.1
$ google-chrome --version
Google Chrome 20.0.1132.27 beta

Jun 13, 2012
#7 cherrot...@gmail.com
I also disabled PepperFlash through chrome://plugins
It works fow now :)
Aug 6, 2012
#8 rhuddusa
i'm running a system halfway upgraded from ubuntu-lucid to ubuntu-precise, but all the sound libs are precise

i'm seeing a ton of these lines in xsession-errors
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream

perhaps this might help, i don't believe chrome should be using any alsa components when running through pulseaudio.  

when playing an mp3 with vlc, i get
sudo lsof +D /usr/lib | grep -i vlc | grep -e pulse -e alsa
vlc       16374   mem    REG  252,0   385240  663060 /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
vlc       16374   mem    REG  252,0   294704  663061 /usr/lib/x86_64-linux-gnu/libpulse.so.0.13.5

but chrome is doing this
sudo lsof +D /usr/lib | grep -i chrome | grep -e pulse -e alsa
chrome    10644   mem    REG  252,0    27248  917575 /usr/lib/x86_64-linux-gnu/alsa-lib/libasound_module_pcm_pulse.so
chrome    10644   mem    REG  252,0   385240  663060 /usr/lib/x86_64-linux-gnu/libpulsecommon-1.1.so
chrome    10644   mem    REG  252,0   294704  663061 /usr/lib/x86_64-linux-gnu/libpulse.so.0.13.5

i don't think chrome should be accessing libasound_module_pcm_pulse.so
Aug 8, 2012
#9 rhuddusa
this might also explain why i get a line 
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
written to my .xsession-errors every second or so
Aug 9, 2012
#10 dnpa...@gmail.com
Another vote for disabling PepperFlash. Worked for me. 
Ubuntu 12,04
Chrome Version 21.0.1180.75 

Enabled:
Version:	11.2 r202
Location:	/usr/lib/flashplugin-installer/libflashplayer.so

Disabled:
Version:	11.3.31.225
Location:	/opt/google/chrome/PepperFlash/libpepflashplayer.so

Aug 12, 2012
#11 mbl...@mbligh.org
Broken for me too. Please turn off Pepper by default until it's better tested.
Sep 17, 2012
#13 saverio...@gmail.com
I am also affected by this; disabling pepperflash stopped the clicking noise.

$ google-chrome --version
Google Chrome 21.0.1180.89 

$ uname -a
Linux nc10 3.2.0-30-generic #48-Ubuntu SMP Fri Aug 24 16:54:40 UTC 2012 i686 i686 i386 GNU/Linux

Oct 2, 2012
#14 jamiek...@gmail.com
I seem to be affected by this same problem: a "click" sound (or gentle "pop") every second or two whenever I have Gmail open in a Chrome tab. If I close my Gmail tabs, I hear nothing.

Disabling /opt/google/chrome/PepperFlash/libpepflashplayer.so and restarting Chrome seems a valid workaround so far.

I'm running the Chrome beta channel updates on Xubuntu 11.10:

$ google-chrome --version
Google Chrome 22.0.1229.91 beta

$ uname -a
Linux jkrug-laptop 3.0.0-26-generic #42-Ubuntu SMP Wed Sep 5 08:37:08 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
Oct 10, 2012
#15 dbarn...@google.com
I have this same audio distortion / Sound Settings issue. Here's a wav recording of the audio as I hear it for http://www.youtube.com/watch?v=MSanNzzKphQ.
MSanNzzKphQ_popping.wav
1.4 MB   Download
Oct 10, 2012
#16 piman@chromium.org
Disabling PulseAudio helped a lot for me.
Oct 10, 2012
#17 mbl...@mbligh.org
What are the chances of waking up the people on the Pepper team to actually fix this?

It seems like it's been broken since before it was released, and nobody is doing anything.
Oct 17, 2012
#18 g...@google.com
I just upgraded from ubuntu Lucid to Precise and am seeing the same damn thing running Google Chrome Version 23.0.1271.26 beta.

This is the Chrome out of box experience on Precise?  WTF.  Completely Broken and unusable.
Oct 19, 2012
#19 viettrun...@chromium.org
Since Pepper Flash just goes through Chrome's stack, it's a pure Chrome problem.
Cc: scherkus@chromium.org
Labels: Feature-Media-Audio
Oct 19, 2012
#20 scherkus@chromium.org
+dalecurtis knows the latest status on Chrome+Alsa+PulseAudio interactions
Cc: dalecur...@chromium.org
Oct 19, 2012
#21 dalecur...@chromium.org
Hmm, I had a similar (same?) problem locally that xians fixed recently, issue 152323:

http://codereview.chromium.org/11019010/

@gps, that patch resolved all the gPrecise issues I was seeing (and should be in the M23 beta you listed).  Are you using a custom audio configuration?
Oct 31, 2012
#22 devuran...@gmx.net
I have the same issue on Gentoo/Linux with www-client/google-chrome-23.0.1271.40_beta162221 and media-sound/pulseaudio-2.1-r1 on Kernel 3.6.4. I also had the same distorted audio with older versions of Chrome, PulseAudio and Linux. YouTube/HTML5 and www-plugins/adobe-flash-11.2.202.243 work without issues. See also:  bug #136624 
Oct 31, 2012
#23 g...@google.com
My issue appears to go beyond Chrome and PepperFlash.  I can reproduce it using the flash plugin in Mozilla Firefox as well.   It sounds like there are multiple issues piling on one another here.
Oct 31, 2012
#24 piman@chromium.org
(No comment was entered for this change.)
Cc: -piman@chromium.org
Nov 12, 2012
#25 bg.bar...@gmail.com
Workaround which works for me:

1) Create an ~/.asoundrc with selects your _real_ soundcard for alsa. http://alsa.opensrc.org/FAQ026

2) Use "pasuspender -- google-chrome" to suspend pulseaudio while chrome is running. Chrome will now fall back to alsa, and avoid the pulseaudio-alsa-bridge since you set your real hw as default in 1).

While chrome will play music well, no other application using pulseaudio (which is suspended/muted) will play sound.
Nov 13, 2012
#26 mbl...@mbligh.org
Why not just turn off pepper? Seems much easier.
Dec 10, 2012
#27 devuran...@gmx.net
Re: comment #22:
This might have some relation to PulseAudio's tsched=0, which I now found I had enabled in my /etc/pulse/default.pa. (I don't remember when I did this - whether before or after I reported this bug). I removed tsched=0 and my Chrome PepperFlash sound distortion problem is gone.
Jan 17, 2013
#28 dalecur...@chromium.org
(No comment was entered for this change.)
Status: Duplicate
Mergedinto: 116435
Mar 11, 2013
#29 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Feature-Plugins-Pepper -Feature-Media-Audio Cr-Content-Plugins-Pepper Cr-Internals-Media-Audio
Mar 23, 2013
#30 bg.bar...@gmail.com
Re: Comment #27

I can confirm that removing tsched=0 from default.pa in /etc/pulse solves this issue.
Thanks for the hint.

This obviously does not work for people which require tsched=0 because of driver/hardware bugs.
Apr 5, 2013
#31 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: Cr-Blink
Apr 5, 2013
#32 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: Cr-Internals-Plugins
Apr 5, 2013
#33 bugdro...@chromium.org
(No comment was entered for this change.)
Labels: -Cr-Content-Plugins-Pepper Cr-Internals-Plugins-Pepper
Jan 22, 2014
#34 practica...@googlemail.com
I can no longer create ecards on jibjab website which I am subscribed to and love using!  
When will this be resolved??



Jan 22, 2014
#35 dbarn...@google.com
Huh, my symptoms stopped a long time ago. In fact, Pepper flash seems to be the only one that works anymore. I had to disable the Adobe libflashplayer.so because Flash videos would blank out and become unclickable every time I switched away to a different tab.

Are you sure you have Pepper flash enabled and the other plugin disabled? What version of Ubuntu are you running?
Jan 23, 2014
#36 melind...@gmail.com
I have recently been experiencing problems viewing Jib Jab ecards using Chrome.  I have not been able to view them if they are posted on Facebook either.  The picture shows up but when the play button is clicked the screen turns black - the sound works but not picture.  If I switch to Safari, I find that it works.

I am running OS X 10.9.1 on a Mac Book.  I just upgraded my OS but Chrome flash didn't work prior to the upgrade either.

How might I resolve this?
Jan 23, 2014
#37 dmichael@chromium.org
@#34 and #36
This bug referred to Ubuntu Linux. It sounds like you are having a different problem. Could you file a new bug at:
crbug.com/new
?
That will automatically put information about your version of Chrome in the bug. When you've done that, you can comment again here with that issue number, and I'll triage it.

Thanks for reporting!
Sign in to add a comment

Powered by Google Project Hosting